Skip navigation
smbPTC
Currently Being Moderated

Buttons that trigger forms fields in InDesign 5.5

Apr 10, 2012 12:40 PM

Tags: #acrobat #pdf #buttons #indesign #form #fields

Hello,

 

I have a 13 page InDesign doc that has hyperlinked text and buttons. When I export as an interactive PDF, I get the purple/pink form field bar at top. I have spent 8 hours trying to trouble shoot the issue (I have previously worked on similar 6+ layouts with same buttons and no issue). The buttons are designed to look like nav buttons along bottom of page. They have rollover states. They are on 2 master pages (one is cover and other is single-page master). The issue is on the single-page master. If I delete the buttons from this master, the form filed goes away. I have tried many, many other scenarios to fix this bug but no success. I did see that this was an issue as far back as 2008. Nothing seems to have been fixed. Any ideas?

 
Replies
  • Currently Being Moderated
    Apr 10, 2012 12:53 PM   in reply to smbPTC

    Correct me if I am wrong - InDesign does not natively export Live Forms; the exported file requires the Form Wizard to be run.

    Including Interactive Elements was correct, and they maintained their interactive states, excepting buttons on a certain master?

     

    Can you override them to the live page or move them to a higher layer than the page elements?

     
    |
    Mark as:
  • George Johnson
    11,703 posts
    Aug 11, 2002
    Currently Being Moderated
    Apr 10, 2012 12:56 PM   in reply to smbPTC

    If you want the purple bar to go away and only have button fields and not text fields, check boxes, etc., you can set security to disallow form filling. The buttons will still work. And though some consider this to be a bug, it really is intentional behavior.

     
    |
    Mark as:
  • George Johnson
    11,703 posts
    Aug 11, 2002
    Currently Being Moderated
    Apr 10, 2012 1:18 PM   in reply to smbPTC

    The purple bar will appear when there are more than 100 buttons in the document, regrdless of which page they're on.

     

    Again, if you set up security to disallow form filling, the purple bar won't get displayed and the buttons will still work.

     
    |
    Mark as:
  • George Johnson
    11,703 posts
    Aug 11, 2002
    Currently Being Moderated
    Apr 10, 2012 1:38 PM   in reply to smbPTC

    Open the PDF in Acrobat and select: File > Properties > Security > Security Method: Password Security

     

    You will then be presented with "Password Security - Settings" dialog. In the Permissions area, select the "Restrict editing..." check box and in the Changes Allowed dropdown select either "None" or "Inserting, deleting, and rotating pages". Both of these options restrict form filling, but will allow your navigation buttons to work. You will also have to enter a password, save the file, and perhaps close and reopen it. Once you do, the purple bar should not get displayed.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points