Skip navigation
mbrouill
Currently Being Moderated

Re: Script Error in Skin Editor

Apr 9, 2012 9:47 AM

Tags: #javascript #plug-in #ie7 #webhelp #toc_error #robohelp8 #script_error #internet_explorer_7 #chrome_frame #void

I posted this as a reply to the following discussion: http://forums.adobe.com/thread/603151 but believe it merits its own post as it was not resolved by the solution that was presented.

 

My company runs Internet Explorer 7 as its default browser and recently installed chrome frame. I was editing a robohelp project this week and encountered the following error message when I opened the skin editor:

IE Script Error.jpg

 

When I opened up the published webhelp I had the same issues described elsewhere in the forums with the TOC and Search not working. I edited the whver.js file using the specifications outlined by piersh in the forum discussion noted above without success.

 

Additional information:

  • I am using RoboHelp 8
  • Functuonality is fine when tested in Firefox
  • Published and tested locally
  • Tested from two additional company computers from a network shared drive
 
Replies
  • Currently Being Moderated
    Apr 11, 2012 11:30 AM   in reply to mbrouill

    Hi,

     

    Bummer that the solution of the other thread didn't work for you. Is the output affected or is it only the skin editor? What happens if you modify the seed files in your RoboHelp installation directory? (Backup the original files first)

     

    Greet,

     

    Willam

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 12, 2012 12:11 AM   in reply to mbrouill

    Try the following link:

     

    In the following post, this poster only got it to work after uninstalling chromeframe and other addons: http://forums.adobe.com/message/4301933#4301933

     

    Does this solve your problem?

     

    Greet,

     

    Willam

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 12, 2012 11:45 AM   in reply to mbrouill

    Yes, both are needed. I thought that this is specified in one of the referenced posts. Good you figured it out.

     

     

     

    Greet,

     

     

     

    Willam

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 19, 2012 5:27 PM   in reply to mbrouill

    mbrouill, did you make the changes to the whver.js file in your Program Files or the WebHelp output folder? I found that the error in the WebHelp Skin Editor dialog box disappeared when I changed the whver.js file in C:\Program Files\Adobe\RoboHelp 8\RoboHTML\WebHelp5Ext\template_stock\ (see m_d_uk2's reply in http://forums.adobe.com/message/3715435#3715435#3715435). If you change the file in the Program Files, the whver.js file in the WebHelp folder will be updated automatically every time you regenerate the help.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points