Skip navigation
Currently Being Moderated

Catalogue gone - cannot restore from backup

Apr 14, 2012 12:49 AM

Having had plenty of performance problems with LR4, now 4.1 RC (unimproved), I probably should not have been surprised to find the whole catalogue missing when I tried to open it today.  My C drive where the catalogue should be, and my actual images (on another drive) are both fine.  But I got an error when I tried to open the one and only catalogue I run.  Something to the effect that it was unable to find the source for LR 4.1, and it went on with verbage I certainly did not understand.  I wish now that I would have written down the message, because I cannot recreate it.  This is because when I tried again to open the catalogue by clicking directly on where it lives, the program all of a sudden makes a brand new catalogue for me with none of the 25,000 images that were on the catalogue I've been working with.  So when I click the icon now, I get this new empty catalogue happily opening.


Now when I go to my most recent backup and try to open that, I get a message from Windows saying it is attempting to configure LR 4.1 RC, then an error message saying "the feature you are trying to use is on a network resource that is unavailable".  It goes on to ask that I enter an alternate path to a folder containing the installation package 'Adobe_Lightroom_x64.msi'.  A search for that turned up nothing.  So it appears to be trying to install Lightroom, correct?  But I already installed it, and it appears in my programs folder.  I assumed that to restore a catalogue backup you simply went into where your backups are stored and clicked on the most recent one.  But I don't know how my catalogue disappeared in the first place.  Again, my images are safe and sound on another drive (but without a day or two worth of edits saved into the metadata, unfortunately - so I'd really like to get the catalogue back).


Can anyone help with figuring out what may have happened in the first place, and how to restore from my backup (which includes the most recently imported images and all my edits).  Thanks.

P.S. LR 4 is turning out to be a nightmare.  I'm really sorry I bought it.

  • Currently Being Moderated
    Apr 14, 2012 3:49 AM   in reply to mikesmtn

    Hi Mike,

    Please don't be upset with my suggestions.


    You seem to be the kind of guy who does lot of things in a haste and cannot remember exactly what it was. So slow down.

    I'd generally suggest, that before you actually do something you take a piece of paper and scribble down what you want to achieve, then outline the steps you think you need. Then as you progress you write down what you actually did and what system reactions you encountered.

    This will help anybody afterwards to make head or tail of what may have happened.


    Which is something probably nobody can do for you at the moment.

    So here are suggestions how I would continue from where you are:


    1. With all LR versions closed salvage everything you might need as a set-up point for later, using Windows Explorer:

    Search for any *.lrcat-file you may find on your computer and save it away, on network storage or an external drive.

    Do the same for your original photos, the ones LR is supposed to get into its catalog (which means LR is going to point at them).

    Result: no further havoc possible without the means to remedy it according to current state.


    2. As your LR seems not to be properly installed:

    De-install then any LR version you may have, using Windows Installation Features.

    This may leave

    C: \ Users \ [your username] \ My Pictures \ Lightroom \


    C: \ Users \ [your username] \ AppData \ Roaming \ Adobe \ Lightroom \

    Rename the last Folder \Lightroom\ into \LR old\, so any new installation will ignore it. To be deleted later once everything works again.

    To be on the really safe side restart your computer.


    3. Download a fresh clean installation version from Adobe.

    Install it. Close it.

    Note: any preferences or settings, plugins will be ditched in doing so. But I suspect any attempt to salvage this would further complicate or introduce other problems...


    4. Now there are several alternative routes possible.

    Difficult to predict the best one, but my guess to try would be as follows:

    4A) Copy your latest LR4-catalog (Lightroom 4 Catalog.lrcat or similar name) from the safe storage under 1. into C: \ Users \ [your username] \ My Pictures \ Lightroom \.

    Right-click on it in Windows Explorer to open it in Lightroom.

    It should open, unless it is corrupted. Then try with an older backup of your catalog.

    If you have to go back to a LR3-catalog, the system will do a conversion to LR4.


    If none of your sufficiently recent catalogs will open, go for alternative

    4B) Open LR4 with its newly created default catalog. Then do File>Import from Catalog and choose the latest non-corrupted catalog that you have.



    I have never seen catalogs (i.e. *.lrcat-files) disappear... this is something you cannot attribute to LR4's buggy state.


    Good luck,


    Mark as:
  • Currently Being Moderated
    Apr 14, 2012 4:25 AM   in reply to mikesmtn

    Hi Mike,


    Incidentally I had a similar experience to your effects:

    As I had an internal error when trying to export to eMail I wanted to ditch my preferences file, so I renamed it.


    When I tried to start LR again I also got the Windows installer with trying to search and ending up with a strong installation failure (or whatever the correct English term is - I use my Windows in German, just LR in English).

    All what happened was that I tried to restart LR and have it rebuild the preferences file - standard operating procedure in former LR-versions for all sorts of strange problems!


    So I renamed my preferences-file back to "Lightroom 4 Preferences.agprefs"

    and everything works perfectly again (apart from my mail-export...).


    Now that is weird ! Should the recreation-mechanism of the preferences file be broken? I am still on LR4.0, not 4.1RC.


    It might open another route for you: look for C:\Users\[your username]I\AppData\Roaming\Adobe\Lightroom\Preferences\Lightroom 4 Preferences.agprefs

    Maybe you have another copy of it, so you can copy over there?

    But that is something I would not have backed up... due to the former standard rule...


    Sorry for laying the havoc at your door earlier...


    Mark as:
  • Currently Being Moderated
    Apr 14, 2012 4:45 AM   in reply to Cornelia-I

    Doing some more tests:

    This time I had renamed the LR4-preferences-file differently, so it started with different digits rather than ending differently.


    I found the problem is when you have another "Lightroom 3 Preferences.agprefs" present in the same folder:

    Then the system looks for the relevant LR3-catalog, which it could not find anymore (because I had moved that earlier, after conversion to LR4).


    But this time I could point the dialog to choose another catalog, and I directed it to my new LR4-catalog. This time it opened without problems, creating a new Lightroom 4 Preferences.agprefs as usual.

    First time I had abandoned the dialog to search for a catalog and had invoked LR from WindowsExplorer, when I got the installer stuff.


    So suggestion for you:

    Remove the "Lightroom 3 Preferences.agprefs" if you have any there (store safely away - you might need it again in case you might give up on LR4 altogether).

    Verify the default position of your latest LR4-catalog.

    Then start your LR4 as it is and direct it in the missing-catalog-dialog to this file.


    I keep my fingers crossed that this will work you same as it did for me.


    Mark as:
  • Currently Being Moderated
    Apr 14, 2012 11:28 AM   in reply to Cornelia-I

    I have had this searching-for-MSI situation happen twice, once some days after each of my LR4 and LR4.1RC installs. 




    I have solved it by starting up the LR installer (setup32.exe or setup64.exe), letting it extract all the setup files waiting for the install go-ahead, then I go find the MSI file it is searching for in the newest gibberish-name temp folder the installer just created and copy the MSI file to another folder I create for the purpose, then point the search window to that location and it finds it and configures LR4 and continues on without having the problem, again.




    My process is likely something only a somewhat sophisticated computer user would be able to do, so it is something that Adobe really needs to fix in the Install process.




    I am glad you think it is associated with having the LR3 preferences file in the same folder, because next time a LR4 version is installed I’ll go remove the LR3 preferences and see if it happens, again.




    Normally I open LR4 and have it open where it remembers its catalog from last time, but occasionally I actually double-click on an LRCAT file to have LR4 open that one specifically.   It is when I double-click on an LRCAT file that LR4 displays the MSI-searching behavior.

    Mark as:
  • Currently Being Moderated
    Apr 14, 2012 3:18 PM   in reply to mikesmtn

    An automatic Windows Update is not going to delete your DNGs.  The reason you can’t find the LR preferences is because C:\Users\yourusername\AppData is a hidden folder. 


    You either have to enable the display of hidden folders in your Explorer Options or do some typing into the Explorer Address bar to get there, or use a DOS prompt:



    After you have made hidden folders visible, then try finding your LR preferences file, again.

    Mark as:
  • Currently Being Moderated
    Apr 14, 2012 8:46 PM   in reply to mikesmtn

    Lightroom doesn't contain image files so I can't see the connection between the loss and Lightroom. Hvae you tried searching for file names of some missing files with Explorer??

    Mark as:
  • Currently Being Moderated
    Apr 14, 2012 9:04 PM   in reply to Geoff the kiwi

    LR would not delete your images from the hard-drive nor would it delete your catalog.  


    You may have lost track of them if your catalog or DNGs were relative to your users folder and your windows profile got changed. 


    The default location of a folder under Pictures for LR is actually a path under C:\Users\yourusername\My Pictures so if your profile got redone and a new path was created, then C:\Users\yourusername2\My Pictures would be a different place even though it shows up as Pictures when you login.


    If you reformatted your hard-drive and re-installed Windows that would have deleted everything, but blaming LR for that seems unfair.


    As Geoff suggests, search your C: drive for *.DNG and see if you can find them.  You need to be an Administrator-class user to see files from other user-profiles, and if you’re not then they may be off limits to you.  Do you know if you are logged in as an Administrator user?

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points