Skip navigation
Currently Being Moderated

Can't authorize LR4 on Facebook

Mar 12, 2012 4:17 PM

Tags: #facebook #authorization #lr4



I've updated to LR4 and can't seem to authorize to Facebook.


I'm using the built-in FB plugin, and when I click the 'authorize on Facebook' button, it opens up a browser window, I then either login, or if I'm logged in, it displays my homepage, with no option to authorize. LR then naturally tells me the authorization fails, or it just continues to display the 'authorizing' message until I quit out.


[edit: I'm on a Macbook Pro running OS 10.7.3, using either Safari or Firefox reproduces the same result. Also the Facebook page in question is one of the new-style 'Timeline' pages.]


Any ideas, please?





  • Currently Being Moderated
    Mar 22, 2012 10:51 AM   in reply to 3dit0r1

    Same problem, I'm on  Windows 7.,  Firefox and IE both fail the same way.Not on Timeline fwiw

    When I try I'm getting

    Firefox doesn't know how to open this address, because the protocol (lightroom) isn't associated with any program.

    Mark as:
  • Currently Being Moderated
    Apr 14, 2012 11:59 AM   in reply to Walkingstaff

    Same problem here. Had you found a solution to it?

    Mark as:
  • Currently Being Moderated
    Apr 16, 2012 4:00 AM   in reply to 3dit0r1


    I found a solution as per this thread:


    See the solution outlined by BKKDon.





    Mark as:
  • Currently Being Moderated
    Apr 16, 2012 4:14 AM   in reply to 3dit0r1

    Odd.. it works for me. anyway, here's the post:



    I found I was able to complete it only using Microsoft IE on windows using the following method:

    1. Delete Lightroom from the Apps on your account

    2. Re-authorize from Lightroom (make sure Microsoft IE is the default internet browser)

    3. When authorizing IE will go to an invalid URL - just copy all of the URL

    4. When Lightroom notifies "Failed to receive the authentication token." Click on it to bring up "lightroom://..." under the Facebook Authorization URL

    5 Replace "lightroom://..." with the URL you copied and it will be authorized


    Note it doesn't seem to work with either Firefox or Google Chrome


    Mark as:
  • Currently Being Moderated
    May 3, 2012 7:06 AM   in reply to juu.borg

    Thanks Juu - I, too, was having problems, but having deauthorised the FB app, then readded, and knowing the trick to cut and paste the LR URL address really helped.

    Back in business!

    Thanks so much!

    Mark as:
  • Currently Being Moderated
    May 6, 2012 11:27 PM   in reply to juu.borg

    Weird, I just tried this, and it still doesn't work. IE didn't go an invalid URL, it went to the FB authentication URL. But when I tried to paste that, I still get the token error.

    Mark as:
  • Currently Being Moderated
    Sep 21, 2013 12:29 PM   in reply to 3dit0r1

    I uninstalled the Facebook plug-in in lightroom, and the app on Facebook, and then set it up, and something shifted, and all of a sudden it worked. This worked in google chrome with a macbook pro.


    The down side was that I lost the albums that I regularly post to, but this seemed to solve the problem for the time being.

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points