Skip navigation
Currently Being Moderated

Export from Lightroom to Facebook

Mar 15, 2012 6:41 PM

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Mar 15, 2012 6:41 PM   in reply to Community Help

    This doesn't work. Facebook replys " No registered app for this extension".  Facebook then opens to my home page, no instructions.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2012 7:14 PM   in reply to ED_S_SMITH

    Yes seems to be a problem with the Authentication Token as if you delete the application and re-register you get the following message:

     

    "Failed to receive the authentication token." and clicking on it brings up "lightroom://..." under the Facebook Authorization URL

     

    It's all explained here http://developers.facebook.com/docs/authentication/ and since the process was updated in October 2011 it may have changed because LR4 is a new application.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2012 6:49 PM   in reply to Community Help

    I'm having the same problem "Failed to recieve the authentication token". I delete the original Lightroom app from the facebook account in an attempt to solve some upload issues I've been having. Now it doesn't work at all because it can't complete authentication. Looks like Lightroom is registered correctly if I go to my facebook account on facebook. Lightroom doesn't know it though.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2012 7:34 PM   in reply to brianwrx

    I found I was able to complete it only using Microsoft IE on windows using the following method:

    1. Delete Lightroom from the Apps on your account

    2. Re-authorize from Lightroom (make sure Microsoft IE is the default internet browser)

    3. When authorizing IE will go to an invalid URL - just copy all of the URL

    4. When Lightroom notifies "Failed to receive the authentication token." Click on it to bring up "lightroom://..." under the Facebook Authorization URL

    5 Replace "lightroom://..." with the URL you copied and it will be authorized

     

    Note it doesn't seem to work with either Firefox or Google Chrome

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2012 3:47 PM   in reply to BKKDon

    This works, thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2012 6:11 PM   in reply to BKKDon

    Yes, thanks BKKDon! That worked!

     

    Now let's see if I can actually upload an album   It would freeze after 2-4 photos before which is why I was attempting to reauthorize.

     

    Update: No. Still fails to upload to facebook. Of course I can't upload into Facebook even with their own web browser based uploaded either...

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 6, 2012 9:14 AM   in reply to Community Help

    I kept having the error using the facebook publishing function in LR4. It kept saying "Return Error #10 Application's Activtiy Privacy for User is insufficient to perform this action"

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 6, 2012 3:02 PM   in reply to Community Help

    im having many keychains requests, Ill check "always" but Ill get many many requests from Snow Leopard (or LR4.1 rc).

    With LR3 no error nor trouble about facebook publishing... some ideas?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 15, 2012 1:06 PM   in reply to Community Help

    Hi all

    I have problem with LR4. I do not have problem with new album on facebook but if I want update or upload new pictures to existing album, I recieved error.

     

    LR shows two messages:

    1) error: photo upload failed

    2) Can´t update this collection. Photo upload failed

     

    thank you for any help!

     

    Karel

     
    |
    Mark as:
  • Currently Being Moderated
    May 27, 2012 9:07 PM   in reply to CarlosRigga

    Thank you so much for this post, worked perfectly!

     
    |
    Mark as:
  • Currently Being Moderated
    May 28, 2012 4:16 AM   in reply to Community Help

    worked fine after updating to 4.1 RC.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2012 11:57 PM   in reply to Community Help

    Just installed latest update,and now everytime I go to the Publishing manager to get authorised to use my FB account,it says i.m authorised but i cant save my settings because there is an internal problem with my LR plugin...it worked fine before ?!?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2012 1:51 PM   in reply to Community Help

    I cannot choose a Facebook album to upload to. It uploads everything to my Wall (which was special just now, as I didn't know that, and now I have a feed with 59 photos as separate entires).

     

    I go to edit the Facebook publishing service, and there is a drop-down to select an album, but it is set to Wall Photos and is greyed out, so I can't change it.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 2, 2013 7:43 AM   in reply to EdHoover

    Samissue as EdHoover here.


    Any help ?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 9, 2013 8:04 AM   in reply to EdHoover

    remove LR apps into facebook, remove account facebook into LR e restart
    I'havent any issue from 4.1 to last release.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 9, 2013 7:44 PM   in reply to Community Help

    Thanks for the info. My photos are being published just fine, however, they are not published to Facebook in the order they are in the collection. Since there is no way to 'reverse order' in Facebook any more (you can only drag and drop individual photos), is there something I should be doing differently to get them to upload in the original order I intended? Everything looks normal in Lightroom 4.3, and I am completely up to date on software. Any ideas?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 9, 2013 7:45 PM   in reply to Community Help

    Thanks for the info. My photos are being published just fine, however, they are not published to Facebook in the order they are in the collection. Since there is no way to 'reverse order' in Facebook any more (you can only drag and drop individual photos), is there something I should be doing differently to get them to upload in the original order I intended? Everything looks normal in Lightroom 4.3, and I am completely up to date on software.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 30, 2013 5:41 PM   in reply to iloveskipper

    Did you ever figure out how to resolve this?  I'm having a similar problem

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 17, 2013 4:26 PM   in reply to ED_S_SMITH

    No it doesn't.  Glad it did for you, but not me.  There is no invalid URL to copy from.  None of these solutions work.  Anyone have any fresh ideas or should Adobe pull their heads out of their butts and make programs that work without and undue amount of hassle.....

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 18, 2013 12:28 PM   in reply to brianbhood

    remove LR apps into facebook, remove account facebook into LR e restart
    I'havent any issue from 4.1 to last releases.

     

    Please, its most important to remove facebook apps, then remove into Lightroom and again resyncro account, adding it to facebook apps!!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 18, 2013 1:15 PM   in reply to Larsenio

    Thank you for the response but I'm sorry, I do not understand why you're saying to do.  The instructions are not clear to me.  Do you mean remove the Lr app in the Facebook account?  If so, I tried that and it didn't work.  What does "remove account facebook into Lr and restart" mean?  What does remove into lightroom and re synchro mean?  How do you do that?

     

    Thanks,

     

    Brian

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 18, 2013 2:02 PM   in reply to brianbhood

    sorry for my bad english too..

    1. yes, remove Adobe Photoshop Lightroom application in Facebook account

    2. yes, remove Facebook account into Lightroom

    3. make a new account into Lightroom, with same Facebook settings

    4. accept Adobe Photoshop Lightroom policy into Facebook

    must work.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 18, 2013 2:12 PM   in reply to Larsenio

    Thank you, we're still not quite there.  How do you do step #2, remove facebook account into Lightroom?  I see no way to do that. There is simply a button to authorize and that sends me to my web browser to log into FB.  How do I scrub Lr of any old FB info?

     

    Thanks for all your help.  I appreciate your time.


    Brian

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 18, 2013 4:23 PM   in reply to Larsenio

    I'm sorry and I know you're trying to help me but the procedures you're suggesting are the very same as those listed above in this posting and they do not work, at least for me.  I've tried these procedures numerous times that you (and many others) suggest and they don't work despite some claims that they do.  That's why I'm asking for fresh ideas from anyone who has solved this problem. 

     

    #1) I have deleted the app from Facebook as you suggest. 

    #2) I then go back into Lr and click authorize. 

    #3) I even changed to Internet Explorer as the default browser as some have told me that Firefox is the problem. 

    #4) I do what Facebook asks of me inside IE and it accepts it. 

    #5) Lr then gives me the "did not accept authorization token error".

     

    I have done these procedures over and over many times and they do not work.

     

    I still don't see the answer to how do you remove "Facebook account into Lightroom"?  All this link shows me is how to create one (asssuming the procedures work, which they do not).  It also does not help with what to do if the procedures fail.

     

    I need a fresh idea if anyone has new info as these procdures do not work and doing the same thing over and over that does not work is a waste of time.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 19, 2013 12:15 AM   in reply to BKKDon

    Will this procedure affect the previously uploaded pictures and albums ?

    I mean, will Lightroom keep the "link" to the pictures and albums previously uploaded to Facebook ?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 19, 2013 4:36 AM   in reply to Sammy_70

    this procedure dont affect previously uploaded pictures, these picture must be removed from Facebook.

     

    @Brian, these procedure arent so easy, but be done with cookies and temp files cleaned before... read comments.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 19, 2013 5:00 AM   in reply to Larsenio

    @Larsenio: what do you mean by "...these picture must be removed from Facebook" ?

    Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 19, 2013 6:33 AM   in reply to Larsenio

    Again, I'm sorry, but I have no idea what you mean.  What does "be done with cookies and temp files cleaned" mean?  What are the procedures to do that?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 19, 2013 1:42 PM   in reply to Sammy_70

    Sammy, if you need to remove some albums from FB, you must remove it manually.

    Lightroom fb's plugin dont remove anything!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 20, 2013 12:57 AM   in reply to Larsenio

    @Larsenio: Good, thanks for your feedbck :-)

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 12:35 PM   in reply to brianbhood

    Does anyone have any fresh ideas how to solve this problem?  The delete app from facebook and re-authorize from Internet Explorer approach does not work.

     

    Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2013 8:20 PM   in reply to brianbhood

    Larsenio, since you're "tried and true" methods didn't work, I had to figure it out myself.  The answer to the Facebook problem is to uninstall the program, then do the following procedures:

     

    First run Microsoft Fix It.  That enabled one to run Lr uninstall.  Uninstall Lr.  Then go to the following link and do a manual uninstall of Lr to clean up residual files.

     

    http://helpx.adobe.com/lightroom/kb/preference-file-locations-lightroo m-4.html

     

    Then run your registry clean up.  Next do a computer restart.  Now you should be ready to reinstall and after doing all this, you will be performing a virgin install (like the computer had never seen Lr before).  Do the install and run the Facebook link up procedures within Lr and it works.

     

    Thanks for trying, but the procedures mentioned above do not always work.  This one worked for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2013 3:12 AM   in reply to brianbhood

    there is no need to unistall Lightroom:

    1. remove facebook application "adobe photoshop lightroom"

    2. remove Lightroom publish services into lightroom

    3. make a new publish service facebook

    4. ie/firefox etc.. accept application "adobe photoshop lightroom"

    5. just do it!

     

    every step need to close and restar Lr app - see feeback.

    http://help.adobe.com/en_US/lightroom/using/WS2bacbdf8d487e58258d44eb8 130dd470977-8000.html

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2013 3:58 AM   in reply to Larsenio

    Yes there is.  I've said several times your procedures DO NOT work and do not make sense.  People cannot follow what you're telling them to do.  I'm trying to save someone else the countless hours of wasted time that I had following what you tell them to do.  My solution works and it's a fresh approach. 

     

    Please do not keep wasting people's time with procedures that do not work!!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2013 4:22 AM   in reply to brianbhood

    Brian, it worked fine for me and many users without unistalling Lightroom, someone also replied above - could be you got some trouble with ur installation.

    Unistalling LR its wasting time but if you get a working approach in that scenario, well done.

     

    Have you removed cookies and temporary internet files?

    IE doesnt works fine if you dont clean this one - must be executed step-by-step, not so easy but worked fine by many users.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2013 8:47 AM   in reply to Larsenio

    No, you did not respond to me about how to remove cookies and temp internet files.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2013 9:30 AM   in reply to brianbhood

    Brian, google -> http://www.inf.aber.ac.uk/advisory/faq/434

    How do I delete cookies and temporary Internet files from my web browser?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 14, 2013 6:06 AM   in reply to CarlosRigga

    I've tried all the workarounds but I'm still getting this error:

    Photo upload failed, but no error string was returned from Facebook.

    Lightroom 4.3 - Mountain Lion

     
    |
    Mark as:
1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points