Skip navigation
Currently Being Moderated

Spry.widget issue in IE

Apr 17, 2012 11:21 PM

Hello,

 

Pls have a look at http aeonit[dot]name/audi_youtube/index[dot]php

 

i have used tabs at left bottom side but i also used scrollbar for the tab content. so i have added an ID to li as follow:

<ul class="TabbedPanelsTabGroup">

                <li class="TabbedPanelsTab" tabindex="0"><span id="first_tab">All</span></li>

                <li class="TabbedPanelsTab" tabindex="0"><span id="second_tab">Official</span></li>

                <li class="TabbedPanelsTab" tabindex="0"><span id="third_tab">Fans</span></li>

              </ul>

 

and the js is

 

<script type="text/javascript">

var TabbedPanels1 = new Spry.Widget.TabbedPanels("TabbedPanels1");

$(document).ready(function(){

                //first tab

                    $("#first_tab").click(function(){

                        $('#scrollbar_comment').tinyscrollbar();

                        //alert('hi');

                        });

                    //second tab

                    $("#second_tab").click(function(){

                        $('#scrollbar_comment1').tinyscrollbar();

                        //alert('hi');

                        });

                        //third tab

                        $("#third_tab").click(function(){

                        $('#scrollbar_comment2').tinyscrollbar();

                        //alert('hi');

                        });

                    })

</script>


So, The function is working perfect in all browser except IE(Double click works there). So can i add function in spry widget on tab click?

 

Thnx....

 
Replies
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Apr 18, 2012 12:45 AM   in reply to mahendra rajeshirke

    What version of Spry have you used? And is your CSS version 2.0 or 3.0?

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Apr 18, 2012 9:07 AM   in reply to mahendra rajeshirke

    mahendra rajeshirke wrote:

     

    i am using version 0.7 - Spry Pre-Release 1.6.1

    There is no CSS 0.7. Where are you getting your version numbers from?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points