Skip navigation
legendarysnake
Currently Being Moderated

FMS on linux

Apr 18, 2012 4:58 PM

hello,

i recently installed FMS on my centos, but actually i am having difficult to start the server.

 

#Fields: date   time    x-pid   x-status        x-ctx   x-comment

2012-04-18      18:58:25        2513    (i)2581173      FMS detected IPv6 protocol stack!       -

2012-04-18      18:58:25        2513    (i)2581173      FMS config <NetworkingIPv6 enable=false>        -

2012-04-18      18:58:25        2513    (i)2581173      FMS running in IPv4 protocol stack mode!        -

2012-04-18      18:58:25        2513    (i)2581173      Host: PTY11222C.FortaTrust.com IPv4: 127.0.0.1  -

2012-04-18      18:58:25        2513    (e)2631013      Failed to create listener for adaptor _defaultRoot_, IP localhost, port 19350: TCCommBridge::createListener 0.0.0.0:65535/other: create socket failed.. -

2012-04-18      18:58:25        2513    (e)2631013      Failed to create listener for adaptor _defaultRoot_, IP , port 80: TCCommBridge::createListener 0.0.0.0:80/v4: bind failed!!!.  -

2012-04-18      18:58:25        2513    (e)2631114      Failed to start listeners for adaptor _defaultRoot__edge1.      -

2012-04-18      18:58:25        2513    (e)2791225      Failed to start edge : _defaultRoot__edge1      -

~

 
Replies
  • Currently Being Moderated
    Apr 19, 2012 8:36 AM   in reply to legendarysnake

    Your sockets seems to be occupied, please shut down any other service that must be using these ports.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2012 8:41 AM   in reply to legendarysnake

    Execute "netstat -nl" to see what port are accupied or are user for a service.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2012 9:10 AM   in reply to legendarysnake

    Port 80 is used, probably by apache.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2012 11:22 PM   in reply to legendarysnake

    Make sure that ICMP 19350 port is open.

    It will be better if you can open all the ICMP port, but if there are security threats, you may need to open 19350 and 11110 ICMP porrts atleast as they are used for internal communication among processes.

    Regards,

    Shiraz Anwar

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 1:21 PM   in reply to legendarysnake

    I didnt see your messge earlier and am back to my home for weekend, I had opened the shell for few minutes and saw the edge crashing in your logs, installation is looking fine to me. Only thing that I still need to verify is the conf folder. Couldnt spend much time on this, wil lrevert back to you around Monday on this issue, meantime am not sure if you have already tried this tutorial - http://help.adobe.com/en_US/flashmediaserver/configadmin/WSdb9a8c2ed4c 02d261d76cb3412a40a490be-8000.html

    See and let me know if it works for you.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 29, 2012 10:34 PM   in reply to legendarysnake

    Have you verified if your system's firewall is off ?

     

    You can check the status of your firewall by running this command in your shell - service iptables status. Sometimes it happens that your firewall won't allow FMS to listen on ports 1935 and 80, because of which

    FMS fails to start.

     

    If the firewall is up, please try switching it off and restart your server again. Command to stop firewall is - service iptables stop.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2012 10:55 PM   in reply to legendarysnake

    Here are a few things I would like you to run -

     

    1. Tell me which version of FMS you are trying to install.

    2. Execute 'ps -elaf | grep fms'  on your shell and let me know the result. I am just trying to make sure there are no multiple instances installed on your server machine that may be causing any problems

    3. Uninstall the FMS server.

    4. Check again for running processes by executing 'ps -elaf | grep fms'

    5. Now run 'netstat -tulpn | grep :80' and 'netstat -tulpn | grep :1935' to check if any of these ports are being used by FMS or some other process.

    6. If you find any process that is currently using any of the two ports, please kill them.

    7. Please make sure you have your firewall disabled and no other security policy in place that may be blocking FMS from using the ports. Once we have FMS running, we can sort out the problem and enable security policies again as suitable for your requirements.

    8. Now install your server again. While installation, ensure that the installer is not throwing any errors or warnings.

     

    I know you may have done all this but just to be sure it would be great if you follow the steps in order, so that we finally catch and solve your issue. Let me know how it goes.

     

    Regards.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points