Skip navigation

your computer does not have sufficient memory resource to publish your file

Jul 14, 2010 12:46 PM

  Latest reply: RodWard, Apr 22, 2012 7:27 PM
Replies 1 2 Previous Next
  • Currently Being Moderated
    Feb 4, 2011 1:09 PM   in reply to ASG_Captivater

    As a follow up to my last post....my Adobe Captivate 4 project contains 80 slides.

     

    I experimented a bit and previewed the first 50 slides by selecting Preview defaults: 50 under the Edit and Preferences menu

     

    • Both the "Advanced project compression" AND "Compress SWF file" buttons were checked,

              it took approx. 18 minutes for the show to begin

     

    • Both buttons unchecked, it took approx. 2 minutes for the show to begin

     

    • "Advanced project compression" unchecked and the "Compress SWF file" checked,

              it took approx. 15 minutes for the show to begin

     

     

    When previewing the entire 80 slide project with both buttons checked, after 4 minutes, the project stopped generating "Progress:  Writing SWF File Tags to Stream" and the message, "Error  Your computer does not have sufficient memory resources to perform this operation.  Do the following: - Check one or more options in the Externalize Resources list, and re-publish.  - Close other applications open on your computer.  You might have to close and reopen Adobe Captivate before publishing the file.  <<I had no other applications open on my computer and I wasn't trying to publish this project, just preview it>>

     

    When previewing the entire 80 slide project with both buttons unchecked, it took approx. 6 minutes for the show to begin

     

    When previewing the entire 80 slide project with "Advanced project compression" unchecked and the "Compress SWF file" checked, after 15 minutes, the project stopped generating "Progress:  Writing SWF File Tags to Stream" and the message, "Error Your computer does not have sufficient memory resources to compress the SWF file" displayed

     

    Please advise.........

     

    Thanks,

    Dave

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2011 3:40 AM   in reply to ASG_Captivater

    I understood your concern.

     

    The reason is " When  you externalize resources, they reside outside the swf file and are  referencedfrom within the file when published.

     

    So what you need to do is

     

    Click  on Edit on the top file menu, then go to Prefernces>  Project >  Publish Settings (under PROJECT) > Externalize resources and select  the third option FMR SWF. Click OK and then Publish

     

    I hope it will work. Waiting for your reply.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2011 5:28 AM   in reply to ASG_Captivater

    Hi, I had the same problem and fortunately i had a meeting with the Captivate team that helped me to "fix" it.

    If your computer is powerful enought, you should be able to finalise your project. Captivate 5 is not perfect (but still one of the best in the market so far), so when I work all day on the software, it becomes "lazy". When I'm about to finish a project, I always have to close Captivate and then re-open the all application with my project, then launch the export. If it does not work, I fixed it by retarting the computer. It's not the best way but it worked for me!

     

    good luck

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2011 11:38 AM   in reply to ASG_Captivater

    Vish and ChimenceSE,

     

    Thank you for the quick replies.

     

    I selected the third option of clicking on FMR SWF as Vish suggested and had both the "Advanced project compression" and "Compress SWF file" buttons selected.  After 30+ minutes of clicking the "Preview" project button, this worked.  It took much longer than I expected, but it worked.  Should I always have the FMR SWF clicked as a best practice?  Should I do this for Widgets and Animations also?

     

    I then wanted to send it to my supervisor for review. When I clicked on "Publish" and then "Review" it began to precess but then froze up again with the message "Error  Your computer does not have sufficient memory resources to compress the SWF file."

     

    At this point I followed ChimenceSE's advice and completely shut everything down, booted up again with only Captivate running and was able to create the review files after 30+ minutes.

     

    Although this moreorless worked, is there anything I can add hardware or software wise to my computer to make this happen quicker and while I'm able to do work with other software at the same time?  Completely shutting down everytime I need to do this will cause many problems with other things I am working on at the same time.

     

    Thanks again and please advise,

     

    Dave

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2011 12:04 PM   in reply to dggambal

    When you publish a project as a SWF file, a single SWF file is produced.

    To reduce the size of the SWF file, you can choose to externalize some of its objects (skin, widgets, FMR SWF file, and animations).

    After publishing, the externalized resources reside outside the SWF file, and are referenced by it.

     

    SO what you can do is first Go to prefences, select the apprpriate option in EXTERNALIZE RESOURCES and then publish it. So you will not face this again in your future. For small SWF files even if you don't choose any option, its OK , however for large SWF files you need to choose FMR SWF option.

     

    By doing this you will get rid of shutting all programs or rebooting etc...

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 8, 2011 4:54 AM   in reply to dggambal

    Hi Dave,

     

    1) When you need to preview/publish the file intermediately i.e. when you are mid-way authoring your project or want to send the project for review, follow this to possibly avoid this issue:

         (i) In the preferences dialog at Project -> Publish Settings, check all the checkboxes under 'Externalize Resourses'.

         (ii) In the preferences dialog at Project -> SWF Size and Quality, uncheck these checkboxes : Advanced Project Compression, Compress SWF File, and      Compress FMR SWF file.

     

     

    2) When you need to publish your project for the FINAL time i.e. for deployment, follow these steps to possible avoid this issue:

     

    Re-start your machine - Make sure NO un-necessary programs are running (especially any back up generation software) - Launch Captivate and open your project. Now:

         (i) First, in the preferences dialog at Project -> SWF Size and Quality, uncheck these checkboxes : Advanced Project Compression.

         (ii) If you still see the issue then, in the preferences dialog at Project -> SWF Size and Quality, uncheck these checkboxes : Advanced Project Compression, Compress SWF File and Compress FMR SWF file ( if you have FMR swfs in your project).

         (iii) If you still see the issue then, follow step (ii) and in the preferences dialog at Project -> Publish Settings, check all the checkboxes under 'Externalize Resourses'.

     

    Do let me know if these steps helped you resolve your issue.

     

    -Manish

    blogs.adobe.com/captivate

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 12:13 PM   in reply to M_Anand

    Has this been addressed in CP 6? I'm still restarting constantly with video heavy lessons... as well as bypassing compression. Seems pretty important that we get this worked out. Students like media.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 6:57 PM   in reply to lefthook77

    Maybe you just need to make your video a little less 'heavy' to reduce load on the app.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 7:05 PM   in reply to RodWard

    Well... we're in an HD world now, and that's the compressor's job. As demonstrated by the recommended fix (disabling all compression), Captivate is currently great at making enormous uncompressed files, but a Shockwave file's main strength (in my opinion)- presenting low drag media, seems to be missing from Captivate when dealing with HD video for use in HD training projects.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 8:50 PM   in reply to lefthook77

    If you're talking about HD video clips that you've added into a Captivate course, I think you misunderstand how Cp works. 

     

    Video files (FLV or F4V) in Captivate 5x are always externalised.  So when you publish a Captivate 5 project, you're not compressing the FLV or F4V at all.  You're only compressing the SWF containing whatever (non-video) objects you added to the stage.

     

    So if you're adding HD video clips using Insert > FLV or F4V, or Insert > Slide Video, or Video > Insert Slide Video, it's ALL going to be externalised video that is unaffected by Captivate's compression.

     

    What format are you publishing to?  HTM/SWF or something else?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 8:54 PM   in reply to RodWard

    I’m creating SCORM 2004 packages. It seems strange that it will publish fine without .swf compression when large videos are present, but when I add .swf compression publishing fails… if the videos are always externalized. By that logic, the result should be the same whether I compress or no… since it isn’t really doing anything to the external video.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 8:58 PM   in reply to lefthook77

    Your issue with the compression might have nothing to do with the videos.  There may be something else in your project that is causing it to fail at publish time.

     

    You need to try hiding slides and republishing with compression on to track down where the troublesome object/s are.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 9:05 PM   in reply to RodWard

    Nope…. I’ve published many many sessions for this client, and the few that have over 100 meg of video fail unless I turn compression off.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 22, 2012 6:55 PM   in reply to lefthook77

    You mentioned that you are creating SCORM packages.  Does this mean you have the Zip option turned on when publishing?  Does publishing still fail without this option on?  I'm wondering whether the failure is caused by attempting to compress already compressed files. 

     

    If you have 100 megs of video file, Captivate will attempt to copy these videos into the publish folder when publishing.  The sheer size of these files might be causing something to malfunction.  For example, if the files already exist in the same publish folder location from the initial publish action, then this might be triggering some issue (normally you'd be prompted to specify whether the existing files should be overwritten).  What happens if you remove the previously copied video files from the publish folder so that there are no files there to be overwritten?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 22, 2012 7:13 PM   in reply to RodWard

    That’s an excellent point, Rod. By the way, I use nearly all of your products… Thanks for the excellent widgets.

     

     

     

    Still, Zipping is a necessity for import into my LMS. Even if it works, the solution won’t do me any good. It would be good to know though. I’ll check soon.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 22, 2012 7:27 PM   in reply to lefthook77

    What I'm suggesting is that if you find the Zip function is part of the issue, you can always zip the SCORM packages AFTER publishing so as to remove this problem from the equation.  All you need to remember is that when you zip the SCORM package using Winzip (or whatever utility you prefer) you need to do it from INSIDE the SCORM folder created by Captivate, not just by selecting the published folder and zipping that.  When you upload your SCORM zip to your LMS, the LMS will need to find your imsmanifest.xml file at the root level of the zip, not one level down inside another folder, otherwise it will reject the SCORM.

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points