Skip navigation
JumpmanRugs11
Currently Being Moderated

I have an issue running a linear SWF story

Apr 23, 2012 2:33 AM

Tags: #flash #website #dreamweaver #swf #story #children #linear

I have about a day to fix a problem I am having.


Basically i created a short story and linked each SWF file to the next scene via buttons, to make it as quick loading as possible. When previewed in Flash to see if it works, it works fine. When each SWF is previewed in a Browser, it works fine.


Scene1 -> Scene2 -> Scene3, and so on.


It worked fine when i previewed it in Flash, but as soon as i place the SWF in Dreamweaver, it plays the 1st scene, but won't play the linked SWF when i click on the next button (When previewing)..


Any ideas?

 
Replies
  • Currently Being Moderated
    Apr 23, 2012 4:30 AM   in reply to JumpmanRugs11

    If the files are in a different directory than the html page, that will be the problem.  When you place an swf in a web page, the directory of the html page becomes the loading reference for any files your swf loads... it is the same as if you placed the swf in that directory anyways. 

     

    If you want to keep the swf's in a separate directory, then you need to adjust the path they use to target the other swfs to be as if they are in the html page directory.  You do not have to put them in the same directory as the html page, you just have to code the targeting of any files they load as if the file doing the loading is in that folder.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points