Skip navigation
prsnrs
Currently Being Moderated

SpryMenu.js Errors in LiveView & Prieview/Debug in browser

Apr 20, 2012 9:12 AM

I createa New File and use a preset Dreamweaver CS5.5 layout. I make a slideshow using the Spry Image Slideshow With Filmstrip widget from Adobe. Previously, it worked flawlessly in both Live View and Preview in Browser. I must have done something to corrupt files somewhere, because now it doesn't work. I get the following error messages:

     SpryPanelSelector.js requires SpryWidget.js1

     SpryFadingPanels.js require SpryPanelSet.js!

     SpryPanelSet.js require SpryWidget.js!

     SprySliderPanels.js require SpryPanelSetting.js!

     SpryFilmStrip require SpryButton.js!

     SprySlideShow.js require SpryWidget.js!

     SpryThumbnailFilmStripPlusin.js requireSpryImageSlideShow.js!

     SpryTitleSliderPlugin.js requireSpryImageSlideShow.js!SpryPanAndZoomPlugin.jsrequire SlideImageSlideshow.js!

 

What have I done and can I filx this mess?

 

Thanks.

 

prsnrs

 
Replies
  • Currently Being Moderated
    Apr 20, 2012 6:59 PM   in reply to prsnrs

    The online version of SpryWidget.js has most likely been corrupted during upload.

     

    Link the file to the version on the Adobe site as per following, and see how you go

    <script src="http://labs.adobe.com/technologies/spry/ui/includes/SpryWidget.js" type="text/javascript"></script>

    Gramps

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 9:31 PM   in reply to prsnrs

    You have got the following in the head section of your document. Just replace the hightlighted line

    <link href="Spry-UI-1.7/css/Menu/basic/SpryMenuBasic.css" rel="stylesheet" type="text/css">

    <script src="Spry-UI-1.7/includes/SpryDOMUtils.js" type="text/javascript"></script>

    <script src="Spry-UI-1.7/includes/SpryDOMEffects.js" type="text/javascript"></script>

    <script src="Spry-UI-1.7/includes/SpryWidget.js" type="text/javascript"></script>

    <script src="Spry-UI-1.7/includes/SpryMenu.js" type="text/javascript"></script>

    <script src="Spry-UI-1.7/includes/plugins/MenuBar2/SpryMenuBarKeyNavigationPl ugin.js" type="text/javascript"></script>

    <script src="Spry-UI-1.7/includes/plugins/MenuBar2/SpryMenuBarIEWorkaroundsPl ugin.js" type="text/javascript"></script>

    Gramps

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2012 4:45 AM   in reply to Ben Pleysier

    Hi Gramps

     

    We've "spoken" one time before in relation to a horizontal menu error.  I've tried doing what you suggested above with the slideshow but it still keeps on coming up with the .js errors.

     

    the page in question is http://www.newchildrensfest.com/Photo2.html  I havent linked it to the site but the page has been uploaded.  Is it because I have the horizontal menu widget on the page too?

     

    Thanks in advance cos its doing my head in!

     

    Kate

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2012 5:52 AM   in reply to Plan of Attack8

    Have a look at the corrupted SpryWidget.js that you have linked to in your online document

    _Capture.jpg

    and compare that to a healthy version

    _Capture.jpg

    As said, link the file to the version on the Adobe site as per following

    <script src="http://labs.adobe.com/technologies/spry/ui/includes/SpryWidget.js" type="text/javascript"></script>

    Gramps

     

    PS Please start a new topic rather than tagging onto an existing topic.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2012 7:22 AM   in reply to prsnrs

    @prsnrs,

     

    No worries, you did the right thing. My message was addressed to Plan of Attack8, but was not meant maliciously, just as a matter of courtesy

     

    Gramps

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2012 8:10 AM   in reply to prsnrs

    Please post a link to your site.

     

    Gramps

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2012 4:45 PM   in reply to Ben Pleysier

    Yes, sorry, wasnt paying attention to etiquette I was frustrated and was cutting corners trying to get an answer.  I also would like to do the right thing.  I did start another question but I cant see where it has "gone" so I just tagged on the end of this existing discussion.  Again, sorry. 

     

    Thank you for your response all the same Gramps and I'll have another look now and fingers crossed will have it sorted.

     

    Thanks again,

    Kate

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2012 4:54 PM   in reply to Ben Pleysier

    Thank you again.  I'm not actually sure if what I've done is what you meant for me to do but it works!  Thanks again!

    Planofattack8

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 5, 2012 4:02 PM   in reply to Ben Pleysier

    Gramps,

     

    I had the same problem as prsnrs and your solution worked!

     

    Thanks so much for your help, you've probably saved me hours/days of work.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points