Skip navigation
Currently Being Moderated

Loader png -  wrong color values in BitmapData

Apr 22, 2012 5:12 PM

When I load png images using Loader class and then access pixel colors I get values different from those I see in image editor. For example, if in image editor I make blue color rectangle(0x0000ff), export it as png and load it using Loader I get 0xfe color value. Is there any options I can set to preserve original colors? The issue does not happen for gif files.

 
Replies
  • Currently Being Moderated
    Apr 23, 2012 8:43 AM   in reply to S_Aleksey

    what are you usign to create the image I do not get the same issue

     

    for my blue rectangle (0x0000ff) I get 0xff as expected

     

    or can you send me the image you are having problems with?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 24, 2012 1:45 AM   in reply to S_Aleksey

    I now get your problem using MSPaint

     

     

    if you create an image in MSPaint filled with 0x0000ff and open it in flash flash thinks it's 0x0000fe however if you open it in photoshop you get 0x0000ff

     

    here are some other  posts on the issue (with no solution)

     

    http://www.actionscript.org/forums/showthread.php3?t=169621

     

    http://www.bigresource.com/Tracker/Track-flash-QXh0kQ2AjQ/

     

    oddly you don't get the same problem if you embed the image only if you load it using Loader

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points