Skip navigation
Currently Being Moderated

Installing Coldfusion 9 and Apache 2.2 on Windows Server 2008 R2 Standard

Dec 14, 2010 12:40 AM

I'm having issues getting ColdFusion 9 working with Apache 2.2 on Windows Server 2008 R2 Standard.


The server is brand new and it's a fresh install of Apache and ColdFusion 9.


Having installed Apache, I tested the web server and it was working fine, so I proceeded to install ColdFusion 9. I attempted to restart the Apache server through the Apache Service monitor, only to get the error dialog box 'The requested operation has failed'.


On closer examination of the Windows error log, I saw the following error:


The Apache service named  reported the following error: >>>
httpd.exe: Syntax error on line 488 of C:/Program Files (x86)/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/ColdFusion9/runtime/lib/wsconfig/1/ into server: The Apache service named is not a valid Win32 application.


I updated the ColdFusion installation to 9.0.1 in case there was an issue with version 9.0 and Apache. Still no joy.


After a bit of research, I thought perhaps there was an issue with the file (since when I commented out the reference to that file from the Apache config file, the Apache HTTP server started without any problem). I tried replacing the with the 32 bit version (extracted from the wsconfig.jar file), but that made no difference either.


I have tried a number of things. I have run wsconfig and uninstalled all web server connectors and then re-created them.


I have to use Apache and IIS is not an option (I use rewrite rules extensively in an existing live installation and have many sites set up in a vhosts file), so please - no suggestions to use IIS instead.


The system requirements on state that Coldfusion 9 will work with Apache 2.2.17 and later on Windows 64 bit, so why am I having issues with a brand-new installation on a 'virgin' server?


Any help would be much appreciated. I have spent hours trawling the Web for solutions.

  • Currently Being Moderated
    Dec 14, 2010 7:20 AM   in reply to jtchivers

    jtchivers wrote:


    Apache is only officially released as a 32 bit version,

    Apache on Windows, maybe.  But Apache on Unix is officially supported in 64bit.

    Mark as:
  • Currently Being Moderated
    Mar 29, 2011 8:35 AM   in reply to jtchivers

    I'm having this exact problem on a fresh R2 install. What is extremely weird is that I have multiple 2008x64 boxes running 32-bit Apache and 64-bit CF9, with absolutley no issues. I wonder what changed in R2??

    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 1:37 PM   in reply to jtchivers

    I will just point out real quick that this is not true at all.  CF9 64-bit works just fine with Apache 32-bit. I just got done setting it up.  I did need to grab the correc out of the wsconfig.jar and drop it in place. Then after reestarting CF and Apache all worked perfectly.



    Mark as:
  • Currently Being Moderated
    Apr 23, 2012 11:51 PM   in reply to jtchivers

    @Jtchivers, please kindly mark the question as answered. As you yourself say, it is bound to help others in future.

    Mark as:
  • Currently Being Moderated
    Apr 24, 2012 3:14 AM   in reply to jtchivers

    jtchivers wrote:


    @BKBK. It has been marked as answered.


    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points