Skip navigation
Currently Being Moderated

Missing text in RoboHelp 7 when previewing/generating Frame files

Apr 23, 2012 12:11 PM

Tags: #missing_text #robohelp_7

This is a new issue for me. Until last week, it seemed to work fine. Now, though, whenever I import by reference my frame files I have noticed that, while they look fine in the Design view, when I click Preview it has missing text in parts. In one file, which was all text (no graphics), it was completely in Preview. Then, when I generated the help, that topic was still blank.


This doesn't always happen, though. Sometimes a topic is fine up to a point, then, all the text is gone, leaving only the screenshots. It generates that way also. On the other hand, some files come out fine, with no missing text. (This is only apparent in the Preview and generated help.)


I'm using TCS 1, that has RoboHelp 7, and I generate to WebHelp. I've applied an update that makes it 7.01.001.  I've also applied the "missing space" fix that Peter Grainge suggested (it worked ).


Like I said, TCS worked fine up to last week, then I started seeing these missing chunks of text. I tried creating a new RH project and starting all over, importing only one small file that had all text and no screenshots/graphics. Both the preview and generated help came out blank, although I could see it plainly in the Design view before generating.


Has anyone else had this issue, or know what it might be?

  • Currently Being Moderated
    Apr 23, 2012 12:24 PM   in reply to dwc3

    Personally, I wouldn’t rely on version 1 of TCS to produce my help (especially since it’s up to 3.5 right now & there’s been so many fixes) – what’s changed in your environment? Where’s the project located? Are you saving before generating the help?

    Mark as:
  • Currently Being Moderated
    Apr 24, 2012 12:40 AM   in reply to dwc3

    Only change in entire environment was a company-mandated change to IE9.

    Only change! That could well be behind this problem.


    Generate the output and try viewing it in a different browser.


    See for RoboHelp and Authoring tips



    Mark as:
  • Currently Being Moderated
    Apr 24, 2012 7:47 AM   in reply to dwc3

    That all points to IE9 being the issue. I don't know of anything you can do with the TCS1 output to make it work in IE9. Maybe someone else can advise on that?


    RoboHelp's preview uses IE so that explains why it too is having issues.


    I believe there may something you can do to make pages IE9 compatible but I don't know if it can be done with RoboHelp output. I am not in a position to look right now but it might be worth googling before you upgrade. If you do go that route, test the trial version to check it resolves the issue.


    See for RoboHelp and Authoring tips



    Mark as:
  • Currently Being Moderated
    Apr 24, 2012 8:05 AM   in reply to Peter Grainge



    A quick 'fix' for IE9 would be to add an IE rendering tag. Try the following: In your output, replace all <head> with <head><meta http-equiv=”X-UA-Compatible” content=”IE=EmulateIE7″ />. This should force IE9 in IE7 mode and it should work. Use a find and replace tool to quickly modify all your output files quickly.


    Can you post a screenshot of what you don't see in IE9 and the HTML associated with that content? I'd like to know why it disappears.





    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points