Skip navigation
Currently Being Moderated

3d painting issue - why is my selected value showing up different then the actual color I'm picking?

Apr 24, 2012 11:54 AM

Love the CS5's 3d painting features but I'm running into a really frustrating issue:

 

When I select a value from the 3d object and try to paint with that value, it's showing up as a different value altogether (the image hopefully illustrates this much better than words).

Not sure if it's got something to do the the lights setup or something else but I cannot figure it out.  Anyone else running into this or have a solution?

Thanks!!!ColorIssue.jpg

 
Replies
  • Currently Being Moderated
    Apr 24, 2012 7:22 PM   in reply to johncboins

    Color management (or its absence) plus naturally shading may figure in - even a uniformely lit model may expose different per pixel color than the actual color of the underlying textures. Whatever it is, it's probably normal and since you failed to provide any more information, nobody will be able to advise more specifically.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 24, 2012 10:17 PM   in reply to johncboins

    I'll explain it but you won't like it even though it is so.

     

    If all the values of the color remained exactly the same youwould have a flat color there would be no 3 D object to see.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 25, 2012 2:12 AM   in reply to johncboins

    Color management (or lack thereof). Make sure to use sRGB and not use any odd monitor profile and/or tell PS not to use it.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 25, 2012 10:21 AM   in reply to johncboins

    In the Layer's panel double click on your texture (the highlighted on the image below). This will open your texture in a new window. Keep it open next to the 3D scene window and pick the colors from the texture image. If you want you can also paint directly on the texture image too.

     

    colorpick.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 25, 2012 12:50 PM   in reply to johncboins

    I don't use Photoshop much for direct painting on 3D but since all dedicated programs have flat texture rendering mode I checked and found that Photoshop has that too.

    In the 3D panel, with the Scene item selected, in the Render Settings section, click the Edit button to open the 3D render settings. For Face Style choose Unlit Texture and click on the floppy disk icon to save the preset and give it a name. Then in the Render Settings section of the 3D panel just change from your unlit texture preset to Default and you can have the best of both worlds.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points