Skip navigation
This discussion is locked
selmslie
Currently Being Moderated

[Consolidation-Locked] Lightroom 4 on XP

Oct 18, 2012 12:23 PM

Lightroom 4 comes with a 32 and 64 bit install but does not install under XP.  Lightroom 3.6 supports XP.

 

Lightroom 4.JPG

WE SHOULD HAVE BEEN WARNED BEFORE YOU ACCEPTED PAYMENT FOR THE UPGRADE.

 

Fortunately, I was able to upgrade on a laptop (Windows 7 64 bit) but the display is not optimal (my desktop XP is much better).

 

Do you contemplate recompiling the product for Windows XP?

 

Message title was edited by: Brett N

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Apr 20, 2012 12:28 AM   in reply to selmslie

    WE SHOULD HAVE BEEN WARNED BEFORE YOU ACCEPTED PAYMENT FOR THE UPGRADE.

     

    You were: http://www.adobe.com/products/photoshop-lightroom/tech-specs.html. The rest is beside the point.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 7:03 AM   in reply to selmslie

    Selmslie I apologize for your inconvience but unfortunately it is a requirement to have Windows Vista SP2 or later to use Lightroom 4.  This limitation was put in place to offer many of the great features in Lightroom 4.  Mylennium has already offered the links to the system requirements but they can be found at http://www.adobe.com/products/photoshop-lightroom/tech-specs.html.

     

    You are certainly welcome to request a refund for your purchase.  The directions on how to accomplish this can be found Return, change Adobe orders | North America - http://helpx.adobe.com/x-productkb/policy-pricing/return-change-orders -north-america.html.

     

    You are correct that you can purchase Photoshop Elements 10 or Photoshop CS5.1 currently to use a Photoshop product under Windows XP.  Unfortunately there is no work around to allow Photoshop Lightroom 4 to function within the Windows XP environment.  If you wish to continue using Photoshop Lightroom 4 it would be necessary to upgrade your operating system to at least Windows Vista Service Pack 2 or higher.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 27, 2012 6:00 AM   in reply to selmslie

    Hello Adobe,

    How can I purchase Lightroom 3.6 now?

    I have windows XP and lightroom 1 and I want to upgrade. When I click "Buy" in Lightroom 3.6 demo, it goes to the Lightroom 4 purchase page. will the Lightroom 4 serial number work with Lighroom 3.6? Is there another way to buy Lightroom 3.6 upgrade from 1.4?

    Thank you.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 27, 2012 8:10 AM   in reply to gennadym

    We are only offering the purchase of Lightroom 4 presently.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 28, 2012 11:22 AM   in reply to Jeff A Wright

    I understand, but will the serial number of Lightroom 4 fit Lightroom 3.6?

    I only have Windows XP, does it mean I have no upgrade options from my lightroom 1.4 or I can use 3.6?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 28, 2012 2:57 PM   in reply to gennadym

    The only upgrade availabe is for Lightroom 4.  Is it possible for you to upgrade your computer to Windows 7 or Vista?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 28, 2012 3:34 PM   in reply to selmslie

    I am sorry Selmslie.  Gennadym can try to purchase an older version of Lightroom from a reseller besides Adobe.  Beyond that though Windows Vista is required to use Photoshop Lightroom 4.

     

    You are right though it will depend on the hardware capabilities of Gennadym's computer for the ease of upgrading to Windows Vista or Windows 7.  If it is a fairly recent computer the upgrade to Windows Vista would possibly be the easiest to implement.  Although depending on how long Windows has been installed, and if they are having any other difficulties with their Windows XP installation, then they may want to format and install Windows 7 so they can have a nice clean install of the operating system.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 29, 2012 12:28 PM   in reply to selmslie

    Jeff & Selmslie, thank you so much for the answers.

      

    Let me describe my use case, maybe the product team can learn something from it.

     

    I am a fine art photographer, I am shooting in big cities, e.g. I am frequently travelling to NYC, Chicago, Houston, etc. Usually I do about 300 pictures on a typical shooting day, but on some days it can be as many as 800. Therefore, I travel with a laptop and process, tag and backup photographs on the same day. Lightroom is a central piece of my workflow - without lightroom it just won't be possible to work through so many pictures.

     

    I have a powerful laptop with a large screen that is 5 years old, it runs XP and it has 4GB of RAM which is its maximum.

     

    Upgrading to Win 7 is not an option for several reasons. I just cannot allow an OS kernel which is 5 times bigger than XP's kernel because I really need this memory for Lighroom and Photoshop and my huge photographs (100 to 200MB PSD files). Besides that, I would need to spend weeks for reinstalling and setting up all my software.

     

    Upgrading the computer is not an option as well. Most of my pictures are vertical, e.g. I will need at least 1000 pixels screen height (my current one has 1050) and a minimum 8GB of RAM.  Quoting such a laptop on dell.com will quickly get  you to well above 1000 bucks, plus second battery, backup device (DVD writer or BluRay), docking station, etc - will be around 2K USD. I cannot do it just for the Lightroom.

     

    At some point in the future I will probably need a higher resolution camera and at that point I will have to upgrade the laptop, because I will produce bigger files. Computers will be more powerful at that time, so there is no sense to upgrade the machine now just for the Lightroom. Until that time I will stay with my XP.

     

    Now, I am using lighroom since its launch back in 2007. I even enjoyed a 1st week discount from adobe, dedicated to "early adopters and active beta testers". ;-)

     

    Today  I'm running Lightroom 1.4.1 and it's very unstable with my 40000-pictures library. Sometimes it crashes and sometimes it says "out of memory".

     

    I tried LR 2.0 and it was very slow. Version 3 was supposed to have a huge performance improvement and it does. I have installed 3.6 in demo mode last Friday and it works OK. When  and I click "buy", it gets me to the page selling version 4, which won't run on my XP. Too disappointing. Now you're saying I have to find some reseller that hopefully will be able to sell me an upgrade.

     

    If I'd would do it a couple of weeks ago before lightroom 4 announcement, I would be happy by now with the $80 upgrade via adobe web site. Instead, I have to find some reseller. Well, if I can find a reseller whom I can paypal USD 80 and get a serial number back - I'm OK. If you know one - please suggest. Otherwise, I'll just stay with 1.4.1 until some future time when I'll maybe upgrade the machine.

     

    I just wonder why not just issue a serial number for 3.6 when I already have it installed? Why not make version 4.0 serial number valid for version 3.6?

     

    I worked for Microsoft full time for 4 years, two of them being PM, managing localization of Microsoft Security Essentials (home antivirus) and Forefront corporate antivirus. So I perfectly understand what is test matrix and how much it costs to support an extra OS, so no claims here. I just wonder why I can't use version 4 serial number for 3.6 or continue buying version 3.6 serial from adobe with the same ease as I can do it for 4.0.

     

    Five weeks ago it was possible to upgrade automatically via the web site. But five weeks ago I was too busy preparing for the FotoFest 2012 in Houston. I am telling you so much detail just to make a point that fine art photographers also have time constraints and cannot upgrade software and computers at a schedule dictated by software companies. There at Microsoft we used 'case studies' to describe real customers, their computing routines and habits. I hope that my little case study will help you better understand photographer's needs and constraints.

     

    And I also hope that you'll help me find a simple way to get a valid serial number for my already-installed Lightroom 3.6 (demo more) on XP to convert it to full mode.

     

    Thank you so much,

     

    Gennady

     

    http://www.gennadymeergus.com

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 14, 2012 12:56 PM   in reply to selmslie

    I'm really bummed out also.   I like to switch back and forth from my laptop XP to desktop win 7 and you can't read a LR 4 catalog in LR3.6 in XP.   **really** annoying and distressing!!

    judy

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 14, 2012 1:45 PM   in reply to Jeff A Wright

    As you might guess, it is a common practice for a photographer to work on the images at their desktop then put the catalog on an external drive so that we can use them in the sales room on the system there - then after the consultation take the revised catalog (with changes made during the sales session) back to the desktop for final retouching and ordering.  My desktop is Win 7 and my laptop (sales room) is XP.  How the heck am I going to do this now? 

    Lightroom is awesome - but we need a work-around here. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 14, 2012 2:15 PM   in reply to Dan Busler

    The question here: how long should Adobe (or any other software supplier) support old operating systems?  The answer clearly isn't "for ever", or Lightroom would run on DOS. 

     

    XP is 11 years old.  Vista came in January 2007 (full release) but was regarded by most as such a dog that most users skipped it, and were still installing XP when Windows 7 shipped in 2009.  That means 3 year old machines may well have been shipped with XP.  On that basis (given that for most purposes we can ignore Vista) it seems a bit remiss of Adobe not to support the operating system of choice until 3 years ago. 

     

    On the other hand, LR4 really does need a fast modern machine.  Touch and go, but I can sympathise with Adobe not supporting XP. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 14, 2012 2:32 PM   in reply to CSS Simon

    There are similar restrictions on the Mac, AND there is no 32 bit Lightroom 4.  You complain of not being notified of the limitation.  Did you consider reading the system requirements?  Time marches on, people.  And so must you.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 14, 2012 2:34 PM   in reply to CSS Simon

    I totally agree,  XP is on my old system, but XP is still used on many systems that photographers are using for their main processing workstation.

     

    For now I can export the images from the LR4 system to JPEGS and then just import them into LR 3.6 in the sales room for client consultations, make the cropping etc revisions and then import just the changed images into LR4 for the final retouching of the original RAW images ..

           

     

    Date: Thu, 14 Jun 2012 15:15:17 -0600

    From: forums@adobe.com

    To: danbusler@hotmail.com

    Subject: Re: Lightroom 4 on XP Lightroom 4 on XP

     

     

     

     

     

     

          

               

               

               

        Re: Lightroom 4 on XP

     

     

        created by CSS Simon in Photoshop Lightroom - View the full discussion

     

     

     

    The question here: how long should Adobe (or any other software supplier) support old operating systems?  The answer clearly isn't "for ever", or Lightroom would run on DOS.   XP is 11 years old.  Vista came in January 2007 (full release) but was regarded by most as such a dog that most users skipped it, and were still installing XP when Windows 7 shipped in 2009.  That means 3 year old machines may well have been shipped with XP.  On that basis (given that for most purposes we can ignore Vista) it seems a bit remiss of Adobe not to support the operating system of choice until 3 years ago.   On the other hand, LR4 really does need a fast modern machine.  Touch and go, but I can sympathise with Adobe not supporting XP. 

     

     

         Replies to this message go to everyone subscribed to this thread, not directly to the person who posted the message. To post a reply, either reply to this email or visit the message page: Re: Lightroom 4 on XP

         To unsubscribe from this thread, please visit the message page at Re: Lightroom 4 on XP. In the Actions box on the right, click the Stop Email Notifications link.

          

         Start a new discussion in Photoshop Lightroom by email or at Adobe Forums

      For more information about maintaining your forum email notifications please go to http://forums.adobe.com/message/2936746#2936746.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2012 8:55 AM   in reply to Dan Busler

    How long to support an old OS?

     

    As long as it is used at least 4% of Potential Customers.

     

    Statistics presents usage of 50% Win7, 30% WinXP, 9% Mac, 5% Linux, 4% Vista.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2012 9:15 AM   in reply to jdf84d68fj4

    Try actually reading the explanation for withdrawal of XP rather than quoting meaningless stats: Lr 4 cannot - ever - run on XP, because some of its capabilities are based on OS-level functions that XP simply does not support.

     

    Or do you think that Lr 4 should be reverted back to the level of capability delivered by Lr 3? Because then it'd be Lr 3, and none of us would be better-off.

     

    You need to deal with the fact that Adobe's hands were tied here: this wasn't an arbitrary decision made just to spite XP users, it was an unavoidable result of the fact that XP is functionally incapable of supporting what Lr 4 does.

     

    And I want what Lr 4 does, thanks...

     

    Let's have another look at the stats, too: http://www.w3schools.com/browsers/browsers_os.asp

     

    By the current rate of decline of XP, it'll be less than 20% by the end of this year.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2012 9:28 AM   in reply to Keith_Reeder

    Keith, are you saying it would have been physically impossible to implement LR4's features on XP?  If so, which features?  I believe CS6, including ACR7 (with all the PV2012 functions) runs on XP. 

     

    LR4 may well use operating system features not implemented in XP, but to say that those features physically can't be implemented in the application would be surprising. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2012 11:14 AM   in reply to CSS Simon

    Video and DVD burning were the new features which would have been too costly to implement on XP.

     

    It's irrelevant that ACR / PS CS6 runs on XP - the markets are different and there's a bigger installed base (see here).

     

    Also my estimates, based on visitors to 2 Lightroom-only websites, are that about 6-8% of the total LR userbase is on Windows XP.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2012 10:08 AM   in reply to CSS Simon

    CSS Simon wrote:

     

    Keith, are you saying it would have been physically impossible to implement LR4's features on XP?

     

     

    That's what I've been led to believe from umpteen previous discussions on the subject, Simon - discussions which included input from the likes of Eric Chan and Jeff Schewe.

     

    Here's something dredged up in a few seconds' search, a statement (with my emphasis) from Adobe employee Brett N: http://forums.adobe.com/message/4483814#4483814

     

    "So, your computer (the physical hardware) being able to run Windows Vista is not the same thing as your OS (Windows XP) being able to run Lightroom 4. It is simply too old and lacks much of the programming to run LR4."

     

    Take-away message - "Lr 4 needs things from the OS that XP cannot deliver".

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2012 10:21 AM   in reply to Keith_Reeder

    Thanks.  I think my point is rather a picky one: I don't doubt what you say, or what the two Adobe people say on that other thread.  My guess is that it would theoretically have been possible to implement LR4's features on XP, perhaps with more difficulty or poorer performance (or greater development cost, to develop capabilities not provided by XP).  But if they're saying XP support wasn't a practical option then I'm not about to say that's the wrong decision. 

     

    However, even if I'm right that doesn't alter the thrust of your argument.  For whatever reason: LR4 uses features not in XP, and that is not going to change. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2012 11:23 AM   in reply to Keith_Reeder

    If at least Adobe would continue to support the Lr3

    or make an Lightroom Light Limited...

     

    What is unsurpassed in XP SP3, the file size? Memory? Disk size?

     

    About statistics: Yes XP declines but I expect it to stay over MacOS for very long time.

    Another stat: http://www.gnuupc.org/operating-system-statistics

     

    Windows XP-SP3 was released on 2008, Windows 7 on 2009.

     

    Never say never...

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2012 11:37 AM   in reply to jdf84d68fj4

    For all you who are still running Win XP:

    Don't invest too much in XP and programs that run only under XP. Microsoft will end their support for XP on April 8, 2014; see here: http://windows.microsoft.com/en-CA/windows/help/end-support

     

    The time for XP is running out.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2012 2:14 PM   in reply to web-weaver

    Yes WinXP support will possibly end in about two years. But life of XP doesn't stop here.

    The best for computers up to 4GB of RAM is Linux or Win XP.

     

    Better suggestion is: invest in programs that support both XP and W7.

     

    I don't know another program than Adobe Lightroom, which would cancel

    support for XP so much forward.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 7:23 AM   in reply to john beardsworth

    I don't see why they couldn't just leave off those two features for an XP version.

     

    That said, I could live with LR 4 if only LR 3 could read its catalog, and I could edit some things on my XP laptop that I've already worked on some on my win 7 desktop.   LR 4 can read the LR 3 catalog.   **why** not vice versa??    Just this change would make me not all that unhappy with the change.  I just wish I hadn't upgraded at this point.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 7:34 AM   in reply to judy04

    No, Lightroom 4 cannot read or use Lightroom 3 catalogs.  It has the code to convert older catalogs to the Lightroom 4 format, but that is all.  Once the catalog has been converted the "compatibility" ends.

     

    Windows XP is an old operating system, people.  Mac users keep finding that older versions are no longer supported, and they don't even have 32 bit support any more.  Times change, and you have to change as well.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 8:38 AM   in reply to selmslie

    In regards to the original post, no super-special "warning" is to be expected from Adobe.  A very basic rule of thumb when purchasing any software is to check the system requirements first.  I'll admit that I get lazy sometimes and don't bother to do this, but it's not as if it's the software company's fault!

     

    @OP:  Sure, it sucks that you bought LR4 thinking it would work on Windows XP, only to be severely disappointed.  I can sympathize.  And, sure, this is the first version of Lightroom that doesn't work on XP.

     

    At the same time, its all right there in the publicly-available list of system requirements... nothing was hidden from you.  If you took all of a few minutes to check the requirements, there would've been no surprises at all.  I really don't think that Adobe ought to have to plaster huge warnings all over their LR4-related pages to effectively punch you in the face with the news that LR4 doesn't work on XP.  Software buyers have always been expected to read the system requirements... its a pretty fundamental part of the software-buying process.  That LR used to run on XP until the latest version is really beside the point.  Check the system requirements from now on (it only takes a minute) and I guarantee you'll never have this problem again with any software, even many years into the future.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 10:25 AM   in reply to selmslie

    I run LR4 on Windows 7 32-bit... so I'd say it has more to do with Windows XP (at least as far as Windows goes... I don't use Macs).

     

    Indeed, people have gotten quite worked up over this.  I mean, I think it really as to do with the fact that people are so divided over their opinion of operating systems.  For example, I have commonly heard the argument that "Vista was a disaster", as you say.  Not for me... worked just fine... no complaints.  Maybe Vista was indeed a disaster for some, but certainly not all.  I mean, the average Joe or Jane that bought a computer with Vista installed (i.e. the average users that comprise the bulk of the computer-using community) was really pretty indifferent on the issue.

     

    So the moment that somebody says "so-and-so operating system is crappy", some people offer resounding agreements while others sit there scratching their head wondering what was so profoundly bad about it.  And, as with opinions on car manufacturers, for example, people who've had a bad experience with a given operating system have a tendency to vehemently insist that everyone in the world had the same problems.  This, of course, is not the case... so any severely polarized arguments about the quality of an OS are going to generate equally polarized responses.

     

    The real divisive issue here is that, in a world where the average computer arguably becomes a dinosaur in 5 years, there's a significant portion of the population that feels like Windows XP users will clutch at the more-than-a-decade-old OS until somebody finally forcefully pries it from their aging fingers.  I will admit that my own viewpoint lies more along these lines.  And the viewpoint on that side of the argument is that "windows xp users need to move on at some point" and that they are gonna be pissed about it no matter when it happens... so why not just start prying now.  Yes, Windows XP was good n' all, but for many people its getting to a point where its over-stayed its welcome, especially when people that are quite happy with Win7 machines see comments on the Adobe site where people claim that Adobe "ought to be ashamed" for not supporting XP, as if it's some kind of obligatory qualification for any software worth it's salt.  Nonsense!  There is nothing to be ashamed about... that's honestly more than a bit melodramatic.

     

    The people on this side of the argument sort of think," You've been able to use the same OS for 10 years... that, in itself, is a miracle."  How much longer did you really think it would last?

     

    And, sure, I'll admit that that may be a rather insensitive viewpoint that doesn't take into account the requirements of many users which, for this reason or that, still use XP.  But, at the same time, I really feel like this is less about XP being some "super-amazing" operating system and more about people being angry that they might have to upgrade a computer earlier than they preferred in order to use LR4.  Understandable... but also inevitable.  Maybe Adobe could've tried to hold off on dropping XP support for LR4 by disabling menus or the such, but how long is it going to go on for? LR5? LR6?

     

    I imagine that some would try to say that," Adobe should just support XP entirely until Microsoft drops support for XP."  Yet, earlier in this thread, somebody wrote something like, "Just because MS is dropping support for XP doesn't mean its going away."  I mean, there comes a point where it's just unreasonable to not finally upgrade... take your pick between Vista or 7... even Win8 will be out later this year.  You've got no shortage of choices... and if you truly believe that they are all terrible... well, you really need to re-evaluate the situation.  There needs to be some point at which XP users are willing to adopt a "new XP"... either that, or simply accept that their aging choice of OS is going to become more and more of an inconvenience for them with the progressively greater loss of support that will undoubtedly occur over the next few years.

     

    Hell, I've never enjoyed laying down the cash for a new machine... it sucks... and it's expensive.  But, I've also had no choice but to do it a half-dozen times over the past 14 years or so... that's just the nature of the digital beast these days, guys.  It's not Adobe's fault... and, quite honestly, it's not Adobe's problem... not in a mean way... just in a frank and practical sense.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 2:44 PM   in reply to selmslie

    Windows XP is 11 years old now.  There are lots of new APIs that are in Vista and 7 and it is WAY MORE WORK to build that functionality into Lightroom if supporting 3 platforms was necessary.

     

    Would you expect to still be using Windows XP 5 years from now?  How long should Adobe be saddled by customers that want to use an OS that hasn't seen active feature development in almost a decade?

     

    Also, most photographers aren't "major corporations" and aren't saddled by legacy IT environments with all sorts of crapware that manage the machines.  Upgrading (or buying a new machine) more frequently than every 5 years is probably a reasonable expectation for folks who buy a new camera that shoots RAW more than every 5 years.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 2:53 PM   in reply to selmslie

    It's a dead horse. I suppose that if people want to keep beating it, no harm will be done, but it isn't going to pull the cart anymore.

     

    I'd suggest finding something more fun and profitable to do than to endlessly complain about dropped support for your favourite operating system--support that isn't going to get undropped.

     

    Hal

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 3:16 PM   in reply to Hal P Anderson

    I agree.  It might make you feel better to complain, and to threaten Adobe that you will take your business elsewhere.  But the reality is that it isn't going to do any good.  This thread could go on for months.  If that's the way you want to entertain yourself then go ahead.  It isn't going to change anything in this regard.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 3:27 PM   in reply to JimHess

    I agree with Jim, and I do not think this thread can lead to any further meaningfull discussion. Maybe a moderator could make a decision here!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2012 1:00 PM   in reply to DdeGannes

    Forget about the OS wars, just let us know where to buy a working license for Lr 3.6 on Win XP!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2012 1:20 PM   in reply to timoisalive

    As Adobe doesn't sell Lr 3.6 any more you have to find a 3rd party vendor (Amazon? B&H?).

     
    |
    Mark as:
1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points