Skip navigation
phpandcss
Currently Being Moderated

how to undo broken image link

Apr 28, 2012 9:56 PM

I got this image that I sliced in photoshop, but when I created a link for it my whole page becomes broken up into lines and squares. what is the best way to undo this effect? I created the css rule that udoes the blue border and that still doesn't take care of the problem.Screen Shot 2012-04-28 at 9.53.10 PM.png

 
Replies
  • Currently Being Moderated
    Apr 28, 2012 11:37 PM   in reply to phpandcss

    Not sure why that is happening without seeing the code. You will have to upload the page and supply a link to the page in question. The constuct from what I can see in the image supplied looks a bit fragile. If you exported the html directly from Photoshop usually that doesnt make a good job of it.

     

    You could try this css below:

     

    <style type="text/css">

    img {

    display: block;

    }

    </style>

     

    Insert it in the pages code directly before the closing </head> tag near to the top of the page.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Apr 29, 2012 12:08 AM   in reply to phpandcss

    You don't just slice your PSD directly. DW is not just a simple slice linking tool. It's a lot more than that. Photoshop should be used purely only for creating your graphics and you can only slice backgrounds for patterns. You must use CSS to style all your elements, regardless small or big.

     

    Regarding your question, post an active link to your webpage and we'll look into it.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 29, 2012 8:37 PM   in reply to phpandcss

    Are you not understanding the requests for you to provide us with a link to your website? You have a problem in your code. The only way for us to help is to see your code.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Apr 29, 2012 10:37 PM   in reply to phpandcss

    You're missing a = in your a href code.

     

    Change this:

     

    <a href"http://gigster.info/index.html/"><img src="images/home.gif" width="144" height="45" alt=""></a></td>

    to this:

    <a href="http://gigster.info/index.html/"><img src="images/home.gif" width="144" height="45" alt=""></a></td>

    in all your links.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Apr 29, 2012 10:37 PM   in reply to Sudarshan Thiagarajan

    ALso, remove the trailing slash at the end of your link ending with .html

     

    <a href"http://gigster.info/index.html/"><img src="images/home.gif" width="144" height="45" alt=""></a></td>

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points