Skip navigation
Currently Being Moderated

Canon S100 RAW color issues

May 1, 2012 10:48 PM

Tags: #lightroom #raw #lion #mac #canon #4 #s100 #lightroom3.6 #canons100 #lr4 #lightroom4

Hello, all. I created a thread with this similar issue a few months ago but never really got it resolved. Instead of reviving an old thread, I decided to just recreate it with updated information.

 

I have the new Canon S100 and I am having an issue with how the RAW files appear in Lightroom.

 

I import the photos into a Lightroom catalog and they all look fine within the importer window (which shows essentially what a JPEG would look like), but when I click on the photo in Library or Develop, once the photo finishes loading, the red saturation goes through the roof.

Any photo that already had a little bit of warmth to it exploded with red.
Whereas any photo taken in normal light gains a little more warmth and exposure.

 

Here are a couple examples of the JPEG preview (also how it looks in-camera) compared with what the RAW looks like once it's been loaded in Lightroom. (The above or left photo is the “normal” version, the bottom/2nd image is the RAW)     

S100 1.jpeg

S100 2.jpeg

S100 3.jpg

S100 4.jpg

S100 5.jpg


It’s sort of difficult to tell with some of the photos by looking at them side-by-side. I also have the individual photos if you want to A/B them to see the changes that are actually occurring.

 


There are no presets being applied upon import.

The only solution I've found is to convert them all into JPEGs using Canon's software (which does not alter the images as seen above), and edit them in Lightroom as JPEGs, but that completely eliminates the point of buying a camera that is capable of shooting in RAW.

I’ve been having this issue since the S100 first came out (when I purchased it) with Lightroom 3.6RC and was told that it would be fixed in Lightroom 3.6… which it wasn’t… nor was it fixed in Lightroom 4.
I decided to just go ahead and convert all my photos to JPEGs until I found a fix to this so I could at least have my photos (I had photos from my anniversary with my girlfriend in November that I couldn’t do anything with so I was sick of waiting).
I figured I’d wait till more people had the camera, expecting this issue to be more widespread… but now that a lot of people have the S100, I’ve looked around and found no other instances of this happening… so I’m worried it’s something on my end.

 

I have a 2008 13” MacBook Pro running OSX 10.7.3 and I have the latest version of Lightroom (4.0) and Camera Raw (7.0) installed. I’ve tried the photos in Photoshop CS5 and it does the same thing. When this first happened back in December I tried the photos in Aperture as well and it did the same thing.
The only software that seems to recognize the true color of the photos is Canon’s horrible “professional editing” software.

 

Thanks in advance.

-Patrick

 
Replies
  • Currently Being Moderated
    May 2, 2012 12:30 AM   in reply to pmartin089

    But presumably you can just simply alter the white balance on the RAW file and then remove some red right? LR's controls are so advanced this could be done in two seconds. I assume DPP is adjusting for the foibles of the sensor and LR isn't but the end result would be the same.

     

    So what's the problem or am I missing something?

     

    David

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 1:01 AM   in reply to pmartin089

    Looks like you're screwed then

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 6:20 AM   in reply to dhphoto2012

    The WB is significantly off toward the red in the first theatre photo, perhaps the camera is picking up on the blue safety lighting so Adobe’s S100 profile being slightly more overly red isn’t anything they need to fix, I don’t think.

     

    The WB seems to be daylight in the second mixed-lighting photo, keying off of the window-light from the purse instead of the bulb near her face.  Again, the wrong WB is not something Adobe needs to fix.

     

    The skin-tones are a little more red in all the photos, but the others look ok because the WB is ok and there’s no mixed lighting is picking up on.  You can’t blame Adobe for the camera choosing the wrong WB, only yourself for not fixing it.

     

    Are these with the Camera Standard camera profile in the Camera Calibration section or Adobe Standard?

     

    Do you know how to synchronize the WB across multiple photos using the Sync button in Develop?

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 9:32 PM   in reply to pmartin089

    With the Canon point and shoots (I've used the G3 and G11), I've found that if the available light is rather red eg the tungsten lighting that many of these images are shot under, then Adobe RAW rendering is definitely a bit redder.

     

    But they are going to be different from the jpegs - that  is the point really. Lightroom is there to allow you to get different results from the jpeg using the RAW images. You  use the lightroom controls to get the results you want, without being tied to the exact rendering that Canon thinks you should have. If you want the same as the jpeg then use Canon's software.

     

    Having said that, there isn't a huge amount of difference between the Canon jpegs and the Lightroom ones that I can see. The first two have shocking white balance in both, and would be much better if corrected so the skin colour was less tangerine. To sync WB across multiple images with the same lighting, get the first one right, then select all the ones you want to change, with the correct one active on the screen, hit the sync button and on the pop up menu just tick off the white balance option and then the synchronize button.

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 10:09 PM   in reply to pmartin089

    pmartin089 wrote:

     

    I think you're missing the point entirely. The problem is that Lightroom is modifying the image from its original form.

     

     

    I think YOU are missing the point, there is no such thing as an "original form"...all raw images are monochromatic sensor dumps of the electrons captured by the sensor. You really don't want to look at a real raw file, it really sucks…so, any raw converter must do a "default" raw to rendered processing. Canon has their black box SDK which they try to make "look" good. Camera Raw and Lightroom do a more "normalized" rendering of the raw file. It's probably much more "accurate" (if there is such a thing for raw files) but there's no way it's gonna match the Canon SDK because, well, Canon's raw processing is proprietary and not used by ACR/LR.

     

    You think the Canon "look" is more accurate? That's only because it matches the look on the camera LCD. If you fall in love with that look, the only option for retaining that look is use Canon software…

     

    Otherwise, I suggest you learn how to use the ACR/LR controls to get what you want out of a raw file and change your "defaults" to match what you think you want. But just understand, the camera LCD is the raw file processed by Canon to look like THEY want it to look and then converting it to sRGB for the LCD display. There's a lot of processing going on to get it to look like that. If you want to match that, you can but you'll have to learn how to use the ACR/LR controls to get your image they way you want. Look, it's not rocket science…you just need to know how to use the controls in ACR/LR and understand that Canon's "look" and ACR/LR's "look" will NEVER match unless you do the work to make it match.

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 11:44 PM   in reply to pmartin089

    pmartin089 wrote:

     

    but telling me I "need" to know how to fix the problem isn't going to help me fix the problem.

     

    But that's the point, there isn't a problem. You just aren't using the software the way it was intended and are blaming it.

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 6:38 AM   in reply to pmartin089

    In the first photo, the stage lighting is very red.  The S100’s AutoWB is guessing the wrong WB.  The S100 apparently has some sort of fix-people’s-skin processing that mitigates the overly-red WB-detection problem.

     

    LR has a way for the photographer to correct the WB down to about 2000K, but no lower, but LR does not have a “fix-the skintones” processing, so the photos taken in overly-red lighting and using the incorrect camera-determined As-Shot WB look very red until you correct the WB, and since LR’s WB only goes down to 2000K, things are still a little too red, because the illumination coming from the left in the photo is very, very red, perhaps from red curtains.

     

    In the second photo, there is bluish daylight from the left, and reddish tungsten light from the right.  This is mixed lighting and while not red to the extreme, you’re still going to have to decide what area of the photo is more important, things illuminated from the left, or things illuminated from the right.  The camera decided the WB was closer to the bluish daylight so made everything else more reddish which makes the back of her head look right, but not her face as far as the WB is concerned, but the camera fixed the skintones and things look better despite the more daylight WB.  In LR there is no “fix-the-skintones” so you’ll have to adjust the WB for her skin to look right and let her hair on the left be a little blue instead of having her hair the right color and he skin be too red as it is when using the As Shot WB.

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 9:02 AM   in reply to ssprengel

    Here are Before/After views of the first two, too-red photos, where the only change is to modify the WB.  You had posted links to the RAW files in the discussion from a few months ago.

     

    Using LR to adjust the WB is not the same as the S100's apparent ability to fix skintones despite the camera guessing the wrong WB, but it makes the photos look acceptable. 

     

    In the first photo, the camera detected 2900K / +6 for the temp and tint, and this would be reasonable for incandescent lighting, but there is something much more red illuminating the faces from the front, so even setting the WB down to 2000K leaves things a little too red, but that is as low as LR will go.  Further tweaks with the red or orange or yellow ranges in the HSL Color Adjustments might fix things a little more, but WB is all I've changed, here.

     

    In the second photo, with mixed lighting, I shifted the WB from the camera-detected 4050K / -8, which is slightly closer to daylight than incandescent, to exactly what LR calls Tungsten:  2850K / +0.  The hair in the back that is illuminated by daylight is now more blue, but not unreasonably so, and since this is mixed lighting, I would probably move the WB up a little more, just not as much as the camera detected. 

    2012-05-02_190653.jpg2012-05-02_185624.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    May 5, 2012 3:15 AM   in reply to pmartin089

    Some of these photos look familiar to me, deja vu...

     

    Seems to me there are 2 issues:

    1. Lightroom (allegedly) handling white balance less consistently than camera/mfr software (or something like that affecting skin tones...).

    2. Default settings are reddish...

    (3. How to fixup...)

     

    I don't have a clue about #1, but if you solve #2 you may find you have less problems with #1:

    (ssprengel has already given good advice regarding #3)

     

    Download DNG Profile Editor and make yourself some profiles that look better to you.

     

    My experience with G12:

    * Camera matching profiles are not so good (unlike the D300 where the camera profiles are quite good).

    * Adobe Standard is better, but runs bright and reddish, with warm greens and cyany blues.

     

    You can use a 24-color chart to normalize profile for your camera and/or tweak color manually (via color tables and/or color matrix hue and/or white balance calib.) Also consider a tone curve which drops the mids/highlights a smidge (for at least one variation anyway).

     

    Patrick - I know you want Adobe to acknowlege S100 is being slighted and bring it up to what you would consider more of a par. But it may take a while (maybe forever). You may find it very empowering to take control of this problem yourself (DNG Profile Editor) in the mean time...

     

    Here's a recipe to start with, but you may not like it:

    http://www.robcole.com/LrForumSupport/Adobe Standard (RC Debright +CC).zip

    (I recommend deleting the color table or replacing it with one created from a shot using your S100)

     

    Please let us know how it goes if you do decide to take this bull by the horns...

     

    Rob

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 8, 2012 5:41 AM   in reply to pmartin089

    I had a similar situation on my S100 with red and blue of the sky. In camera calibration drop the red saturation and  adjust the blue tone and save it to a preset. Works for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 16, 2012 8:39 AM   in reply to pmartin089

    I recently bought an S100 and encountered the same problem. With Camera Standard in Lightroom, Reds are too bright, greens are shifted towards yellow, and some yellows are shifted towards orange.

     

    I have been using Lightroom since the beta, with different cameras from different manufacturers. The camera profiles for the S100 are the worst I have experienced by far. The profiles, particularly all of the profiles that start with "Camera," do not fit this camera. I believe somebody made a mistake. It could have been someone at Canon, it could have been someone at Adobe. I don't expect this mistake to be fixed, or even acknowledged.

     

    Moving on, here is my workaround:

     

    Start with the Powershot S110 Camera Standard profile.

    Use dcpTool to decompile the profile.

    Open the decompiled profile in a text editor.

    At the top, change the name to S110 Standard.

    At the bottom, set the baseline exposure offset to zero.

    At the bottom, change the model restriction from S110 to S100

    Use dcpTool to compile the modified profile. Give the resulting .dcp file a different name than the original.

    Put the new .dcp file in the appropriate directory, open Lightroom and apply the S110 Standard profile to your S100 images.

     

    dcpTool is here:

     

    http://dcptool.sourceforge.net/Introduction.html

     

    This hacked S110 profile gets rid of the blazing reds. It does have some problems with yellows and greens. I solve this in Lightroom by using +20 in Camera Calibration: Green Primary: Hue. I haven't had my camera very long, and I may end up making other adjustments in Lightroom. But using the Powershot S110 Camera Standard profile seems like the best place to start.

     

    I tried using Adobe's DNG Profile Editor app on the S110 "Camera" profiles, but did not get good results. From what others have posted on Adobe's forums, this is to be expected. A lot of the "Camera" profiles are too complicated for DNG Profile Editor to work well on. Both the S100 and S110 Camera Standard profiles have over 23,000 lines of code when decompiled!

     

    I also tried dcpTool (and DNG Profile Editor) with some of the other S series and G series profiles, without finding anything that works better than the S110 Camera Standard profile.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2013 3:03 PM   in reply to pmartin089

    Recently I bought a Passport Colorchecker. I made some color profiles for the S100, and they work well for me. Here is a link to a google drive folder containing the profiles:

     

     

    https://drive.google.com/folderview?id=0B8zQMOs6acYVZFZfUm5UWUJ2VGc

     

     

    Notes:

     

     

    The color is the same in three profiles: Passport Standard, Passport Neutral, and Passport Adobe. Only the tone curve changes. Colorchecker Passport software does a good job on color, but not on tonality. I used dcpTool to decompile the Passport profiles and discovered that they do not include a tone curve at all. I believe the default raw curve is used, which does not work well with the Canon S100. I decompiled the stock S100 profiles with dcpTool and added the Camera Standard, Camera Neutral, and Adobe Standard tone curves to the Passport profile.

     

     

    The Passport Night profile is made from a different raw file, exposed under artificial outdoor lighting at night, and the color is different. I used the stock S100 Camera Neutral tone curve on this profile. The Passport Night profile is a work in progress. It is a starting point for artificially lit outdoor night photos.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points