Skip navigation
Currently Being Moderated

Importing DXF loses layers

May 4, 2012 4:59 AM

Despite the option to "merge layers" in the AI DXF import dialog, I find that in fact when I import a DXF it all ends up in a single layer (whether that option is ticked or not).

 

The DXF comes from the British government "Ordnance Survey" mapping agency. It has several dozen layers in it.

 

Each layer has its own Autocad color number (dxf group code 62) and AI correctly notices this and assigns the right colour to each object. But it always merges the layers.

 

Any fix for this?

 
Replies
  • Currently Being Moderated
    May 4, 2012 5:06 AM   in reply to PeterFacey

    If you are using CS3, they had a problem with everything going to one layer.

     

    http://helpx.adobe.com/illustrator/kb/updated-dfx-dwg-plug-illustrator .html

     

    If not CS3, what version are you using?

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 9:17 AM   in reply to PeterFacey

    You'll probably have to recreate the layers. If infact everything is color coded then it is simply a matter of choosing everything with a given color and placing it on a new layer. Use the Select Same Fill/Stroke (as appropriate) and just drag the little square at the right end of the layer line to the new layer. It will probably help to turn off the visibility of the layer as you complete each just to keep track.

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 10:12 AM   in reply to PeterFacey

    I would download a map myself and try but it seems they send you a disk and I am not sure if they charge or not.

     

    Is there somewhere we can have access to a map or portion of a map file to test?

     

    Are you ate liberty to post a file?

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 11:28 AM   in reply to PeterFacey

    I use cs5 for importing DXF and DWG files with layers all the time. It preserves layers. Upload a link to one of files and I will look at it. You might need to save your DXF or DWG files to an older version or maybe the files are not layered.

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 12:02 PM   in reply to PeterFacey

    I just opened the file in CS5. Layer names were perserved. I did it with the attached preferences. If I check "Merge Layers", it forces all entities to Layer 1.

    su42.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 11:58 AM   in reply to PeterFacey

    It opened the same for me when using Scale to Artboard. Otherwise its off the working area completely.

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 12:56 PM   in reply to PeterFacey

    Mine is 17.4 MB and is dated Sep 22, 2011 which is probably when the software was installed.

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 1:03 PM   in reply to PeterFacey

    Mine is Windows version. It is closer to 7mg. Make sure you uncheck "Merge Layers" when importing.

    DxfDwg.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2012 1:59 PM   in reply to PeterFacey

    I'm on a Mac.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points