Skip navigation
Currently Being Moderated

Premiere Pro CS6 - Video Output (GPU) bad quality...

May 6, 2012 11:56 PM

Hi,

 

I have a question about Adobe Premiere Pro CS6...

I have installed the Trial-Version and use a BM Intensity Pro to output Full-HD 1080i (50, Interlace) trough HDMI Video-Output...

 

The Video-Output works correctly, but if I enable the "GPU"-Acceleration (CUDA), and scale or transform a Video (for example a 3D-Transformation) the Quality of the transforming is very bad! (jerky, not "smooth", Interlace-Lines etc...)

 

If I deactivate the GPU-Acceleration (Software only Mode), everything is smooth and looks good!

 

Also if I render the Timeline, all tranformations are also smooth, only the Realtime GPU Rendering looks very bad....

 

What can I do?

 
Replies 1 2 Previous Next
  • Jon-M-Spear
    970 posts
    Jan 27, 2006
    Currently Being Moderated
    May 7, 2012 12:57 AM   in reply to Christian1979de

    I'm about an hour behind you and haven't got there yet - but have you updated the BM Intensity drivers to v9.5?

     
    |
    Mark as:
  • Jon-M-Spear
    970 posts
    Jan 27, 2006
    Currently Being Moderated
    May 7, 2012 2:28 AM   in reply to Christian1979de

    It's crashing CS6.  I can make out a parrot - then it crashes.

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2012 6:49 AM   in reply to Christian1979de

    Drag a Clip in your Timeline (Full HD)

     

    On a side note, you said you're using 25 fps interlaced media.  But "Full HD" is defined as 1080 progressive.  So...which is it?  Have you used the wrong sequence settings, possibly?

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2012 6:53 AM   in reply to Christian1979de

    OK.

     

    In a matching sequence?  Is it an Adobe sequence, or a BM sequence?

     

    Does it also look weird on the Program Monitor inside PP, or just on the external monitor?

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2012 9:23 AM   in reply to Christian1979de

    Click the wrench in the program monitor - did you set your playback resolution to full?  If you're using the default (1/2), that's bound to look rotten on a fielded external monitor. Also, try messing with the field display options...

     
    |
    Mark as:
  • Currently Being Moderated
    May 8, 2012 4:07 PM   in reply to Christian1979de

    What kind of system are you operating with? What kind of GPU?

    What are the specs?

    Is the 3D transformation the only problem with output on the GPU?

     

    With CS6, you do not want to use a BMD sequence, use a standard 1080 sequence.

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 12:31 AM   in reply to Christian1979de

    - What version of the nVidia drivers are you using? (You should be on version 296.10, if not, I'd definitely suggest updating)

    - any chance that you can beg/steal/borrow an nVidia card from the supported list to see if it behaves any differently?

    - if possible, I'd like to see a screen grab of the fullscreen mode so we can see what's going on with the video...

     

    Cheers

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 10:13 AM   in reply to Christian1979de

    There are two settings for resolution in the program monitor settings:  there's one for playback, and another for paused.  It sounds like your playback resolution is set to 1/2 (or less), and the paused state resolution is set to Full. That's the most logical conclusion I can come up with.

     

    (Having two separate settings was designed out of supporting things like 4k RED playback - we know that lower end machines simply won't support anything over 1/4 res decodes for realtime playback, but people still want to be able to make out details when they pause on a frame.)

     

    Cheers

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 1:21 PM   in reply to Kevin Monahan

    Hi Kevin,

    just one more opinion.

    Looks like GPU Accelerated video output is always deinterlaced.

     

    I try to find out if the interlaced SD video material is lower or upper first, but it is impossible to see with hardware acceleration on.

    Software Only mode you can see if  it is lower or upper field first.

     

    Win 7 Pro

    GTX 470 (296.10 driver)

    Blackmagic HD extreme2 (9.5.0.0) analog component video connected to old Sony Broadcast tube monitor.

     

    pena

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 2:56 PM   in reply to Christian1979de

    Tschüss Christian,

    yes with 3D effect I saw the same interlacing problems, both with SD-monitor and HD-monitor via HDMI.

    And Software Only was smooth as you have noticed.

    But without 3D effect both Hardware and Software mode were perfect and smooth.

    So it looks like HD is interlaced both Hardware and Software modes, different than my SD.. hmm

     

    This Basic 3D effect combines both fields when previewing GPU Accelerated output, but rendered or exported it is perfect.

     

    pena

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 9:59 AM   in reply to Kevin Monahan

    To clarify, third-party hardware will no longer use special editing modes, but manufacturers may still provide their own sequence presets.  So while Blackmagic users will not use a Blackmagic editing mode in CS6, users may still start with a Blackmagic sequence preset in CS6.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 12:25 PM   in reply to Christian1979de

    Hi Christian1979de,

     

    This matches a bug we have logged internally, #3184520.  The team will be investigating it further.

     

    Regards,

     

    Zac

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 1:02 PM   in reply to Christian1979de

    The bug is still under investigation.  Sorry I can't speak to the timing of a fix.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 1:07 PM   in reply to Zac Lam

    I understand not being able to address timing. I continue to applaud your simply acknowleding an issue and stating that it is under investigation. I love the Adobe presence on the forums.

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2012 8:43 AM   in reply to Christian1979de

    I also recognized the strange effect (CS6 6.0.1.) with effect "warp-stabilizer". With Mercury GPU on I got these lines on playback. When pausing sequence playback the lines/stripes are gone after a short delay (0.5 - 1 second). Rendered clips look o.k., too. When using software Mercury this strange behavior is gone.

     

    After doing some tests with AVEC test patterns I would agree with the others, that Mercury GPU Acceleration is trying to deinterlace all outputs.

     

    I'm using a Matrox MXO2 device but I also tried it without Matrox hardware installed. Effect can be seen on internal Program Monitor, too. So this is definitely no problem with external hardware devices.

     

    Can we hope for a fix in 6.0.2 ?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 13, 2012 4:11 AM   in reply to Christian1979de

    Same problem on my system please take a look at http://forums.adobe.com/message/4465694#4465694

     

    Darren

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 14, 2012 7:28 AM   in reply to Darren Hall

    A very similar problem on my system (PPro CS6 - 6.0.1). We first noticed it when trying to do a crawling title, lots of blur and interlace lines. We have tested with CS4 and CS5.5 and none of these problems exist there.

     

    I've noticed other serious problems with the Mercury Playback Engine outlined here:

     

    http://forums.adobe.com/message/4490294#4490294

     

    I'm kind of wishing Adobe would have included a third option for MPE - "OFF".  ;-)

     

    I'm hoping for a fix soon!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 14, 2012 11:27 AM   in reply to Christian1979de

    Hi Christian,

     

    Generally we can't talk about fixes in unannounced products.  But rest assured we're tracking this issue closely.

     

    Regards,

     

    Zac

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 8:45 AM   in reply to Zac Lam

    It's been almost a month...any news on a fix for this??

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 6, 2012 6:57 AM   in reply to AlanP1964

    I'm with the 6.02 now. This bug is still present. Working on 1080@50i

     

    :-(

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2012 8:36 AM   in reply to zuccon123

    I'm on 6.02 now as well. DV output is still very bad. When can we expect a fix for this?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2012 10:52 AM   in reply to Christian1979de

    Hi Christian, you mentioned if you turn off GPU acceleration, then the fields are properly preserved.  For now, you can use that when you need to lay off the final result to tape.

     

    Alan, from other forum threads I believe your issue is different, since you are not using GPU acceleration.  One common issue I've seen between your reports and others is that you're using PAL DV.   Your issue is under investigation and since we don't want to cause confusion over the two issues, it's probably better to keep that on a separate thread like here:

    http://forums.adobe.com/thread/1019730

     

    Thanks,

     

    Zac

     
    |
    Mark as:
1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points