Skip navigation
Currently Being Moderated

CF 9 Installer won't run on Mac OS Lion

May 6, 2012 6:37 PM

So I'm trying to setup CF 9 on my Mac running OS X Lion and, surprise surprise, the installer won't run. I've run into this wonderful problem on Windows before, but don't remember how I solved it there nor do I know it it would be the same problem. Just to be clear, it's not a failed installation process. The process doesn't even get started, the installer doesn't run at all. I realize maybe they don't support Lion, but even then, something should happen in the installer saying the OS is not supported or something.


I checked the Console logs and this is the error that's coming up:


macbook[94] ([0x0-0x2a6ba69].ColdFusion 9 Installer[96113]): posix_spawn("/Users/tmessier/Downloads/ColdFusion 9", ...): Permission denied


No idea what that really means, I always run installations from this same directory and never had a problem. I'm guessing maybe it's trying to copy the installation files from the archive somewhere and executing from that directory and that fails, but not sure how to remedy this problem.


Any help would be appreciated.

  • Currently Being Moderated
    May 7, 2012 11:13 AM   in reply to tmessier

    I've installed ColdFusion well over 100 times on numerous operating systems and don't recall ever having a problem. So I find your bitterness hard to take. I also get frustrated with people who immediately get indignant about a problem like this, particularly when trying to do something that is clearly unsupported.  CF9 is not supported on Lion, so try not to get so frustrated with Adobe when you are trying to do something that they never claimed you should be able to do.


    That said, I will try to help.


    First, are you aware that Lion does not come with Java?  Did you install it? 


    Second, have you check the execute permissions on the installer. Who owns the file? It doesn't matter if you've run installers from the directory before, files can have their own permission. Perhaps something with your got buggered. Worst case, you could just try setting it to 777 (don't forget that a .app is a package, so you need to recurse file permission changes.  chmod -rf 777 ColdFusion\ 9\


    You could always try downloading the file again.


    Hope that helps. If it doesn't you might also want to check this: chd-peruser-error



    Mark as:
  • Currently Being Moderated
    May 7, 2012 1:45 PM   in reply to tmessier

    Also, I googled "getting coldfusion to run on macos lion" and got a bunch of people detailing how they got it running.


    Have you read all of those, and tried 'em out?


    (sorry, just a Windows & very occasional Linux user, me... so no help when it comes to using a Mac)




    Mark as:
  • Currently Being Moderated
    May 7, 2012 3:06 PM   in reply to tmessier


    Hey Adam, I did read a bunch of things,


    No worries.  I always ask because it never occurs to really a lot of people around here to do some research before posting.  Glad you're not one of them, and that you got your problem sorted.




    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points