Skip navigation
medgno_43
Currently Being Moderated

"Unable to set maximum number of files to be opened" in CS6 trial, CS5 runs fine

May 7, 2012 8:05 AM

Tags: #illustrator #adobe #mac #bug #startup #cs6

Trying to start up the CS6 trial on a mac running OS X 10.7.3, I get the following message: "Unable to set maximum number of files to be opened."  After clicking "OK" on that dialog, Illustrator quits.  Illustrator CS5 runs perfectly, as does Photoshop CS6 trial.

 

Searching for this error showed other people having this on much earlier versions of Illustrator as a result of their maxfiles limit being set too low.  The suggested fix was removing /etc/launchctl.conf to unset the limit.

 

Running `launchctl limit` show my maxfiles hard and soft limits are 10,000.  I do not have an /etc/launchctl.conf file, and running `mdfind launchctl` doesn't show any other config files with that name sitting elsewhere (like in /private).  Finally, I've run Repair Disk Permissions.

 

If anyone has ideas on what I can do to get Illustrator running on my computer, I'd appreciate it.

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    May 7, 2012 9:32 AM   in reply to medgno_43

    Hi medgno_43

     

    Just for confirmation. The build is installed on your machine is the official Illustrator CS6 trial that Adobe made avaliable for download today at this page: http://www.adobe.com/cfusion/tdrc/index.cfm?product=illustrator&loc=en _us ?

     

    Did you try to trash preferences or reinstall Illustrator CS6? Does the problem persist?

     

    Best Regards

    Gustavo.

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2012 10:25 AM   in reply to medgno_43

    Do you have any whiteboard software installed? I think I remember this as being the culprit.

     
    |
    Mark as:
  • Currently Being Moderated
    May 8, 2012 5:32 AM   in reply to medgno_43

    I am having the same issue. I bought the CS6 Standard Suite Upgrade, and Illustrator gives me the exact same dialog, then quits.

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 2:48 PM   in reply to RAILhead

    I'm having exactly the same issue. Cannot do anything to solve it. All the other CS6 programs work but not Illustartor. I installed it from the Design Premium CD I was sent by Adobe. Any ideas anyone?

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 3:27 PM   in reply to Nick320

    Hi

     

    I´ll forward this post to an engineer from Adobe Illustrator Team. Will ask about this problem.

     

    Thank you for bringing this issue. Expect to receive answers soon.

     

    Best Regards

    Gustavo.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 4:44 AM   in reply to Gustavo Del Vechio

    Hi Friends

     

    I´m in contact with an engineer from Adobe Illustrator Team.

     

    Could you please tell us if the SMART Product Drivers 10.6 are installed on your systems? http://smarttech.com/us/Support/Browse+Support/Support+Documents/KB3/1 46595.aspx

     

    Also...could you please tell us if it happens to old Illustrator version?

     

    This info will help the engineer to find the problem.

     

    Thank you a lot

    Gustavo.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 6:06 AM   in reply to Gustavo Del Vechio

    Hi Gustavo

    Thanks for the help...I don't think the SMART Product Drivers are installed. When I follow the procedure within terminal that you sent me to above, I get this:

    Screen Shot 2012-05-10 at 14.00.35.png

    My Illustartor CS5.1 is still working fine.

    Hope that helps.

    Cheers,

    Nick.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 7:38 AM   in reply to Nick320

    Hi Nick

     

    This is a note from the engineer:

     

    "Launch terminal window on your Mac and type in ulimit. If you get anything other than unlimited you should change it back to unlimited.  There are plenty of web resources that you can use to find out more about this command and how to change it or you can ask on one of the MAC forums.

    If you see the value unlimited and still see the error you should report back the bug to Adobe: https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

     

    Gustavo.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 8:28 AM   in reply to Gustavo Del Vechio

    Hi again Gustavo.

    Thanks for the suggestion but it hasn't helped!

    I tried the above and I get unlimited:

    Screen Shot 2012-05-10 at 16.17.59.png

    I've reported the bug as you suggest on the link you sent.

    Fingers crossed.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 9:26 AM   in reply to Nick320

    Hi Nick

     

    Thank you

     

    Your form is already with the engineers.

     

    Thank you a lot

     

    Best Regards

    Gustavo.

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2012 3:09 PM   in reply to medgno_43

    Having the same issue from a fresh install today from the Creative Cloud. I don't have any SMART driver software installed and ulimit shows unlimited for me as well.

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2012 1:36 PM   in reply to Ian Kelleigh

    Is there an ETA on this? Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    May 16, 2012 8:29 AM   in reply to medgno_43

    I'm having this exact problem with my newly downloaded Illustrator CS6.  It worked all day yesterday, and today I have this message.  Tried all the terminal commands as instructed above and no change.

     

    CS 5.1 is working fine.

     

    Any update on this issue is much needed.

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2012 2:05 AM   in reply to amcoWork

    Create a new user accunt on your mac login using the newly created user and see if it changes things for you. Make sure you also have the latest OS updates installed on your mahine

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2012 7:38 AM   in reply to ADBEDesigner

    Yes, when launching Illustrator CS6 under a new user account, it runs fine. But how do I get it to run with my real account?

     

    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2012 9:02 PM   in reply to Ian Kelleigh

    Hi Ian,

    Glad to see it works for you.

    I reccomended a new user account to remove few variables. I have tried this on numerious occasions when I see something weird happening only for me. If it runs fine under new account that means you need to review one of the softwares in your startup or some MAC OS settings. Troubleshooting this may take lot of time, If you are short on time maybe you should just copy files from the old account and start using the new one.

     

    -- All the best

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 4:26 AM   in reply to ADBEDesigner

    Hi guys

    Just to let you know. I just updated the OS (to 10.7.4) and now it works! I've done nothing else. I'll let you know if it keeps working.

    Hope that works for you.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 5:48 AM   in reply to medgno_43

    I also encountered this issue on MAC OSX 10.7. I tried many hit and trials and finally found a way to launch Ai, though it is just a workaround. I followed these steps:

     

    1. I created shell script which can launch Ai. You can download this shell script from the location: http://dl.dropbox.com/u/47167182/launchAI.command.zip.

    2. Unzip the folder and drag the launchAI.command file into your dock area. (Please verify the application path, since I have installed AICS6 on default location)

    3. Click launchAI.command icon in the dock.

    4. A terminal will appear asking your user password, enter your password to see if AI launches successfully.

    5. If you don't like typing password  for each run, you can edit /etc/sudoers file to add a line "%staff ALL=(ALL) NOPASSWD: ALL" . (Replace staff with your user's group name).

     

    Please see if this workaround also works for you.

     

    All the best!

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 6:56 AM   in reply to ADBEDesigner

    ADBEDesigner, do you have any suggestions on where to start looking for software that would modify this max open files option? My OS is the latest version (10.7.4).

     

    Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 6:57 AM   in reply to Nick320

    @Nick320: Even reinstalling 10.6 would have worked or just creating a new account. Most of these issues impacting few users are related to OS settings.During the course of our working we install many softwares and few of these even change the default settings at times we also change settings that we do not recall changing.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 7:00 AM   in reply to creative_nick

    Creative_nick, that script works perfectly. That's really strange, what is different about how this is being launched versus just launching the app normally? BTW, during launch I get this error in the terminal window:

    2012-05-18 06:57:59.647 Adobe Illustrator[69428:3e03] CFURLCreateWithString was passed this invalid URL string: '/System/Library/Frameworks/' (a file system path instead of an URL string). The URL created will not work with most file URL functions. CFURLCreateWithFileSystemPath or CFURLCreateWithFileSystemPathRelativeToBase should be used instead.

    2012-05-18 06:58:22.879 CS6ServiceManager[69443:a03] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x1d03, name = 'com.adobe.csi.CSServiceManager.3'

    See /usr/include/servers/bootstrap_defs.h for the error codes.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 7:16 AM   in reply to Ian Kelleigh

    Ian:  is is very difficult to pin point the software that would have modified it. I suggest you should have a look at all applications or hardware installed and most likely culprit could be products that deal with databases, network operations or file management systems. Cant really tell as we do not have this issue at computers at our office.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 8:27 AM   in reply to Ian Kelleigh

    Ian,

    This all is related to permissions that are avaialable to the process. When you launch the app with terminal (with the script that I provided), AI is invoked through shell and inherits the shell quota. It also gets sudo permissions so that AI is now able to change the limit of number of open files.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 8:31 AM   in reply to Ian Kelleigh

    CS6ServiceManager[69443:a03] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x1d03, name = 'com.adobe.csi.CSServiceManager.3'

    Ian, Did you deny participating in Adobe PIP (Product Improvement Plan)? I have seen such an error in that case.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 8:35 AM   in reply to Ian Kelleigh

    do you have any suggestions on where to start looking for software that would modify this max open files option? My OS is the latest version (10.7.4).

    @Ian: Please look for files /etc/launchd.conf, $HOME/.launchd.conf or /etc/sysctl.conf. These are the common files where the limit may exist.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 9:02 AM   in reply to creative_nick

    Thanks Nick. I couldn't find any of these files (and yes I knew to make sure the system files were visible to search in them). In the mean time I will keep using your script solution right now. It works and that's all I wanted. Cheers!

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 10:31 AM   in reply to Gustavo Del Vechio

    Hi,

    I had the same problem after upgrading from CS5 to CS6.  I found this solution: http://www.smarttech.com/us/Support/Browse+Support/Support+Documents/K B3/146595.aspx

     

    This solved my problem

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2012 4:24 AM   in reply to creative_nick

    The solution with the shell script works perfectly.

     
    |
    Mark as:
  • Currently Being Moderated
    May 22, 2012 10:51 PM   in reply to ergon_g

    Script works, however it appears it's required to run everytime to open Illustrator. Is that correct?

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2012 3:28 PM   in reply to medgno_43

    I really really really REALLY hope that Adobe is paying attention to this issue.

     

    I've now had this issue happen intermintantly on two different computer, neither of which have ever had the SMART software installed on them and neither that appear to to have the launchd.conf or sysctl.conf (unless I'm missing some kind of setting to reveal this files, but I doubt it as I'm going through terminal on an admin account). 

     

    One of the computers is essentially a totally clean instal with nothing on it other than MS Office and Adobe CS 6.

     

    Thankfully the script Nick made is working, but its crazy to have to resort to this.

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2012 9:06 PM   in reply to amcoWork

    @amco: create a new user account and run Ai after logging into it. does it work. At times we think our machines are clean but softwares do get installed on our machines e.g unknown ones like device drivers or known ones like MS office. One thing is however certain Adobe enginers did not enocounter this before they shipped it.

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2012 6:27 AM   in reply to creative_nick

    The script launches Illustrator just fine.

     

    I had this issue when I first installed CS6, but after a restart, Ai started working normally. I go to launch it today, and I get the error at startup again. BUT, this screipt works -- now Adobe just needs to figure out what's going on instead of putting the brunt of the work on us. CS5 Ai works just fine. I don't -- and never have -- had Smart installed, nor any app like it.

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2012 6:36 AM   in reply to RAILhead

    I receive the following Terminal error when I use the script:

     

    2012-05-24 08:34:34.189 Adobe Illustrator[56601:3e03] CFURLCreateWithString was passed this invalid URL string: '/System/Library/Frameworks/' (a file system path instead of an URL string). The URL created will not work with most file URL functions. CFURLCreateWithFileSystemPath or CFURLCreateWithFileSystemPathRelativeToBase should be used instead.

    2012-05-24 08:34:38.874 CS6ServiceManager[56607:a03] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x1d03, name = 'com.adobe.csi.CSServiceManager.3'

    See /usr/include/servers/bootstrap_defs.h for the error codes.

     
    |
    Mark as:
  • Currently Being Moderated
    May 31, 2012 10:40 AM   in reply to RAILhead

    No word from Adobe on this?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 4, 2012 6:23 PM   in reply to Ian Kelleigh

    Strangly enough, the problem seems to have fixed itself at some point. Maybe after a restart, not really sure. But my preferences were all reset which is fine, but now I don't have to use that terminal command.

     
    |
    Mark as:
  • Ivan David
    135 posts
    Jun 9, 2010
    Currently Being Moderated
    Jun 14, 2012 3:38 AM   in reply to Ian Kelleigh

    Thought I'd consolidate the useful replies to the OP, and add the inputs I've received form the Illustrator Engineering team.

     

    On Mac OS, Illustrator usually launches with normal user account permissions (non-privileged). To maximize performance, Illustrator tries to increase the maximum number of files to be opened.  Mac OS does not restrict or limit Illustrator from increasing the maximum number of files that can be opened. However, a system administrator or third party software may place such restrictions on the maximum number of files that can be opened by a process, by adding a system preference to configuration files.

     

    When such a file limit setting is enforced, a process like Illustrator that is starting with normal user account permissions fails to launch.

     

    The possibility of such a system preference being added to your configuration files is higher if you have installed SMART Product Drivers 10.6 (See KB article http://www.smarttech.com/us/Support/Browse+Support/Support+Documents/K B3/146595.aspx). But, here's a procedure to isolate and fix the problem even if it is not SMART product drivers that tweaked this system preference.

     

    You need to first check for the file limit system preference, and then try solution 1 or 2.

     

    Check if your computer has this system preference:

     

    1. Check if these files exist in your system:

      •     /etc/launchd.conf,
      •     $HOME/.launchd.conf
      •     /etc/sysctl.conf.

    2. If you find any of the files listed above, check for a setting like:

    limit maxfiles

     

    Solution 1: If the system preference exists on your computer:

     

    1. Create a backup of the file that contains the file limit setting
    2. Open the file with editing permissions. For example, sudo vim <filepath>
    3. Find the line that contains the setting, and delete it by pressing dd.
    4. Save the file and press !wq to quit vim.
    5. Reboot and launch Illustrator CS6.
    6. If the error persists, there is a chance that this setting is being enforced from a different location. Perform the actions outlined in Solution 2.

     

    Solution 2: If the system preference does not exist on your computer:


    1. Download the shell script attached with this reply.
    2. Unzip the file, and drag the launchAI.command file into your dock area. Do verify the application path; the command file assumes that Illustrator CS6 is installed at the default location.
    3. Click launchAI.command.
    4. In the terminal that appears, enter your user password, and check if Illustrator CS6 launches successfully.

     

    If you don't like typing your password every time you launch Illustrator:

     

    1. Open the /etc/sudoers file in editing mode.
    2. Add the following line to the file:

      %staff ALL=(ALL) NOPASSWD: ALL

    3. Replace staff with your user's group name.
    Attachments:
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 15, 2012 12:41 AM   in reply to Ivan David

    Ivan David,

     

    We know how to work around the issue, and launch illustrator with a shell script as root user. But that is merely a workaround and does not fix the issue...

     

    Fact is that under my normal user account, I have NO file limit setting of any kind:

     

    bert@bertbookpro ~> ulimit 
    unlimited

     

    But still I get the error message displaying the "Unable to set maximum number of files to be opened" error, while I have no files that exists where the ulimit setting could be present:

    bert@bertbookpro ~> cat /etc/launchd.conf
    cat: /etc/launchd.conf: No such file or directory
    bert@bertbookpro ~> cat ~/.launchd.conf
    cat: /Users/bert/.launchd.conf: No such file or directory
    bert@bertbookpro ~> cat /etc/sysctl.conf
    cat: /etc/sysctl.conf: No such file or directory
    

    (which means that this solution also does not work)

     

    THAT is the core problem, so there has to be a real solution to this instead of a workaround, so I can run Illustrator under my normal user account...

     

    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 15, 2012 6:50 AM   in reply to Bert Devriese

    I know. I almost feel like installing then uninstalling those drivers to see if that fixes it because right now I don't have any of those files sitting around.

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points