Skip navigation
Currently Being Moderated

I can’t launce Photoshop CS 6 from within Lightroom Properly.

May 10, 2012 12:51 PM

Tags: #photoshop #lightroom4

I'm using LIghtroom 4.1 RC2 Camera Raw 7.1 RC, CS6 Master Collection Trial Version, Windows 7


This is a known issue / conflict with the Photoshop 6 Beta and Windows UAC that seems not to have been resolved (See detailed description below)?? If anyone knows of a workaround I would be VERY Grateful… Turning UAC off is not an option nor does it rectify  the problem.


When I select an image right click and choose Edit In “Edit in Adobe Photoshop CS6…” Windows throws a UAC User Account Control warning “Do you want to allow the following program to make changes to this computer” choosing yes opens Photoshop CS6 but the image is never created. I have to exit out of Photoshop. After Photoshop has closed (And a few minutes) Lightroom will then display “The File could not be edited because Adobe Photoshop CS6 could not be launched…” I then get a second UAC User Account Control warning “Do you want to allow the following program to make changes to this computer” and the file is created and opens up in Photoshop. (The last part never happened in the Beta but at least Lightroom now creates a .psd file (In the Beta, I had to first create the PSD using Photoshop 5.1)


However I still can’t get Lightroom to open a dng as a smart object in Photoshop Edit In /  “Open up in Photoshop as a Smart Object” to work at all!! This is ultamatly what I would perfer to be able to do.




This info below was posted here -


Unfortunately it doesn’t seem that the problem with User Profiles (where the user profile doesn’t reside in the default location C:\Users\XXX) has been resolved… took two days but I finally was able to down load and install Master Collection…


In Windows there is an Administer Icon on lower 1/3 of the Photoshop Icon, indicating that you need to “Run As Administrator” which wasn’t present in the Beta. And when application is launched “User Account Controls” does prompted you “Do you want to allow the following program to make changes to this computer”


On the - Adobe Photoshop CS6 (64 Bit)\Photoshop.exe I have changed the “Change Settings for All Users” to “Run this program as Administrator” but as with the Beta I still get the User Account Controls prompt each time I launce Photoshop!


It was a real problem with Lightroom 4… I was never able to create a smart object  psd in Lightroom. And creating a psd file required that I create the PSD using Photoshop 5.5 and only after creating the 5.5 PSD could I open the file in Photoshop 6.


Is there some stem that I have missed or some other work around???

  • Currently Being Moderated
    May 11, 2012 1:17 PM   in reply to evan.sante

    Sorry, I should have posted my findings on this original post (new to this forum stuff). But yes, I tried this on my Mac and it still doesn't work. I've pretty much given up at this point too and just pray that Adobe comes up with a viable solution soon.

    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 7:16 AM   in reply to evan.sante

    I think I've found the solution.  Simply right click Lightroom go to compatability and check run as administrator.  Seems to work for me. 


    I think the issue is that Lightroom doesn't have the privilege to access the RAW module in CS6 by default.  So what it has to do is create a .tiff copy and get photoshop to open that.  Allowing Lightroom administrator privilege seems to fix that.


    Edit: I think the 32bit workaround works by getting Lightroom to directly create a tiff file off the bat so you aren't actually using the Raw 7.1 module at all.  It's what Lightroom does in the original post when it can't access photoshop.

    Mark as:
  • Currently Being Moderated
    Aug 11, 2012 10:39 PM   in reply to josephlck

    I had the same problem - unable to open photoshop cs6 by clicking on edit in photoshop on an image in lightroom.  I followed josephlck's advice.  I clicked on the properties of lightroom 64, photoshop cs6 64, and photoshop bridge cs6 64 and set all to run as administrator.  Now I can open and edit an image from lightroom in photoshop without any of the 32-bit dodge discussed.

    Mark as:
  • Currently Being Moderated
    Aug 16, 2012 3:53 PM   in reply to pizzachef84

    On a Mac, how does one go into LR's compatibility? I've been searching and can't figure out where the 'run as administrator' option is.

    Mark as:
  • Victoria Bampton
    5,302 posts
    Apr 1, 2008
    Currently Being Moderated
    Aug 17, 2012 4:09 AM   in reply to idc215

    IDC, that's a Windows command.  Can you tell us exactly what's happening on your machine?  And which LR version and which Photoshop version?  Is everything updated with the latest updates?  And do you see the same issue with all file formats?

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points