Skip navigation
randomguyinHB
Currently Being Moderated

Premiere Pro could not find any capable video play modules

May 9, 2012 5:34 PM

I downloaded the trial of Premeire Pro CS6 today, and after I launched the application, it said "premiere pro could not find any capable video play modules".

 

Tried again, no luck.

 

My graphics card is at the latest driver that HP has out.

 

What should I do before I give up?

 

HP DV7t Quad 17'' Laptop

i7 2720

AMD Radeon 6770HD (Switchable Graphics)

8GB Memory

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    May 10, 2012 1:22 PM   in reply to randomguyinHB

    I downloaded the trial of Premeire Pro CS6 today, and after I launched the application, it said "premiere pro could not find any capable video play modules."

    I'm having the same issue and can't figure it out. I have tried too many things to remember and put down!

     

    Here is my computer setup:

    HP h8-1080t Quad w/ i7 Quad-Core Processor

    Windows 7 Professional

    NVIDIA GTX-580 (using driver version 295.73)

    24 GBs DDR3 RAM

     

    I have tried using previous driver versions - didn't work

    I have tried creating another account on my computer - didn't work

     

    Is there an answer out there? It appears my computer is setup according to Adobe's recommended specs - but I can't get Premiere Pro or Prelude to start. All other programs work great!

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 1:47 PM   in reply to Enrique1972

    This must be a bug or some issue with Premiere Pro CS6. This is what I did to solve the issue.

    1. I put the shortcut to open Premiere Pro on my desktop.
    2. I right-clicked the icon and selected "properties"
    3. Once the Properties window opened, I selected the "compatibility" tab.
    4. Under Privilege Level I checked "Run program as administrator."
    5. Then I clicked "OK."

     

    Now Premiere Pro and Prelude opens with no issue! But each time I open one of these programs, I have to click "yes" in the security window that comes up asking if I want this program to make changes to my computer. Now - how can I stop that from coming up?!?

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 2:36 PM   in reply to Enrique1972

    >click "yes" in the security window

     

    As far as I know, that is simply the way Windows works... but you may search at Microsoft for Windows help

     

    http://search.microsoft.com/search.aspx?mkt=en-US&setlang=en-US

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 11:32 PM   in reply to randomguyinHB

    For some reason it stopped working for me. It was great for a while today. What is the problem?!? I wanted to get this straight due to my software coming in the mail this coming Wednesday. If I open it and can't use it - I'm stuck. The trial version works great except for Premiere Pro and Prelude. Anyone have a solution yet?

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2012 8:39 AM   in reply to Enrique1972

    Has any one found a solution? every other CS6 app works fine but PP yet my laptop (same as the one mentioned above, HP dv7) is well within the specs (2.5gb 1920/1080 /w OpenGL 2) it is however a Radeon dualed with an intell HD... could this be the issue (dual cards OR Radeon) as I have noticed Adobe plastering Nvidia all over the website and the laptop won't initeate the higher end card until the program launches (i have mannualy configed it but have noticed that games that set the graphics before loading (Skyrim, Witcher2) willnot detect the higher graphics card, nore will dxdiag) have included some screne shots to hopefully help.

     

    Clipboard01.jpg

     

    Clipboard02.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2012 10:12 AM   in reply to HippoHQ - Paul Shaw

    I was able to resolve this problem on a laptop. In the AMD control panel, the main GPU selected was the Intel integrated video card that come with the processor instead of the more powerfull AMD video card.

     

    So, for those of you out there that have an Intel processor with the integrated GPU, make sure adobe premiere isn't using the Intel GPU to launch.

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2012 1:39 PM   in reply to alexandrepitre

    > I wish Adobe would help.

     

    This is a user-to-user forum. If you want guaranteed help from Adobe, you need to contact Adobe Technical Support: http://www.adobe.com/support/contact

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2012 5:42 PM   in reply to Todd_Kopriva

    I have gone in and set every application (including the GPUSniffer) to run on the high preformance GPU and updated to the latest catalyst controll center but still no luck, is there a way to force the launcher to use the AMD GPU without going through the catalyst controll center?  Also the contact page doesn't include any NZ details.

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2012 5:56 PM   in reply to alexandrepitre

    I also am having this problem .  An AMD card HD6470, 1GB memory card.  Both Premiere Pro and Prelude do not work.  There is also an Intel card

     

    I have set both to use the Radeon card when they start. 

     

    Tried all of the info in this thread and others still I cannot use either program. 

     

    Going to try a uninstall / re-install on Prelude and premiere Pro to see if that corrects it.

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2012 6:31 AM   in reply to randomguyinHB

    There are many different steps you can try to resolve this error.

     

     

    1) Recreate preferences.

     

     

    Go to start & type "%appdata%" in the search box & you will see a roaming folder in the search results.

     

    Open the roaming folder & then go to the adobe folder & then the Premiere Pro folder. Inside you will find the 6.0 folder. Right click on that & select rename & change the folder name to "6.0old".

     

    Then try launching Premiere Pro while holding down the shift key while it loads the various components on the splash screen.

     

    (Holding down the shift key refreshes the plugin information)

     

     

    2) Update the NVIDIA & AMD drivers to the latest version. Do not run the automatic update. Manually go the NVIDIA or AMD website & then look up the latest available graphics drivers for your graphics card & then download & install them.

     

     

    NVIDIA - http://www.nvidia.com/Download/index.aspx?lang=en-us

     

    AMD - http://support.amd.com/us/gpudownload/Pages/index.aspx

     

     

    3) Try disabling the startup items & services at some services running in the background could be blocking access to the graphics card for Premiere.

     

     

    Click on start & type in "msconfig" in the search box & press enter.

     

    It will open the System Configuration utility. Under general>startup selection select the option for selective startup & then uncheck "load startup items".

     

    Go to the "services tab" & make sure to check the option for "hide all microsoft services" (Very Important)

     

    Then click on disable all.

     

    Now go through the list of services that are given & check any of the following adobe services you might find in the list like :

     

    FlexNet Licensing Service

    Adobe Switchboard

     

    After checking the above services click on apply>ok>restart.

     

     

    After restart try to launch Premiere Pro again.

     

     

    Note : To re enable all your services again open the System Configuration utility again using "msconfig". Under general>startup selection select the option for "normal startup". Click on apply>ok>restart. This will reenable all your services.

     

     

    4) Try logging in to the hidden administrator account.

     

     

    Click on start & type "cmd" in the search box. At the top of the windows you will see cmd in the search results. Right click on that & select run as administrator.

     

    It will open the DOS prompt windows.

     

    In that type in "net(space)user(space)administrator(space)/active:yes" & press enter.

     

    You should get the message comand completed successfully.

     

     

    Close the window & restart your computer. After restart once you get to your login page you will see a new account called administrator. Login to the account & then try to launch Premiere.

     

     

    For those users for whom the above DOS command does not work might have the administrator account disabled, just try to create a new administrator type user account & then try to launch Premiere in the new user account.

     

     

    The above steps should solve the problem for atleast NVIDIA card users. For AMD card users it might not solve but I am looking into it & I will post try to post further steps after research.

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2012 9:44 PM   in reply to randomguyinHB

    http://helpx.adobe.com/prelude/kb/error---preludevideo-play-modules.ht ml

     

    this worked for me after several days with Adobe and HP for HOURS!

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2012 11:49 PM   in reply to Enrique1972

    It does work, wonder if it will age the laptop any faster.

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2012 1:36 AM   in reply to randomguyinHB

    If yours is HP pavillion g4 2002tx and adobe is not treating ur AMD radeon HD 7670m as the primary video card, then go to control panel-->system and security

    -->power options-->(look for 'personalization' at bottom left)-->(look for 'display' at bottom left)-->Change display settings-->advanced settings-->go to 'Adapter' tab

     

    Try to disable the Intel Graphics 4000 in the 'Properties' key. Adobe should work then. But might have prob if you need the intel graphics again. but you can always revert your settings using a earlier restore point for windows. Please correct me if there is any wrong and i hope it helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Jun 5, 2012 12:58 AM   in reply to myselfof86

    go to control panel-->system and security-->power options-->(look for 'personalization' at bottom left)-->(look for 'display' at bottom left)-->Change display settings-->advanced settings-->go to 'Adapter' tab

     

    Try to disable the Intel Graphics 4000 in the 'Properties' key. Adobe should work then. But might have prob if you need the intel graphics again. but you can always revert your settings using a earlier restore point for windows. Please correct me if there is any wrong and i hope it helps.

     

    I might be able to add something here...

     

    I've got a Dell Inspiron 15R, with an AMD Radeon HD 7670M, so I tried the same thing to force the dedicated GPU as default, but I found that if I disabled the Intel Graphics 4000 adapter, Windows (7) reverted to the VgaSAVE driver...

    (I also tried the BIOS, but that didn't give me any graphics options at all, and 'run as administrator' didn't work either... that just returned the standard 'no video play modules' error...)

     

    The only way I could get it working was to open up Catalyst Control Center and manually add the Premiere Pro exe file to Power/SwitchableGraphics/OtherApplications... I know that hasn't worked for everyone, but I haven't had any problems since...

    (Also set both 'PowerPlay' settings to maximum performance if you're still having problems...)

     

    If this worked for you, I know it's a bit of an annoying way to configure your system just to get applications to run properly, but once you've set up your core high performance programs, it's really handy for conserving power. After I got Premiere Pro working, I went ahead and did the same thing for Photoshop, Illustrator and Flash, but not Audition (so I can scrape a little more juice out of the battery when editing audio tracks on the road...)

     
    |
    Mark as:
  • Pierre Courtejoie
    7,052 posts
    Jan 11, 2006
    Currently Being Moderated
    Jun 11, 2012 3:09 AM   in reply to John.Ritchie

    A user in the French forum is in the same case, with a HP DV7. He deactivated the intel GPU, and is facing lower resolution with his Radeon HD7470M.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 13, 2012 11:56 AM   in reply to randomguyinHB

    Hey, I found a solution that worked for me!

     

    I'm a long time Adobe Suite user, had CS5.5 on my laptop and everything worked great. Updated to the CS6 suite and everything worked fine except for Premiere Pro 6. I was getting the "Could not find any capable video play modules. Please update your video display drivers" error.

     

    I have a HP Pavilion dv6 (Win 7) with a Intel® Processor Graphics 3000 and AMD Radeon HD 6700M Series Display Adapter.

     

    I tried the tip above to disable the Intel Graphics and and it reverted to the VgaSAVE driver instead of my AMD Radeon. My resolution shrunk down to 1024 but Premiere CS6 now opened without a problem. Working with the low resolution, however, was just not an option.

     

    So I went on the HP website and although Windows said my Intel Graphics 3000 driver was up to date (9/3/11), I found a newer driver (1/21/12). Here's the driver link:

     

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3231&Dwn ldID=20841&ProductFamily=Graphics&ProductLine=Laptop+graphics+drivers& ProductProduct=Intel%C2%AE+Core%E2%84%A2+Processors+with+Intel%C2%AE+H D+Graphics&lang=eng

     

    I installed it, restarted my computer, and now Premiere CS6 opens up with no problems.

     

    Hopefully this helps!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 13, 2012 6:38 PM   in reply to Enrique1972

    I am riunning Win7 64 bit using a Desktop with 16 GB of RAM, an Intel i7 2600K processor and a Radeon 6970 GPU. My motherboard is an Asus P8Z68-V Gen 3 Mobo and the rig is self built. I am using Lucid Logix Virtu to dual task my use of the built in Intel Graphics 3000 (driver 4/29/12) in my system with my 6970 GPU (Driver 4/4/12). This works perfectly on every other program I have on my computer including CAD programs and all Microsoft Programs, Nikon's CNX2 64 bit and I can even run CS5 Production Premium Pro without problem. I tried running CS6 Premiere Pro as an Admin and it started, so thre is obviously some bug in CS6 since it worked before in CS5 and  all my drivers are up to date. the idea of disableing my dual graphics configuration just to run this Adobe program does not appear to me to be the kind of solution Adobe should be putting forward. IF you made it work in CS5 you can make it work in CS6 without workarounds.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 13, 2012 6:53 PM   in reply to robsbphotog@comcast.net

    >tried running CS6 Premiere Pro as an Admin and it started, so thre is obviously some bug

     

    Not so obvious to me... I have CS5 and I MUST use the "Run as Administrator" option with Encore to create a dual layer DVD... but not with a single layer DVD... which is an "oddity" of Win7 permissions

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 13, 2012 8:02 PM   in reply to robsbphotog@comcast.net

    After dinking around and rechecking all my drivers which are the very latest, I was still not able to run Premiere Pro or Encore, some of my other programs in CS6 seemed a bit unstable, i.e. they loaded but were either sluggish or hung. So I rebooted and then set Premiere Pro and encore and the other programs that seemed a bit skittish and set them up to all run as Admin. Problem solved! Everyone of them booted OK without problem. So now the question is why is this necessary in CS6 and not in CS5 (at least not in my set up though others have said they need to run some stuff in CS5 as Admin. I hope Adobe looks at this and comes up with a general fix.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 13, 2012 8:07 PM   in reply to robsbphotog@comcast.net

    There is a fix, that has been around for ages, and that is to log in to Windows as an administrator.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Jun 14, 2012 12:07 AM   in reply to alexandrepitre

    I think I have the same problem.  But how can I change my video card that Adobe Premiere isn't using the Intel GPU to launch.

     

    Tim

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 15, 2012 12:35 AM   in reply to randomguyinHB

    Hello I had a similar problem and I fixed it changing a parameter in the BIOS, as suggested here (same problem for Prelude)

    http://helpx.adobe.com/prelude/kb/error---preludevideo-play-modules.ht ml

     

    The steps you need are:

    1) restart your computer

    2) press F10 to access the BIOS while restarting

    3) change the Switchable Graphics from Dynamic to Fixed.

     

    That worked for me.

    Roberto

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2012 10:18 PM   in reply to randomguyinHB

    Hi I had a similar problem with my Vaio VPCCA35FG and I found this solution which worked for me

    1. Go to Catalyst Control Center/Graphics Properties

    2. Choose Power/Switchable Graphics Method

    3. Change from "Select the graphics processor based on application needs." to "Select the graphics processor manually or based on power source."

    4. Click Apply, wait for a few screen flashes and you are all set to start Premier Pro CS6

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2012 1:41 PM   in reply to Enrique1972

    Hi all,

     

    I have an HP DV6, 6 gb ram, radeon HD 6490M and apparently an Intel?  I downloaded the trial, but I am looking to buy the full CS6 master suite at the end of the week, but don't see the point if Premiere won't run!!

     

    I have tried some of your suggestions; i.e. changing properties to "administrator"; logging in as secret administrator; tried looking for somewhere to change the display type, no luck, have a radeon, but can't find a separate control panel; changing the folder name and using shift!

     

    ummm... any suggestions would be fantastic as I really want the software, but Premiere is one of the reasons I am thinking of buying it.

     

    Can anyone please help??

     

    thanks

     

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2012 3:23 PM   in reply to thedarksword

    According to http://www.newegg.com/Product/Product.aspx?Item=N82E16834158580 that has a screen of 1366 x 768 - which will not work

     

    Some ideas for a Laptop Video Editing PC from past discussions

    http://www.adkvideoediting.com/

    http://www.sagernotebook.com/ - http://forums.adobe.com/thread/957472

    .

    For effective HD video editing, a laptop with the following

    -at least the Intel sandy bridge 2720 or 2820 quad processor

    -and nvidia graphics such as the 460m with 1Gig video ram

    -1280x900 display with OpenGL 2.0-compatible graphics card

    -and 8 or 16 gig ram and Win7 64bit Pro

    -and 2 internal 7200 HDDs minimum

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2012 11:24 PM   in reply to thedarksword

    Hello thedarksword

    have you tried changing the BIOS settings as described at 25.

     

    The steps you need are:

    1) restart your computer

    2) press F10 to access the BIOS while restarting

    3) change the Switchable Graphics from Dynamic to Fixed.

    Roberto

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 7:40 PM   in reply to thedarksword

    Hi.

    I had the same problem and I found a solution.

    Apparently, it has something to do with the Radeon graphics card.

     

    1)Go to Catalyst Control Center (Right-click on the desktop and click on "graphics properties")

     

    2)Click on the option "Power"

     

    3)Click on the option "Switchable Graphics Method"

     

    4)Choose the option "Select the graphics processor manually.", and apply it.

     

    5)Go back to "Power" and this time, click on "Switchable Graphics"

     

    6)Verify if it's written "High-performance GPU" in the text box. If not, click on the option "High-performance GPU" below.

     

    That should work. Enjoy!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2012 12:03 PM   in reply to New Realm Media

    Here's a more complete document with solutions for Premiere Pro for this issue:

    http://bit.ly/Mur4jo

    Error: "Premiere Pro could not find any capable video play modules"

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 11:22 PM   in reply to Mch32463

    Hello from France

     

    i've got the trouble with PPRO with a  NVIDIA GE FORCE GTX 460.  behaviour varies from one driver to another.

     

    driver 295.73 : pb ("ppro could not find any capable play module"  where AE or PS are running correctly).

    driver 295.51 : No pb !

     

    But the main issue is the automatic upgrade that goes me to the wrong version !

     

    please hel.

     

    regards, Philippe.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 11:25 PM   in reply to Posorus

    Update your driver to at least 301.42 or 304.79

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2012 8:17 AM   in reply to Harm Millaard

    Hi,

     

    Unfortunately, the 301.42 doen't recognize the GTX 460 and nver heard about the 304.79. file not found in Nividia web site.

     

    regards, Philippe.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2012 8:23 AM   in reply to Posorus

    use the nVidia Hack http://forums.adobe.com/thread/629557 - which is a simple entry in a "supported cards" file

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2012 8:23 AM   in reply to Posorus

    Weird.

     

    nVidia_driver.png

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 25, 2012 11:05 AM   in reply to Pallav A

    I am having the same problem. My graphics card is Nvidia 9800 GTX+. Drivers are up to date. I have gone through all the steps described above  and still unable to get Premier Pro 6 to start up. Had been running verion 5/5.5 successfully before. Any other thoughts out there? I am about to uninstall and go back to previous version?

     

    Later that day..

     

    OK, I now know why I can't get it to run. I ran GPUsniffer and found that it was rejecting my card due to insufficient memory.  My 9800 GTX+ has 512mb of memory. That seems to be less than the minimum required.  Guess I either have to upgrade my card or go back to last version.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 25, 2012 11:54 AM   in reply to DCW02

    You "should" be able to use "just about any" card with CS6... but in software only mode if the card has less than 1 gig of video ram

     

    If you have the card name entered in the supported cards file, you will have to reverse the hack and remove the name

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 26, 2012 11:03 AM   in reply to John T Smith

    Thanks. From what I have read, that is only a MAC fix. I am using Windows 7 and not sure what the equivalent is. I turned off CUDA support on my card and recreated the preference folder but that didn't seem to do it.

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points