Skip navigation
NMS25
Currently Being Moderated

Installing problem for Premiere Element 10

May 13, 2012 7:08 PM

Tags: #photoshop_elements_10

I am having trouble installing Adobe Premiere Elements 10 to my computer it keeps coming up with "This installation package is not supported by this processor type. Contact your product vendor".  I have no idea what this means and I want to be able to fix this problem. I hope you can help me?

 
Replies
  • Currently Being Moderated
    May 13, 2012 9:56 PM   in reply to NMS25

    Moving to the premiere elements forum.

     
    |
    Mark as:
  • Currently Being Moderated
    May 14, 2012 3:17 AM   in reply to NMS25

    Check you are not trying to install the PC version to a Mac, or the Mac version to a PC.

    If you are trying to install from a download version, try downloading it again, making sure you pick the right version (PC or Mac) for your computer.

     

    Cheers,

    --

    Neale

    Insanity is hereditary, you get it from your children

     
    |
    Mark as:
  • Currently Being Moderated
    May 14, 2012 6:53 AM   in reply to NMS25

    What are the full specs. of your computer? The more info, the better.

     

    There are minimum system requirements, including the SSE instruction set, used by the CPU.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2012 4:50 AM   in reply to NMS25

    Good to hear you got it sorted. For the benefit of others, who may have a similar problem, will you please post the details of how you fixed it.

     

    Cheers,

    --

    Neale

    Insanity is hereditary, you get it from your children

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2012 11:13 AM   in reply to NMS25

    Can you please share how you fixed it? I'm having the same issue.  Thanks!  I'm running Windows XP, but was able to download and operate Elements 10 successfully...

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2012 1:30 PM   in reply to flockjam

    >was able to download and operate Elements 10 successfully

     

    This IS the forum for Elements... do you mean you are able to run PHOTOSHOP Elements, but not PREMIER Elements?

     

    Did you review the system requirements? http://www.adobe.com/products/photoshop-premiere-elements/tech-specs.h tml

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2012 1:40 PM   in reply to John T Smith

    Thanks - I got it. I already had Photoshop Elements 10 running just fine.  Apparently my older computer runs on 32 bit and I was trying to load the wrong cd for Premiere (the 64 bit).  Thanks for your time!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2012 1:42 PM   in reply to flockjam

    O and sorry if I posted in the wrong forum - the top question here was regarding "Installing Problem for Premiere Elements 10" so I thought I had the right group.  Anyhoo, I'm good now! Thanks again!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points