Skip navigation
Currently Being Moderated

App rejected again. This is imposible!

May 16, 2012 12:40 AM

Tags: #app #dps #apple #rejection

Our client got rejected again, this time not due to content, but due to app behavior.

 

Here's what the apple review says:

 

We found that your app exhibited one or more bugs, when reviewed on iPad (3rd Gen) running iOS 5.1.1, on both Wi-Fi and cellular networks, which is not in compliance with the App Store Review Guidelines.

 

When the app is launched, no content is displayed. We've added one or more screenshots for your reference.

 

This is the screenshot:

Rejection Photo.png

 

It's a v19 multi issue with subscription app.

The clint has 2 issues in the cloud, one free and one In-App purchase.

 

What's wrong???

 
Replies
  • Currently Being Moderated
    May 16, 2012 2:45 AM   in reply to Adi Ravid

    Did you check the developer.ipa before submission to Apple? Was it working in the developer.ipa on an iPad3? If the issue is only limited to iPad 3 and works on iPad 1/2, most likely problem is related to renditions. If you have published renditions for ipad1/2 and ipad 3 then make sure to manually select the publication date in folio producer when you publish your renditions. The product id, Folio name and other data should also match.

     
    |
    Mark as:
  • Currently Being Moderated
    May 16, 2012 5:25 AM   in reply to Adi Ravid

    I had the exact same issue during the release of v19. I had to rebuid the app viewer with v18 as well as a lot of messing about with rolling back to early versions of the folio producer tools etc.

     

    I suggest you rebuild your viewer with v18 and see how the developer.ipa behaves on your various iPads.

     
    |
    Mark as:
  • Currently Being Moderated
    May 16, 2012 5:53 AM   in reply to Adi Ravid

    @Adi : It should work fine on iOS 5.1.1 if it works on 5.1, Can you cross check by updating your iPad 3 to iOS 5.1.1 and testing your developer.ipa in 5.1.1?

     
    |
    Mark as:
  • Currently Being Moderated
    May 16, 2012 6:09 AM   in reply to Adi Ravid

    I think that's possible. I have had an app approved that takes ages to load the library. It does eventually load, so it can't be rejected for not working as intended.

     
    |
    Mark as:
  • Currently Being Moderated
    May 16, 2012 6:09 AM   in reply to Adi Ravid

    Most likely that did not cause the issue as the outage was only for a few hours yesterday, there were no issues reported with this behaviour due to the outage.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points