Skip navigation
Microbilla
Currently Being Moderated

Cs6 slow, lagging performance

May 16, 2012 11:53 PM

Tags: #photoshop #help #cs6

As in the title, I have Photoshop cs6 and I cannot make it work properly. It's almost as the program was running on a much slower system. Common optimization has given no results. I can wait 5 seconds or more before seeing the effect of a command or brush stroke.

Cs5 gives no such probelms. I have a 64 bit Windows 7, but 32 and 64 bit versions behave the same.

 
Replies
  • Currently Being Moderated
    May 17, 2012 3:59 PM   in reply to Microbilla

    Have you tried disabling "Use Graphics Processor" in the performance preferences?  You can also try changing the setting from the default (advanced) to Basic and see if that helps.

     

    Finally, I'd suggest lowering the total amount of RAM allocated to Photoshop to 70% to see if that helps with overall performance.

     

    Please let me know if any of these changes make a difference.  If not, we can try some other steps.

     

    Thanks,

    Adam

     
    |
    Mark as:
  • Currently Being Moderated
    May 19, 2012 9:17 AM   in reply to Microbilla

    Hi,

    Have you tried updateing you Graphics Card Driver?

    You should be able to run a check here:

    http://www.intel.com/p/en_US/support/detect

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2012 2:29 AM   in reply to Microbilla

    I have exactly the same problem

    Similar configuration, same system, Intel i7 processor

     
    |
    Mark as:
  • Noel Carboni
    23,469 posts
    Dec 23, 2006
    Currently Being Moderated
    May 20, 2012 7:54 AM   in reply to Microbilla

    Someone has said that disabling the little thumbnail icons that show in the Layers panel sometimes has a positive effect.  Not having seen the problem myself, I can't say, but it's another place to look / thing to try.

     

     

    Icons1.jpg

     

    Icons2.jpg

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,469 posts
    Dec 23, 2006
    Currently Being Moderated
    May 20, 2012 9:49 AM   in reply to Microbilla

    I wouldn't stop looking for a workaround myself.  It could help you uncover the root cause, which in turn you could provide information on to Adobe.

     

    One thing that might be helpful is for you to make a particular file with which you're experiencing the problems available online for others to download and test with.  If nothing else, it could help confirm whether your system specifically has the problem, or its a problem in the file or with the Photoshop software itself.

     

    A couple of days ago I had a "slow operation" problem having to do with 3D rendering of some text.  On a prompt from Steve (SG) from Adobe, I began experimenting with different text, and it finally came to light that I actually had a bad font installed.  It wasn't "crash Photoshop" bad, but it was "slow the hell out of Photoshop" bad.  I only mention it because it's possible you have something like that happening as well, and quite likely no future patches to Photoshop would have solved it.  What it finally took for me was to eliminate every ARIALN*.TTF file from my system.

     

    Let's see what Adobe says this coming week about this.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2012 1:16 PM   in reply to Noel Carboni

    Please tell me you forwarded a copy of that font to SteveG....

    (cause I want to know how the @#$%#% it slows things down)

     
    |
    Mark as:
  • Noel Carboni
    23,469 posts
    Dec 23, 2006
    Currently Being Moderated
    May 20, 2012 1:56 PM   in reply to Chris Cox

    Yeah, he's got the font files.  I posted a copy of the 4 files I removed online, so you can have it too. 

     

    http://Noel.ProDigitalSoftware.com/temp/ARIALN.zip

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2012 12:01 AM   in reply to Microbilla

    >>>I also have the "can't create scratch file" problem, and reinstalling after cleaning with the Adobe cleaning tool didn't help.

     

    Reinstalling wouldn't help with a system permissions problem.

    You need to fix the permissions on your disks to get rid of the "can't create scratch" error.

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2012 9:12 AM   in reply to Microbilla

    Microbilla wrote:

     

    …my configuration should let me handle much bigger stuff anyway.

     

    Depending on the size of your files, your available scratch disk space is nothing to write home about—or feel unduly confident about either:

     

    Scratch volume(s):

      F:\, 135,2G, 43,5G free

      E:\, 97,7G, 59,3G free

      C:\, 232,8G, 167,8G free

    You have precious little free space on your F and E drives, and on the C drive Photoshop's scratch disk has to slug it out with the swap files of the OS, your web browser's cache, and things like that.

     

    Just for reference, my primary scratch disk is a dedicated, physically separate, 200 GB internal hard drive.  Many other users have a lot more.  Roughly, in terms of available, contiguous scratch space, figure on at least 35 to 50 times the size of your largest file or more, multiplied by how many files you keep open.

     

    As for fixing permissions, I'm not a Windows specialist so I can't tell you how, but in essence it boils down to making sure you have full read and write permission on the drives and partitions you want to use as scratch.

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2012 11:51 PM   in reply to Microbilla

    Microbilla wrote:

     

    … I still feel I should be able to handle bigger files without all this lag.

     

    As long as your machine agrees…

     
    |
    Mark as:
  • Currently Being Moderated
    May 22, 2012 11:49 AM   in reply to Microbilla

    Would depend on what you are doing with the 100 meg image.  In CS6 they did change the liquify filter and others.  They added the Mecruy Graphics Engine so many features rely more on the graphics card.

     
    |
    Mark as:
  • Noel Carboni
    23,469 posts
    Dec 23, 2006
    Currently Being Moderated
    May 22, 2012 1:29 PM   in reply to Microbilla

    You may not be able to do anything immediate about it.  Since Photoshop CS6 is new, it stresses things like display drivers in new ways, and some of them don't work perfectly.  Though you have the latest release at the moment, I'm sure nVidia is working on a new driver to work with Photoshop better as we speak.

     

    Do you see relief if you go into the Preferences menu and disable the [  ] Use Graphics Processor setting?

     

    If that helps, try enabling it but choosing different Advanced settings.

     

    Remember to close and reopen Photoshop after making any of these configuration changes.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2012 1:47 PM   in reply to Microbilla

    Instaling the new nVidia driver helped me with performance issues

     

    Hope it will do it for all others - thanks!

     

    Artur

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2012 9:41 AM   in reply to Microbilla

    So far we haven't reproduced any such slowdown in house (even on really dirty systems).

     

    We have heard from people who have older video card drivers causing slowdowns, and bad anti-virus software (esp. Norton) causing slowdowns.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2012 3:16 PM   in reply to Microbilla

    We've been running on everything from single core to 32 core systems.

     

    Most likely there is still something else on your system that you haven't told us about causing the slowdown.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 12:02 PM   in reply to Microbilla

    Try turning off other software and utilities to see if they may be interfering.

     

    Yes, sometimes it's easier to start with a clean drive and reinstall everything slowly to see where a conflict occurs (which explains why I have 4 bootable OS volumes, plus a stack of spare drives here at home -- yes, I am a Fry's frequent shopper :-).

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2012 12:28 PM   in reply to Chris Cox

    Video Card Renderer: GeForce 9800 GTX/9800 GTX+/PCIe/SSE2

     

    This might be you're problem

     

    On CS6 I've tried GT 240, GTX 9800+ and GTS 450

    Personally I didn't found a way to enable MPE in CS6 with the the GTX 9800+

     
    |
    Mark as:
  • Noel Carboni
    23,469 posts
    Dec 23, 2006
    Currently Being Moderated
    Dec 8, 2012 12:43 PM   in reply to Microbilla

    Microbilla wrote:

    ... cleaned useless files and registry system, ...

     

    Ugh, don't tell me you ran a "registry cleaner".

     

    (This for others reading this thread) You really need to avoid registry cleaners.  They don't do a lot of good, and they introduce a lot of potential problems.  The registry does not need cleaning!

     

    -Noel

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points