Skip navigation
Currently Being Moderated

Remove blank space around project

May 24, 2012 9:26 AM

Hi everyone,

I am getting extra space outside of my project.  Below is a screenshot of the published project.  The blue border indicates the edge of my slide.  It is a square shape drawn on the slide.  I have turned off the playback bar and borders.

 

Is there code I need to modify in the html file?

 

space.gif

 

Thanks!

Micky

 
Replies
  • Currently Being Moderated
    May 24, 2012 9:33 AM   in reply to mickyfokken

    Hi Micky

     

    Here's the deal. When you configure the project initially, you choose a size it will be. That's known as your "project resolution". The goal is a constant moving target. You want to choose a size that fits easily on your target audience's display without forcing them to scroll. So this is a fixed size.

     

    What it sounds like you are wanting is for the project to dynamically consume all available space in the browser. And that can be done if you open only the SWF and not the HTML page created to present the SWF. As long as you are happy with the result, that will work most of the time.

     

    Cheers... Rick

     

    Helpful and Handy Links

    Captivate Wish Form/Bug Reporting Form

    Adobe Certified Captivate Training

    SorcerStone Blog

    Captivate eBooks

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2012 10:36 AM   in reply to mickyfokken

    I believe that you can do that as well. Just edit the HTML and change the pixel values to 100%. Although I have this nagging feeling that it doesn't work in all cases or all browsers. Can't remember which.

     

    Certainly give it a try... Rick

     

    Helpful and Handy Links

    Captivate Wish Form/Bug Reporting Form

    Adobe Certified Captivate Training

    SorcerStone Blog

    Captivate eBooks

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2012 6:08 PM   in reply to mickyfokken

    I always add this code into the HEAD section of my Captivate HTM templates:

     

    <style>body {margin:0px;}</style>

     

    This turns off the normal dead space around any HTML page.

     

    The other thing you need to do is find this line of code in any SCORM HTM template.  Note that I have set table padding and spacing values to 0 to remove more dead space.

     

       document.write('<table border="0" cellpadding="0" cellspacing="0"> \n');

    

     

    These changes should help to remove the scroll bars appearing, but you may need to fiddle a bit with the actual size you set to display the content.

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2012 6:11 PM   in reply to RodWard

    I'm not a great fan of setting the HTM template to display the SWF at 100% of screen width.  I've found that this can often mean your project content loses resolution at anything other than the exact size it was captured.  Less of an issue with soft skills or general training content, but definitely can have a visible impact with any software tutorials or captures you might be doing.

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2012 7:25 PM   in reply to mickyfokken

    If your course is running inside an iframe on another web page then this might account for the extra space.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points