Skip navigation
Currently Being Moderated

"RAM Preview needs 2 or more frames" error back in CS6

May 7, 2012 2:14 PM

Hey everyone,

I'm quite familiar with this old error and how to avoid it and fix it but when preparing new CS6 lessons for my classes it just seems to come up again and again without any apparent relationship to the assets I'm working with. I've mostly been preparing some "What's New in CS6" lessons and have had this error come up using Evironment Layers, Raytracing lessons, Motion Tracker lessons, etc. using text, footage, solids, you name it.

 

The main thing that seems really telling is that before this issue happens, the blue and/or green cache bars seem to be gone within my workspace range. Purging the caches doesn't fix it but closing and reopening AE does fix it.

 

Using the updates AE 11.0.0.378 on OS10.6.8 MacBook Pro 2.8Ghz Core 2 Duo with 4GB of RAM

All prefs are set to the defaults.

 

Thoughts?

 

Thanks!

 

steven

Branched to a new discussion.
 
Replies 1 2 Previous Next
  • Currently Being Moderated
    May 7, 2012 2:54 PM   in reply to EchoOut

    Hi Steven,

     

    The "RAM Preview needs 2 or more frames" error basically means AE has run out of usable memory space. Purging should normally fix that. I'm most concerned about this:

    > before this issue happens, the blue and/or green cache bars seem to be gone within my workspace range

     

    We want to take a look at this.

     

    When you get into this state, open the Activity Monitor and look at the System Memory display. Please send a screenshot of that to kurkoski at adobe dot com. Also, select the AE process in Activity Monitor, click the Sample Process button, save the log and send it to me. Thanks.

     

    -=Tim

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2012 6:43 PM   in reply to EchoOut

    hi did you fix this issue?

    I have the same message when i start a preview

    I having the same problem actually with CS6, and CS5 worked great....

    thanks in advance

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2012 3:57 PM   in reply to EchoOut

    I'm seeing the same issue, and through some simple trial and error it seems like opening Safari at the same time as AE could be part of the problem, or maybe its just a wierd coincidence.

     

    I'm on OS X 10.7.4 - 2x2.66 quad core, 24GB ram.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 1:03 PM   in reply to Tim Kurkoski

    I would like to add that I am also experiencing this problem constantly after upgrading to CS6 with the recent update.


    Please fix ASAP because it is making the program virtually unusable for me and I cannot find any way to mitigate the problem (closing other programs, etc.)


    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 2:41 PM   in reply to cbowlcut

    Same problem as in thread.

    Can't RAM preview, just getting this error.

    CS5 worked great, im very upset that i can't finish my work(in 2 days) with cool cs6's effects.

    BTW, Adobe, may be this screenshot can help you http://dl.dropbox.com/u/14882469/2/scr.jpg (Actual CPU's used: 0 - is it right?)

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 3:06 PM   in reply to rasielrt

    rasielrt - Turn off the Multiprocessing preference. 4GB is far too little RAM to make effective use of MP, even with only 2 processor cores. Read up on recommended settings for MP here and here.

     

    asdbnasmbashgjasdas - If you have MP turned on like rasielrt does, turn it off, regardless of how much RAM you have. Does that help? Yes? Good. Now post back with more information about your system: how much RAM is in your machine, how many processors, and what kind of work are you doing in AE. How big are your comps? How big are your source files?

     

    To recap, the "RAM Preview needs 2 or more frames" error is an "out of memory" error. You are very likely be seeing it because you are, in fact, out of memory. Yes, there is a bug in AE CS6 that we are still researching that contributes to this error occurring, and the error message itself isn't terribly helpful.  But the bottom line is that if you are in a low memory situation you are still going to easily run out of memory. Turn off MP (it multiplies AE's RAM usage), shut down other applications, and optimize your memory usage (go to the first two links in this post).

     
    |
    Mark as:
  • Currently Being Moderated
    May 19, 2012 12:21 AM   in reply to Tim Kurkoski

    Already tried this, the same error.

    But I am going to retry this, may be im wrong (ill get to home in about 30 minutes), i will post result.

    I tried to change almost every option to get RAM preview work.

    Is there any way to turn of this new "Fast preview" and make it work as in CS5?

     
    |
    Mark as:
  • Currently Being Moderated
    May 19, 2012 2:09 AM   in reply to rasielrt

    Ok, I got it to work.

    No matter if I turn off multiprocessing, but it loads very few frames, and starts looped RAM preview.

    More frames will be loaded if I lower resolution and frames skip.

     

    Then, I got to "Preview" section of settings and set alternate RAM preview from 5 to 100. And it started to render RAM frames as it was in CS5 even if I set back from 100 to 5 or turn off multiprocessing.

     

    0_o!

     

    ...

     

    It's because every other app is turned off now.

     
    |
    Mark as:
  • Currently Being Moderated
    May 19, 2012 6:08 AM   in reply to rasielrt

    i Have got the same issue, i just upgrade my MBP to 8GB RAM, it s better, but still have this message sometimes, i find out that when i close everythiong and reboot, and justworking on AE, it s ok, i can have a preview a real one, of about 1 minute, but if i open justy one thing else, this message happen again..

    And if i want to preview another part of my timeline i have to reboot it because even when i purge, the second preview i test after reboot is only few seconds looping.

    So i just keep rebooting for making preview RAM, and it is really not an good way of working

    Hope you ll fix this vere soon, !!

     
    |
    Mark as:
  • Currently Being Moderated
    May 19, 2012 12:58 PM   in reply to Tim Kurkoski

    I thought that I would add:

     

    It turns out that Safari was a contributing factor. I still get the error if I have too many CS applications open, but closing safari has helped by about 70%.

     

    I have the fasted 2011 MBP with 8gb RAM. I do not have MP on.

     

    This problem is also occuring on other fast iMacs around here.

     

    Can we get an estimate as to when an update will resolve this problem? We need to decide whether we should downgrade to CS5.5 or wait this out. I must repeat that this problem never occured with CS5.5 no matter how many apps were running on the computer.


    Thank you,


    Cassidy

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2012 7:44 AM   in reply to cbowlcut

    Hey, I want to add too! This was driving me nuts as well, purging, cleanout out database, nothing worked...then I closed Safari, and it just went away- without doing anything else! On a mac 12-core OS10.6.8, in case that helps.

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2012 12:48 PM   in reply to CJ_Shaw

    Same problem here!!

     

    Trying to ram preview jpeg image sequence. First was only able to render couple of frames. After turning off disc cache, now I´m able to render about 2 secs, but very slowly. And that 2 secs is way too short!!??! CS5 I was able to preview tens of secods.

     

    My computer is macbook pro dual core with 8 gb of ram...

     

    Is there going to be fix for this soon??? Program is useless like this!!!

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2012 1:11 PM   in reply to seetukka

    I posted earlier that closing Safari helpd it go away, then it came back. I turned off disk cache, didn't help, but closing everything seems to help. Then I started getting a 6 to 8 sec delay on anything I would do in the interface (even zooming!) when I hit over 50 layers, which I didn't have a problem with in cs5. I guess this eats ram up, and I closed everything else, dropped to qtr res and that seems to help, but not desirable to say the least. (there are many 3d layers with 2d render passes, etc, etc, so yeah, it hits 50+ layers pretty quickly).

     

    My mac pro 12-core OS10.6.8 has 16gb ram, I know, that isn't enough for the 2gb/proc suggestion, so I guess you need boat loads of ram for cs6?

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2012 1:20 PM   in reply to CJ_Shaw

    I notised that on the info window it says " switching to foreground" after rendering couple of frames. Never seen that before!

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2012 12:45 AM   in reply to seetukka

    If you're seeing the "switching to foreground" message, that means that the background rendering processes are starved of memory and are going quiescent and turning rendering over to the single foreground process.

     

    Disable Render Multiple Frames Simultaneously multiprocessing. You should only use that when everything is going well, you have lots of memory, and you want to try parallel processing. If you're getting out-of-memory errors, turn this preference off.

     

    Also, an After Effects CS6 update is available:

    http://adobe.ly/lsrkmJ

     

    Install the update. It solves a lot of problems, including some with RAM handling.

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2012 1:47 PM   in reply to Todd_Kopriva

    Hi there, just installed the update and tooled around for 5min and it seems faster, more interactive...so, just wanted to say thanks!!

     
    |
    Mark as:
  • Currently Being Moderated
    May 31, 2012 10:20 PM   in reply to EchoOut

    I found temporary  (as I hope) solution. I use small application called Purge (might be just GUI for purge terminal command) when this error arrives. No need to restart or even relaunch AE. It resolved all my problems and I'm very happy, 'cause on my old Mac Book Pro CS6 is _significaly_ faster than 5.5.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 4, 2012 7:37 AM   in reply to Tim Kurkoski

    Hi I've installed the patch onto my trial version of CS6 and it hasn't made any difference to the error message

    'Ram preview needs to or more frames to play back'

    Multi processing is off, i'm running a 2x2.26 ghz quad core with OS 10.7.4.  The Ram available for Afx is 6GB.

    I've got 2Gig for other applications and i'm rendering from C4D in the background as a neccessity.

    This is causing real problems to my work flow and impending deadline.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 4, 2012 7:40 AM   in reply to Touch Sugar

    This sounds good.  Could you send me a link to the software please?  Thankyou.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 4, 2012 7:47 AM   in reply to Engles11
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 4, 2012 8:13 AM   in reply to Touch Sugar

    Thankyou.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 5:48 PM   in reply to EchoOut

    Hey, for a loooong while I had that same problem, purges and restarts wheren't good enough,

    I even did the update posted in this forum which didn't work either.

     

    By random chance I just found an stable solution (at least for my case).

     

    On Preferences go to Memory & Multiprocessing. Press on the Details button.

     

    Here is the key to understand the problem, despite having a good 16.00 on Max Usable Memory, in Max Allowed Memory I had 0.40,

    meaning that the error message wasn't random or a bug, but that AE wasn't getting access to the full RAM amount.

     

    After googleing for that problem I found in a forum that the reason behind that could be a firewall or an antivirus,

    then I checked my firewall and found that I had a process blocked called dynamiclinkmanag that was trying to reach the local host (127.0.0.1).

     

    Once I allowed the process to get through After Effects has suddenly appeared reaching also the local host

    and now AE is working wonders with the RAM preview.

     

     

    Hope it helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 4:10 PM   in reply to Touch Sugar

    Purge seems to work for me too on a laptop MacBook Pro 17". If you have Cocktail it is also a command in that application. I still think there is something not right with AE CS6 because on the exact same machine I can run CS5 After Effects with MP on and it doesn't have a problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2012 4:05 PM   in reply to EchoOut

    I have the same error problem, in a Mac Pro, I've installed OSX Lion on a second hard drive, Installed CS6, updated CS6, but if I try to render any comp, I receive the same error mesage (works without problems, for one hour) I've erased the cache, purge all memory.

     

    I switch to the other hard disk with Snow Leopard and CS6, and I can render any simple or complex project without any problem.

     

    This it's my Mac Pro Specs:

     

    Model Name:          Mac Pro

    MacPro3,1, Quad-Core Intel Xeon, 2.8 GHz, Number Of Processors:          2 Total Number Of Cores:          8

    L2 Cache (per processor):          12 MB, Memory:          8 GB

    ATI Radeon HD 2600 XT:

    Chipset Model:          ATI Radeon HD 2600, Type:          GPU, Bus:          PCIe, Slot:          Slot-1, PCIe Lane Width:          x16

    VRAM (Total):          256 MB, Vendor:          ATI (0x1002), Device ID:          0x9588, Revision ID:          0x0000, ROM Revision:          113-B1480A-252, EFI Driver Version:          01.00.252

    Cinema HD: Resolution:          2560 x 1600

     

    Thanks for your help

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2012 5:55 PM   in reply to Tim Kurkoski

    Hi Tim

    I've also been getting this 2 frame error - its been happening fairly unpredictably (ie sometimes it previews just fine) but to me it seems to happen more often if I jump to another app whilst the preview is rendering.

    This is pretty standard practise for me - ie hit 0, then apple-tab to check my mail or tweak a psd. Using CS5 I would know the preview was ready because ae would jump in the dock, i'd tab back to it, hit 0 again and get instant playback.

     

    Now under CS 6 all this happens but when I go back to ae the cache bar has changed from green to blue (or sometimes goes altogether). Most of the time I then get the "needs 2 or more frames" dialog, although sometimes when I hit 0 it just starts to cache again, like I'm hitting 0 for the first time. Very annoying!

     

    On a big comp I will use shift 0 to skip 1 or 2 frames, but the behaviour as described above is the same.

     

    When I purge (image cache or all), the blue line if it is there persists, but the error continues.

     

    My specs are below and I will email you my activity monitor and log as requested. Do I also need to file a bug report or is this enough for you at this stage.

     

    It would be super if you could fix this!

     

    Thanks

     

    Dan

     

    specs:

    mac osx 10.7.4

    2x2.4 ghz quad core intel xeon (mid 2010)

    16gb 1066 MHz DDR3

    ATI radeon HD5770 1024mb

    2x 23inch cinema displays + 1x cintiqWX

    startup disk 120GB OCZ vertex2 SSD

    project disk 1TB WDC 1001 SATA internal

    cache disk 120GB OCZ vertex3 SSD

     

    after effects CS6 v 11.0.1.12

    disk cache setting maximum dsik cache 60gb (nothing else writes to this 120gb volume)

    RAM reserved for other apps 4gb

    ram shared by CS apps 12gb

    multiproc OFF

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 11:29 AM   in reply to EchoOut

    This is sad, I've been using these products for a long time and could not believe that I got this message, nor the responses to it.

     

    I had previously been using CS5.1, but installed 6 to try the new Creative Cloud, my employer was going to pay for the monthly cost for the time being.  Since this conversation started in May and the update has been out since May, why when I download and install yesterday am I still using a faulty version.  I had to waste an hour of my time to try to correct it, then waste more time downloading the updates.

     

    The 2 second error has gone away thankfully, eveyone that get this error, please try updating.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2012 2:44 AM   in reply to dan from remote ltd

    Hi Dan,

     

    have you checked how much memory is AE actually using?

     

    you can do this through:

     

    the Memory & Multiprocessing options on the Preferences menu.

     

    There you need to press the Details button and allow it a couple of seconds to refresh the information.

     

    You will see then what is the Max Allowed Memory.

     

    A low value here will explain why you have this problem and that is not acting randomly but something is blocking AE to access the RAM.

     

    In my experience it was the firewall although it seems that an antivirus can also hold it back.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 8, 2012 5:25 PM   in reply to EchoOut

    same problem for me too. on both my mac pros

     

    brand new : 2.4ghz 12 core - 32gb ram - nvidia 4000 - plenty of HD space

    mac pro 4,1 : 2.26ghz 8 core - 32gb ram - 2 ati radeon 5770 - plenty of hd space.

     

    same thing happens on both machines reguardless of manual purging of cache ( 93gb ) . running with no other applications open.

     

    is there a setting we are all missing?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 8, 2012 5:40 PM   in reply to EchoOut

    does anyone else see in the activity monitor multiple " aeselflink " ? could this be associated with the problem?

     

    i have 14 of those processes running - all taking up .8 cpu / 74 threads /  122mb.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 12:34 AM   in reply to james@suspended.tv

    JImmy,

     

    Yes. I have the same aeselflink in my Console Logs.

     

    I have reported this last year .. and I am currently discussing the issue with Apple.

     

    Adobe officially states that there is no problem .. and it is not an 'error'.

     

    I am awaiting Apple's 'official' response .. but so far they said that if it shows up in the Console .. it is a problem.

     

    I am using the Master Suite 5.5 and a 12 Core Mac Pro 2010 running OS X 10.7.4

     

    I am not happy with the performance .. especially with the fastest Mac Pro I could buy compared to other window users who praise the software performance .. and I also have other Adobe related errors in my Console.

     

    I have also found these errors listed on a Mac Pro 8 Core in a Apple Store running the Adobe Suite.

     

    Check back with me for an update.

     

    Once I get Apple's Official response ... I will install the Adobe 6.0 Suite trial and see if these error still show up in my console and cause performance issues.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 7:25 AM   in reply to Pharther Phurther

    Hey Pharther.

     

    i did discover what those processes are after messing around with some settings in AE. they are "multiprocessing" processes. so for earch aeselflink process you have it is directly linked to the number of threads you've selected in your AE settings. if you switch off multiprocessing and watch your activity monitor - you will notice at once all those processes quit.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 23, 2012 5:49 PM   in reply to EchoOut

    Same ridiculous issue here... what is the point of multiprocessers and 16GB ram if the software can't take advantage of it. Turning off MP doesn't really seem like a good solution.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 23, 2012 10:49 PM   in reply to rlmilton

    Exactly ... especially when I purchased the Master Suite that stated in it's advertisment about taking advantage of multiprocessors ... ( the same reason I bought a 12 core Mac Pro )

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 2:03 AM   in reply to Tim Kurkoski

    Hi

    i have this problem also, so far i have…….

    -purged the ram

    -turned off muliproccesing

    -and installed the update/patch!!

     

    My imac (2.7 ghz, 4G Ram)  is only 3 months old

    ive been using AE or over 10 years

    and it happens right at the beginning of a project when everything is very simple

    just a few jpegs in layers

     

    Please Mr adobe get it sorted…

     

    Megumi

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 2:35 AM   in reply to Megumi2

    Is it just me or has Adobe GIVEN UP with this issue?

    Their last post above (their own forum) was in April

    Sign.. .back to AE 5 again with its own iratatiing bugs

     

    Megumi

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 8:26 AM   in reply to Megumi2

    Yes i d like to be able to go back again with AE5 but how to find this version now? and i payed for the Creative cloud few monthes ago ! But indeed no answer to this issues, and it drived me that crazy, i stopped making video...

    But i really hopped that was fixed in one or 2 monthes, we are now waiting from 4 monthes, and no any answer...

    Hello ADOBE ! Help Us to use you software that we are paying for !!

    I payed for more RAM in order to fix this issue, but not any amelioration... nothing! AE can't use my RAM that a really big problem !

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 10:05 AM   in reply to yelloween

    No, we have not given up on this issue.

     

    Here's an explanation.

     

    This error message is After Effects telling you that it can't do a RAM preview because it can't render and preview at least two frames. This state has many causes, though:

     

    One cause is operator error. If you have the current-time indicator at the end of the composition or work area, and you have From Current Time enabled in the Preview panel, then you'll get this message when trying to RAM preview. This is because you're already at the end of the previewable duration.

     

    Another cause is a badly behaved plug-in that is demanding waaaaaay too much memory, so After Effects can't render two frames using this plug-in. (Video Copilot Reflection has been known to behave badly in this way, for example.)

     

    The two above causes apply to all versions of After Effects.

     

    A cause that only applies to After Effects CS6 is a bit more problematic and technical. In previous versions of After Effects, when you started a RAM preview, After Effects would start rendering frames and storing them in RAM without first checking to see how much memory was available; it would stop when it ran out of RAM, wherever that might be. But this was potentially a very rude thing for After Effects to do, since it might be forcing other contents of RAM used by other programs out of RAM and onto the disk (paging), which can cause some slowdowns. So, in After Effects CS6, the program first does a check to see how much RAM is available. And here's the problem: Mac OS is bad about communicating how much RAM is really available. In fact, in many cases, it says that almost no RAM is available... and After Effects CS6 believes it and reports that it doesn't have enough RAM to render and store two frames. Specifically, After Effects is asking how much RAM is "free". If you leave Mac OS running for a long time, the amount of "free" memory dwindles to nearly nothing under normal operation, as the OS accumulates a lot of stuff in "inactive" memory, which is not reported as "free". Previous verisons of After Effects would go ahead and use this "inactive" memory for RAM preview, and perhaps After Effects CS6 should, too. We're discussing how we can best fix this.

     

    So, what can you do? There are some command-line ways of purging "inactive" memory and making it free in Mac OS. I won't recommend any specific ones here, but a quick search on the Internet will turn them up. But a guaranteed and easy way of doing this is to restart the operating system.

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points