Skip navigation
Currently Being Moderated

Many apps crash after clean install of CS6. solution: "run this program as an administrator" in Win7

May 9, 2012 10:03 AM

I upgraded from CS5.5 to CS6 by a clean install using the Adobe uninstallers. I have never had any problems with any upgrade before as I was about to experience with this one.


The following applications crashed while exploring the application:

  • Adobe Bridge, when I wanted to open a folder to explore my harddrive. The faulting module is: MMXCore.8BX_unloaded, wpdshext.dll and ntdll.dll
  • Fireworks and DreamWeaver, when I wanted to use mini Bridge on module: BIB.dll


The following applications could not even start:

  • InDesign crashed just after loading all plugins on KERNALBASE.dll and MSVCR100.dll.
  • Photoshop refused to start and gave a warning about privileges on a scratch file. I tried to remove the settings file when starting the application using the CTRL ALT SHFT keys, but it did not work


This was a very unwelcoming introduction to CS6. Fortunately, all problems went away after I gave each application in the suite elevated privileges by turing with the ""run this program as an administrator" option in my Windows 7 HP system. The problem with Photoshop gave me hints in that direction.


Is this issues known? If elevated privileges are required, why was it not included in the installer script?






Replies 1 2 Previous Next
  • Currently Being Moderated
    May 9, 2012 10:29 AM   in reply to d.p.middleton

    Installers can not elevate user privileges. They can only temporarily request system privileges based on certificates and signatures. anyway, this shouldn't be necessary and since it affects so many files, I would simply assume that your file permissions are messy - since they are inherited, any invalid permissions ripple through. It's pretty much the only expleanation. So check your drive root properties and fix file permissions.



    Mark as:
  • Currently Being Moderated
    May 10, 2012 3:58 AM   in reply to d.p.middleton



    I've got the same problem and did not find a solution yet (except giving admin rights to the applications). For me, it concerns Bridge, InDesign and Encore [CS6 Master Collection, Win7 x64].

    By the way: it's very much the same problem as here:


    I fixed it in Photoshop by starting as admin and setting the scratch drive to another location than C:\


    So, what's happening here as far as I found out:

    It seems to come from a Photoshop problem. A file called "PhotoshopTemp[number]" is created in the root directory of C. Due to writing permissions, this file cannot be created if you do not start the software as an admin. All programs having trouble seem to create this or a similiar file. (Encore crashes while loading Photoshop library)

    That makes sense: Bridge, InDesign, Encore (, Fireworks and I think also Dreamweaver) have a strong interaction with photoshop files. I wonder why After Effects does not have this problem. Perhaps psd-files are addressed in a different way?

    While testing I noticed that full permissions for the C:\ root directory were not enough to fix the problem (even that would not be an acceptable solution). There might be more files that cannot be written?



    Regarding the other post and my research, a problem could be:

    The temp directory of windows is at another location than default - does this apply to you, Dave, as well? However, changing back to default does not help anymore.


    A workaround is to start the software with admin rights. Of course, this cannot be a solution.


    A solution could only be to change the pointer to the directory(s) which is not possible through the "preferences" of the programs except Photoshop.


    This was a very unwelcoming introduction to CS6.




    Hoping for a solution or a hint!


    Mark as:
  • Currently Being Moderated
    May 11, 2012 11:04 AM   in reply to CFStudios

    Thanks so much for helping me discover why I am having this problem.


    It does, however, make me wonder if Adobe tests their software on Win7 x64.  Writing to the root directory of a drive has not been allowed since the x64 version came out!  Between that and Photoshop's dislike of the Users folder not being on C: (easy to fix, but why should I have to go through the extra steps, adn why doesn't Photoshop gracefully recover from it), I'm less than impressed with Adobe's testing.


    I still love the software, but do some better testing, folks!!!



    Mark as:
  • Currently Being Moderated
    May 14, 2012 2:04 PM   in reply to kolohe280

    Perhaps, you've read it already:

    aochenglong, Adobe Employee 10.05.2012 04:46


    Can Bridge work if you run it as administrator? If yes, will it generate a temp file named like “Photoshop Tempxxxxxx” under the root of C drive when Bridge launch? If still yes, it should be a same issue as what others encountered. And we are investigating this issue now.

    --> see


    so, we can look forward to a solution within the next updates.



    Mark as:
  • Currently Being Moderated
    May 22, 2012 9:43 PM   in reply to d.p.middleton

    I thought I should add to this thread so Adobe knows that this is an issue that they simply must fix!


    I am the ICT administrator for a school - we have approx 250 computers which we install Adobe CS on. Every version including CS5.5 worked flawlessly. CS6 has been a nightmare!


    I too encountered both the Photoshop and InDesign errors exactly as described here. I found the solution for Photoshop was also to change the scratch disk to a different drive than C - a little tip I figured out for anyone with multiple users or a domain environment, you can copy the directory C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop CS6\ from a user whose scratch disk has been changed to another drive and paste it to any other users, and their scratch disk will be changed without having to elevate privileges and manually changing each time.


    As for InDesign, I have been working on this for three days solidly, and have found no solution, having tried literally hundreds of things including giving all users of my test machine full permissions to the entire C:\ drive. Nothing makes InDesign work except running it as the administrator (which I simply cannot do in my environment). It cites MSVCR100.DLL in the crash error, which is located in C:\Windows\SysWOW64 but updating this file and altering its permissions also does nothing (deleting it stops InDesign loading at all )


    I have also tried redirecting InDesign file recovery to a different drive and setting permissions on all directories listed under InDesign support on (local and roaming data, cache). No effect.


    Notably, InDesign fully loads up before crashing. It crashes once the application window has appeared, after about 2-3 seconds. The cursor changes to the loading wheel and immediately crashes. When running as an Administrator the loading wheel also appears after 2-3 seconds, so the error seems related to whatever InDesign is doing at this time, but I have no way to tell what this is.


    Definitely need some updates regarding these issues, as I cannot roll out CS6 to our computers until this is fixed!

    Mark as:
  • Currently Being Moderated
    May 23, 2012 6:43 AM   in reply to HT_Peveus

    we have the same problem with InDesign CS6

    have you news to fix the problem?

    Mark as:
  • Currently Being Moderated
    May 24, 2012 12:42 AM   in reply to d.p.middleton

    InDesign seems to work if you give all users the permission to create directories on c:\

    Seems to be the same error like in Photoshop.


    This is a nightmare if you want to run it on a Terminal Server or in an hostile environment, but that's another issue.




    P.S.: What are the TEMP and TMP environment variables good for if nobody is reading them?

    Mark as:
  • Currently Being Moderated
    May 24, 2012 1:04 AM   in reply to Gerhard Schneider

    for Photoshop work with the solution from HT_Peveus in this Discussion

    I found the solution for Photoshop was also to change the scratch disk to a different drive than C - a little tip I figured out for anyone with multiple users or a domain environment, you can copy the directory C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop CS6\ from a user whose scratch disk has been changed to another drive and paste it to any other users, and their scratch disk will be changed without having to elevate privileges and manually changing each time

    for Terminal Server, it´s ok for my, all users need the same settings


    my problem is InDesign with Terminalserver

    i have set the permission for all users on "c:\" to full, but i have the same problem, InDesign crash after it´s 3-4 seconds running

    Mark as:
  • Currently Being Moderated
    May 24, 2012 5:55 AM   in reply to zittrellw

    We are running 2008R2SP1 and it was enough to give users the special permission to create and delete folders and files to c:\


    InDesign is creating another c:\Photoshop TempNUMBER file

    Mark as:
  • Currently Being Moderated
    May 24, 2012 10:22 PM   in reply to Gerhard Schneider

    Hallo Herr Schneider,


    ich Antworte und Frage auf Deutsch, ich hoffe, das ist Ok und vielleicht können Sie mir weiterhelfen.


    Zum Überblick: Ich versuche im Moment einen Terminalserver 2008 r2 mit CS6 zum Testen (später Produktiv) zum Laufen zu bringen.

    Wir haben Roaming Profiles und wir leiten beim Anmelden des Users, das Profile auf ein zusätzliches Laufwerk um.

    Soweit auch alles kein Problem, funktioniert.

    Ich hatte schon mit Photoshop das Problem, wie in dieser Diskussion. Gelöst hab ich das, nach langem Suchen, wie hier. Da gab´s diesen Eintrag noch gar nicht.

    Nachdem bei uns eh alle User die gleichen Einstellungen haben sollen, hab ich Photoshop direkt auf dem TS konfiguriert. z. B. das Arbeitsvolume habe ich geändert und zwar auf das Laufwerk, wo unsere Profiles liegen. Per Skript kopier ich dann die Einstellungen von C:\Users\Administrator\AppData\Roaming\Adobe\Adobe Photoshop CS6\ in das Profil des Users. Funktioniert.


    nun zum InDesign


    Beim InDesign kann man wohl das Arbeitsvolume nicht anpassen!?

    Das mit der PhotoShop Temp Datei von InDesign habe ich nun auch nachvollziehen können.

    Könnten Sie mir vielleicht verraten, wie Sie die Berechtigungen genau zum anlegen und löschen von Ordner und Files gesetzt haben?

    Ich denke aber, dass das auf einem TS schon gefährlich ist!?


    noch ein Nachtrag: ich habe jetzt die Umleitung des Profiles auf das zusätzliche Laufwerk wieder rausgemacht. Jetzt fuktioniert´s!!! Auch wenn ich keine Berechtigungen setzte!!! Nun hab ich auch das Problem mit Photoshop und dem Arbeitsvolume nicht mehr!!!

    Mark as:
  • Currently Being Moderated
    May 28, 2012 3:29 PM   in reply to d.p.middleton

    Sorry, same thing - InDesign does work if you are able to create another admin account and run it from there. Terriffic. Anybody know if Adobe working on an iron for this bug?

    Mark as:
  • Currently Being Moderated
    May 28, 2012 9:13 PM   in reply to Jollysod

    Hi, I had cs6 probs until:

    - set Win7 system and user tmp and temp variables from x-drive to c:\temp

    - relocated any cs6-related caches from x-drive to c.

    Setup: win7 64-b, ssd as os-disk, ssd-raid0 used to be for caches.

    Not gonna pinpoint the least amount of changes needed, I'll just wait Adobe to fix it and then return my settings.

    Mark as:
  • Currently Being Moderated
    May 29, 2012 12:07 PM   in reply to Mikko J Jokinen

    Cheers Mikko,

    worked a treat (for now...). Doesn't bode well for the tech guys who have to get on-site distribution to work though - or those of us who are trying to get a little more life out of SSDs...


    Mark as:
  • Currently Being Moderated
    Jun 4, 2012 9:31 PM   in reply to Jollysod

    Having a similar problem with Indesign and Encore. My windows user profile is on "D:\"and for some reason both apps want to write a temp file ( "photoshop temp" ) to the root of "C:\". This can only be achieved by running as an admin. If I run the programs logged in with a user profile that is stored on "C:\users.." they create the same ( "photoshop temp" ) in the correct location being "C:\Users\%username%\Appdata\Local\Temp" and the program works happily.


    I am 98% sure this is the reason for the crashing at startup, but I cant find where Adobe has set this path. I dont want to flatten the file system just for these applications


    Adobe Please Help!


    Mark as:
  • Currently Being Moderated
    Jun 6, 2012 3:20 PM   in reply to McWindows

    Can you change the Compatibilty Mode for the Indesign to Win XP SP3 and then check.


    Right -click on the Indesign.exe , Go to Properties and then change the compatibilty mode

    Mark as:
  • Currently Being Moderated
    Jun 14, 2012 10:53 AM   in reply to Manish-Sharma

    I tried running indesign in XP SP3 compatability mode as you suggested above and it worked.


    I'm running Win7 x64.


    I should add to this that I have the Users and ProgramData folders located on the D: drive.  I did place hard links on C: to redirect to D:, and this seems to work for every other piece of software I have installed on the system

    Mark as:
  • Currently Being Moderated
    Jun 28, 2012 5:06 AM   in reply to kolohe280

    After installation of Design Standard CS6 and the latest update, InDesign, if started "normally", still crashes with a Runtime error a few seconds after the opening screen appears; this does not happen when running it as an administrator or in XP SP3 mode. Apart from the UAC prompt that appears in these two work-arounds, it is just annoying that InDesign cannot be run "normally" like every other program I have installed (except Photoshop CS6 with its scratch disk problem that can be resolved by going the administrator route only once to change the scratch disk).

    Apart from the above, Ilustrator CS6 starts with an error message about the Drop Shadow plug-in not being loaded due to an error, but it does not crash.

    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 6:13 AM   in reply to Mikko J Jokinen

    worked for me. Thansk for the tip.

    Mark as:
  • Currently Being Moderated
    Aug 1, 2012 4:02 AM   in reply to d.p.middleton

    I want to share the solution of serious bug of all products Adobe CS6.


    After 8 re-installation of Windows 7 x64, and clean install applications CS6 was found that:


    changed the location of the temp folder to another disk. For example the

    transfer of the Temp folder from the disk "C" on drive "D".


    Use of NTFS junction points (mklink /D C:\Users\west\AppData\Local\Temp D:\All_temp\temp) after the transfer, also does not solve the problem.


    Solution!!!: return everything back to default.

    Important!!! for correct installation of applications CS6 need to be installed after

    return paths of the variables by default, and reboot to apply the values.


    p.s. Adobe solve this problem please!!!

    Mark as:
  • Currently Being Moderated
    Aug 1, 2012 5:57 AM   in reply to wesstyless

    OK, so I've spent several hours trying to figure this issue out (to get Encore to launch, in my case) and after reading several forum postings about it and testing things on my computer, here's the workaround I came up with. This is largely based off of wesstyless's post above, which gave me the idea to redirect it with a junction point.


    My user profile and temp directories are on my D: drive (and I intend to keep them there!)

    1. I created a "dummy" user profile directory in the default location on drive C
    2. In this dummy directory, I created an NTFS junction named Temp which pointed to my actual temp directory on D
      mklink /d C:\Users\Chris\AppData\Local\Temp D:\Temp\Chris
    3. I switched the TEMP and TMP environment variables (right-click computer, properties, advanced system settings, environment variables) to both point to the new junction point in the dummy user directory


    After setting this up, I ran Encore and it launched just fine. I haven't actually used it for anything but configuring my settings yet, but it crashed on startup every time I ran it as a standard user before, so getting to the UI is significant progress.


    Obviously, the best solution is for Adobe to fix the issue with an update (it boggles my mind how they could have hard-coded a temp directory on to drive C). Theoretically there's no downside to my workaround, because even though everything in Windows that uses the TMP or TEMP environment variables will be trying to write to the directory on drive C, the Junction point will *automagically* cause the reads and writes to happen on drive D where they belong. Still, it's kind of a hack.


    I hope this helps!

    Mark as:
  • Currently Being Moderated
    Aug 1, 2012 1:06 PM   in reply to My Fault Productions

    The problem is completely solved!!!!!!!!!


    My Fault Productions, You are also grateful for the tip =)


    The correct way to move the system variables using junction points. On the example of folder Temp.


    1. Transferring the Temp folder to another drive as usual (for example: D:\temp). Reboot.


    2. Delete the folder Temp, which is the default disk "C" (C:\Users\%username%\AppData\Local\Temp)


    3. At the command prompt running with administrator privileges, enter the following command:

       mklink /D C:\Users\west\AppData\Local\Temp D:\temp

       (Everyone has his name) This will create a transition point.


    4. In the setting of the location of the Temp folder restore the default path:



    5. Reboot and enjoy. The system thinks that the Temp folder is the default, but really is on another drive.


    All applications CS6 with this method of working.


    It's important! Need to install the application after such manipulation.

    Updates are working.

    Mark as:
  • Currently Being Moderated
    Aug 25, 2012 7:23 AM   in reply to wesstyless

    I was trying this and I got to the point of restoring the default path to the Temp folder and couldn't proceed.


    I logged in as Administrator and followed steps 1-3, but when I got to step 4, the "Temp" folder that's in my "H:" drive does not have the location tab. So I am unable to change the default path.


    Any reason why? Did I miss something that is causing me not to have this tab? Any assistance would be greatly appreciated.

    Mark as:
  • Currently Being Moderated
    Aug 31, 2012 3:14 AM   in reply to mrosario354

    You have a problem in step 3. Name "west"  you need to change the name of your account on the system:


    "mklink /D C:\Users\(you account)\AppData\Local\Temp D:\temp"


    Or I do not understand you well. I'm Russian.

    Mark as:
  • Currently Being Moderated
    Sep 2, 2012 3:50 PM   in reply to wesstyless

    Thanks for the reply. I have a problem in step 4-


    "4. In the setting of the location of the Temp folder restore the default path:



    When I go to the Temp folder properties, it does not give me the "Location" tab to change the path back to default. Maybe I'm doing this wrong.


    Mark as:
  • Currently Being Moderated
    Sep 6, 2012 3:05 PM   in reply to Aggerts

    step 1 and 4.   switched the TEMP and TMP environment variables (right-click computer, properties, advanced system settings, environment variables.



    Mark as:
  • Currently Being Moderated
    Sep 28, 2012 2:48 AM   in reply to d.p.middleton

    It is still not fixed, but my solution solves this problem completely, for any user or administrator.

    Mark as:
  • Currently Being Moderated
    Oct 12, 2012 12:30 AM   in reply to wesstyless

    I confirm that it's not fixed yet but the weestyless solutions solves the problem ! Thanks.


    To make it easy (not more secured but easier) and work with XP without admin right on C drive :

    - I created a directory c:\temp with the create, modify rights for my users

    - I created a wrapper batch script that

      - save my TMP et TEMP variables in MYTMP and MYTEMP

      - then "setx TMP c:\temp" and "setx TEMP c:\temp"

      - Launch the adobe program

      - set the 2 variables back to original values

    - I used that script so when my user close it's adobe application, everything is back to normal envrionment.


    What is amazing is the answer of adobe support that i'll share with you (it's in french, but i'll translate it after) :


    Cher Monsieur Chambault,


    Merci d'avoir contacté le service clientèle Adobe.


    Je vous contacte suite à votre problème. Il semblerait que vous utilisez notre logiciel sur une session en domaine. Malheureusement, nous ne supportons pas techniquement une installation en domaine. Veuillez souscrire à un contrat d'assistance technique pour ce faire. Le problème que vous rencontrez est tout à fait normal, vous avez des droit limité, et ce, même si vous êtes administrateurs


    Si jamais vous rencontrez le moindre souci, n'hésitez pas à nous recontacter et c'est avec plaisir qu'un de mes collègues ou moi-même tenterons de résoudre votre problème dans les plus brefs délais.


    Afin de fournir un meilleur service à nos clients et pour améliorer le niveau de notre service clientèle, je vous invite à compléter l'enquête de satisfaction attachée à ce mail.


    En vous souhaitant une excellente journée,




    Mika E.

    Adobe Service Clientèle.


    Nous vous adressons ce message en réponse au cas de support n° 0209102993 ouvert par cedric chambault.


    Pour répondre à cette mise à jour ou consulter l'historique des cas, connectez-vous au  Portail du support technique  Adobe et recherchez le numéro du cas dans la section des activités récentes. Pour ajouter des informations, ouvrez le cas et mettez-le à jour.


    Si vous ne parvenez pas à vous connecter, consultez le   forum aux questions sur les identifiants et les adhésions Adobe




    Le service clientèle Adobe




    So, if you don't understand french, i'll translate for you :

    "The support says that you payd a lot to buy our software, but it's not supported in a professional environment. However, if you pay more in subscribing a support contract, we will help you"


    Amazing answer !! When you create such a bug on a "professional" application, you must correct it ! it's not about support silver or gold or no support at all !

    Mark as:
  • Currently Being Moderated
    Oct 22, 2012 7:21 AM   in reply to caran77777


    How can a company like Adobe officialy ignore domain networks ? Completely astonishing !!!

    We have still not bough our CS6 updates (several thousands dollars) due to this temp directory bug and Adobe ignoring entirely the most elementary network security rules ... This really don't give trust into Adobe, for the least !

    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 9:13 AM   in reply to Nicolas.k

    Yep I get this too. Thanks Adobe.


    Not a chance in hell I can get a company of 14000+ to change it's policies because you can't write software correctly. Noticably Dreamweaver, Fireworks and Flash run just fine. Your new 64-Bit re-writes fair the worst. Also thanks to your custom downloaders I can't download the right installer through our network. I got the one from and it turns out to be English/Hebrew, not what I wanted.


    So yeah I will be running the apps as admin because of this debacle.


    I've been using Photoshop since the late 90s in college. I thought you guys saw what happened to Quark when they treated their customers this way.

    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 12:03 PM   in reply to SopraGroupUK

    This is a user to user forum. You are ranting at other users, not at Adobe.




    If nothing else, I hope you feel better.





    Mark as:
  • Currently Being Moderated
    Dec 6, 2012 2:07 AM   in reply to Bob Levine

    Yep sorry, you are right Bob.


    I hoped I was ranting with them rather than at them.


    I will bare that in mind in the future.

    Mark as:
  • Currently Being Moderated
    Dec 23, 2012 2:24 AM   in reply to SopraGroupUK



    I got the same porblem since upgrading from cs5.5 to cs6.


    But still not resolved for me.


    I'm working under windows 7 x64


    All my users profiles are on d:


    So let say my user name is toto.


    I have d:\Users\toto\AppData\...


    And in my system vairables :





    I tried making a d:\Temp and a mklink /D c:\Users\toto\Local\Temp d:\Temp

    but still same problem importing psd file into ae.


    Using processmonitor, I see that it tries making a 'Photoshop Tempxxxxx' file under c:\


    What can I do ?

    Mark as:
1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (3)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points