Skip navigation
Currently Being Moderated

After purchasing the Auto-Renewable subscription, the latest issue did not become available

May 15, 2012 3:28 AM

Tags: #in-app_purchase #auto-renewable_subscription

Hi, I have a problem with my app: After purchasing the Auto-Renewable subscription, the latest issue did not become available for download/reading.

 

These are the steps I done:

1. I selected one of the options for subscribe

2. Gone through In App Purchase

3. After going through the In App Purchase, app updates the library

4. After updating the library, the latest issue, is not available for download. It still has "Buy" button

 

The ios certificates seems ok (redone many times), same steps of other 3 apps I already done.

The In-app purchase Product ID are the same in the iTunes Connect and in the app through Viewer Builder (latest version with v19 tools)

In Adobe dashboard the shared secret are set properly, paywall disabled

 

Somebody had the same problem and can help me? I don't know really what else I can do

Thanks in advance

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    May 15, 2012 4:30 AM   in reply to Siduno

    Check the publication date of the respective folio. I guess it is outside the period of the subscription.

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2012 6:53 AM   in reply to Siduno

    Can you post the productId of the folio that's not appearing as expected? I can do some research.

     

    Thanks.

     

    // James Roche

    // I was born lucky

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2012 10:23 AM   in reply to Siduno

    One thing about subscriptions in the sandbox...

     

    Apple only supports the subscription for a fraction of the time listed. I'm not sure if there's an exact science to it, but we've seen some subscriptions last only a few minutes. Please try to purchase again and let us know if you continue to have problems.

     

    For what it's worth, I don't see any problems with the folio listed in your account.


    Let me know what you find when you re-purchase the subscription in the sandbox.

     

    Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2012 8:25 PM   in reply to Siduno

    Have you tried creating a new test user in iTunesConnect? There should be no problem with a separate user.

     

    Let me know, thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2012 4:30 AM   in reply to Siduno

    I am actually having this exact same problem!

     

    One thing I did notice is that if I kill the App and restart it, the first subscription issue is now available for download.

     

    Have you resolved the problem Siduno?

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2012 5:26 AM   in reply to Siduno

    we have some problem too

     
    |
    Mark as:
  • Bob Bringhurst
    4,640 posts
    May 29, 2007
    Currently Being Moderated
    May 17, 2012 10:24 AM   in reply to Siduno

    No, Apple can't approve a private folio.

     

    Apple's default behavior for subscriptions is to entitle customers to all issues between the start date and end date of the subscription, like a print subscription. When you sign up for a print subscription on November 15, you wait awhile and get the December issue when it comes out. But when people subscribe on a mobile device, they expect something to happen right away. That's why Adobe tries to make the most recent folio available. With an iTunes subscription, the person who subscribes on November 15 should get the November 1 issue. The glitch in the system is when you publish an IAP folio that Apple hasn't yet approved, that unavailable folio counts as the most recent folio. Users who sign up for a subscription while the published IAP folio is in review don't get the most recent folio.

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2012 12:31 PM   in reply to Bob Bringhurst

    Hi Bob,

    We do not have IAP folio or unpublished folio or anything like this but still get same problem.

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2012 2:51 PM   in reply to Siduno

    I'm sorry guys, but it has nothing to do with entitlement or IAPs or anything like that. It is a bug.

     

    As mentioned, killing the app and restarting it brings it back to a rightful state where the 'subscribed' issue becomes available for download.

     

    Hope Adobe can fix this as it doesn't seem to be an isolated case and is affecting our investment.

     
    |
    Mark as:
  • Bob Bringhurst
    4,640 posts
    May 29, 2007
    Currently Being Moderated
    May 17, 2012 3:35 PM   in reply to Paolo Sotto Manzano

    I'll look into it and let you know when I hear something.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 3:59 AM   in reply to Siduno

    Please follow this KB: http://helpx.adobe.com/digital-publishing-suite/kb/subscription-purcha se-doesnt-change-folio.html which is a known issue to find out which one could be the root cause.

     

    Thanks

    Laxman Negi

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 5:27 AM   in reply to negilaxman

    How do you explain quitting and restarting the App restores it to its rightful state?

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2012 6:24 PM   in reply to Siduno

    Didn't help with me as well.

     

    As mentioned, quitting and restarting the app restores to its rightful state where issue is available to download.

     

    I think the Viewer Builder has been essentially throwing out a few lemons here and there.

     

    Any other alternatives Adobe? Hope you guys are looking into this.

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2012 8:17 PM   in reply to Siduno

    Same thing is happening to me:

     

    Apple replied:

    1. Launch app

    2. Tap "Subscribe"

    3. Select the subscription option

    4. In App Purchase confirmation window

    5. Tap "Confirm"

    6. Enter Apple ID and password

    7. Share-personal-information window appears

    8. Tap either of "Allow" of "Don't Allow"

    9. Share-personal-information window dismisses

    10. App updates the library

    11. After the library is updated, the latest issue, in this case summer 2012 issue, still has "Buy" button as shown in the attached screenshot

     

    The folio publication date in dps is 2012-05-18

     

    This is v20 of the app... What is going on?

     
    |
    Mark as:
  • Bob Bringhurst
    4,640 posts
    May 29, 2007
    Currently Being Moderated
    May 25, 2012 8:11 AM   in reply to Siduno

    The testers are looking into this issue. It sounds like it should be resolved in a hot fix. We'll let you know when we hear something. Sorry about the inconvenience.

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2012 10:05 AM   in reply to Bob Bringhurst

    Would a hot fix require a rebuild of the app?

     

    --

    Chris Muench

    Sent from my iPhone

     
    |
    Mark as:
  • Bob Bringhurst
    4,640 posts
    May 29, 2007
    Currently Being Moderated
    May 25, 2012 11:02 AM   in reply to blasto333

    The hot fix should happen next week if all goes according to plan. My understanding is that this is a viewer bug, not a server bug, so unfortunately you'll need to rebuild your app.

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2012 3:16 PM   in reply to Bob Bringhurst

    Magnificent. After making us go through all these supposed 'fixes' and 'known issues', it turns out it is a bug after all. I have been saying that since day one. They even wanted me to troubleshoot with them over the phone - but there was no way I was spending another minute helping someone I am paying a shitload of money to in order to fix their own ****. Interesting how it takes Adobe almost two weeks to acknowledge and another week to fix. We should get a refund of our monthly fees for the month of May.

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2012 3:19 PM   in reply to Onaznam

    And it wasn't an inconvenience - it was a massive waste of our valuable time thinking we were doing something wrong and trying to troubleshoot. I am ******** furious.

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2012 3:19 PM   in reply to Onaznam

    And Gold Support ain't worth crap.

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2012 3:47 PM   in reply to Onaznam

    Very disappointed

     

    --

    Chris Muench

    Sent from my iPhone

     
    |
    Mark as:
  • Currently Being Moderated
    May 28, 2012 8:04 AM   in reply to Bob Bringhurst

    Good to hear that a hot fix is coming very soon. I have exactly the same problem, and my app has been rejected twice by apple because of it. I've subscribed to the thread, and hope to hear something as soon as the hot fix is out.

    Thank you!

     
    |
    Mark as:
  • Currently Being Moderated
    May 28, 2012 11:37 PM   in reply to Siduno

    We are experiencing the same problem with V20 and our app has been approved by Apple. None of our subscribers can download new issues and new users can't even buy an issue! 

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2012 12:41 AM   in reply to Bob Bringhurst

    The status page is still saying "No known issues have been escalated and are scheduled to be fixed in the next hot fix release." If the status page had been correctly updated we would never have released a Sprint 20 app.

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2012 5:32 AM   in reply to Bob Bringhurst

    As Bob did write earlier, the DPS team is working on a hot fix. If you want to release a viewer, you still can target the v19 viewer in Viewer Builder. If you are on a tight schedule, my suggestion is to use this functionality.

     

    If you already have a v20 viewer in the market and you are experiencing this issue, you can consider downgrading the viewer to v19. I know this will have implications on content authoring.

     

    -Klaasjan

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2012 6:05 AM   in reply to Klaasjan Tukker

    This happens in a v19 viewer also. Our magazine is in the store with an approved v19 viewer and is causing the same problem. I have sent our development app (with proper UUID to Winston). This needs to be resolved soon!

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2012 6:19 AM   in reply to Siduno

    So, I just did what Mr. Tukker suggested and it turns out there is an issue too? WTF? More ******* wasted time and effort...

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points