Skip navigation
Currently Being Moderated

Flash player not loading on http but works on https

May 15, 2012 3:09 PM

I have an issue where flash player shows "movie not loading" on http pages but works fine on https.


I am using windows 7 64 bit, ie9 64 bit, i have tried it with the latest firefox and chrome and i still get the same issue.


This started with flash player 10.3, the 10.2 version did not have this problem and all subsequent versions have the same issue. i am currently using the 11.2 version of flash.


Example: Any flash video on youtube with the address beginning with HTTP, the video screen is black and when you right click you get movie not loading and the correct version of the flash player. If you change the header over to HTTPS the video works fine. this wouldnt be much of a problem except when going to any other website that has flash as its main element but does not have an HTTPS version, you cannot use the page or its features.


I have uninstalled and reinstalled several times, done a clean install, deleted all files and updated every area of my computer but this issue remains. I have read the forums here and done any suggestions listed to no avail and noticed many people have this type of problem. This issue has now been going on for almost 6 months. Can anyone help?


I may have posted this in the wrong forum and I appologize. If so can you please move it to the correct location?

  • Currently Being Moderated
    May 15, 2012 5:04 PM   in reply to Deadivanhoe

    I don't claim to know the solution to your problem, but in your situation I would try either or both administrator install methods: 1) Right-click the downloaded install file, choose "Run as Administrator" and install the software as usual. 2) Try using a different Windows account that you are positively certain has full administrator rights or the actual Administrator login name, install with that account.


    Also, make sure you empty the browser cache before retrying the http pages. What about other browser settings, like security or privacy settings? Any add-ons or antivirus browser helper objects?


    Do you only use Internet Explorer, or is this issue the same in Firefox, Opera, Chrome and Safari?


    Good luck, hope you get the error fixed.

    Mark as:
  • Currently Being Moderated
    May 17, 2012 2:56 PM   in reply to Deadivanhoe

    Thanks for your update. If this issue is the same in different browsers, I think the source of your problem may not be flash or the browser, but some other kind of software or something else in your Windows installation. I can't be sure what causes this to happen on your computer, but it seems slightly like a problem I had once when installing the flash update didn't work because my java version was outdated or had stopped working.


    Have you tried installing the beta versions or checked any other software settings on your computer that could affect your network connection (i.e. TCP port 80 vs port 443) or tried running a version check of all your software with secunia (either the online scan or the install version)? Perhaps the cause of your problem is buried somewhere else in your system?

    Mark as:
  • Currently Being Moderated
    May 31, 2012 3:06 PM   in reply to Deadivanhoe

    Thanks for the feedback, sorry about the delay in answering you. It has been a hectic week at work.


    I'm glad you solved it, I was about to suggest to test your scenario on one of my own computers just before you posted this. Glad I didn't have to spend the time doing that. .;-)

    I also should have thought about antivirus programs earlier on, but forgot it since I wasn't in my daily mood of troubleshooting at work. Anyway, glad to get the problem solved. Cheers! :-)

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points