Skip navigation
Currently Being Moderated

Exporting DNxHD in 10bit

May 31, 2012 4:04 PM

I cannot get my export of DNxHD to export in 10-bit depth.  The original file is DNxHD 10-bit, but when I export using the settings pictured in the attached pic and re-import and do any color grading...it's clear that it has shifted to 8 bit. 

 

1) There are no non 32 bit effects on the footage.

2) the sequence is setup for max bit depth.

3) When i grade the clip before exporting and re-importing, it is clearly 10bit.

 

I record to DNxHD 10 bit and like to use DNxHD as my intermediate when sending to other programs or just want to flatten a complicated part of the timeline.  My other options produce too huge of files (animation, dpx, etc) and I really would like to keep it in the family.

 

Any thoughts how I can get Premiere to export DNxHD to a 10-bit?export1.jpgexport2.jpg

 
Replies
  • Currently Being Moderated
    May 31, 2012 5:41 PM   in reply to Richard Crook

    .it's clear that it has shifted to 8 bit. 

     

    What makes it so 'clear'?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2012 8:26 PM   in reply to Richard Crook

    444.PNGRichard,

     

    Have you tried the DNxHD 444 10-bit.  If you download the trial of Avid the codec installers are in there and work in Premiere, too.

     

    Worth a shot.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2012 9:47 PM   in reply to Richard Crook

    Yeah, I found this quite by accident when I downloaded the Avid trial and noticed the Procodecs were there.  Anyhow you can see they indicate 444.

     

    But your second post makes me think your odd resolution more probably could be causing the banding.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 11:46 AM   in reply to Richard Crook

    here's a screenshot.

     

    Even at 8 bits, I've never seen banding that bad.  I'm inclined to say something else is going on here.

     

    On another note, things often work out better when your frame dimensions are evenly divisible by 8.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 7:58 AM   in reply to Richard Crook

    Richard,

     

    I would have un-checked "Render at Maximum Depth" in the Export Settings dialog and try again. You have already specified 10-bit in the DNxHD Codec configuration so i see no need in then telling Pr to render out to 24-bit by using the "Render at Maximum Depth" option in the Export Settings dialog. Maybe that's the problem, telling the exporter to do 10-bit via the codec configuration and at the same time tell it to do 24-bit via the Export Settings. (I would have skipped the "Render at Maximum Depth" no matter what when going to DNxHD.)

     

    If the problem persists, place the media in a 1920 x 1080 timeline and render out to 1920 x 1080. Maybe DNxHD cannot handle non-broadcast frame sizes.

     

    If the problem still presists, try another codec to see if it is a codec related issue or not.

     

    /Roger

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 8:04 AM   in reply to Richard Crook

    Yes, but maybe the issue goes away if you do un-check the "Render at Maximum Depth" when you use the Gaussian Blur.

     

    What version of Pr?

    GPU Acceleration on or off?

    Can you post a screen shot of the Timeline?

     

    /Roger

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 8:32 AM   in reply to Richard Crook

    Can you post a screen shot of the Timeline when you have all filters on the clip, ie a screen shot from the Timeline you are exporting from. (I should have been more clear.)

     

    /Roger

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 8:50 AM   in reply to Richard Crook

    The screen shot you posted of the Timeline have one clip with *no* filters on it, and since filters are involved with the issue it would have been nice to see the actual Timeline you are exporting from, with the clips that has filters on them. (I have seen issues when the fault was in the timeline itself and not within the codec, hence the request.)

     

    Since you now have found out that it is a codec issue there is no need to post a new screen shot.

     

    /Roger

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 11:55 AM   in reply to Richard Crook

    I've never heard of this.  Please explain.

     

    Most deliverables these days use some form of MPEG compression - broadcast, DVD, Blu-ray, web, phones and tablets,  etc.  The MPEG 2 codec divides the frame up into 8 x 8 "blocks" of pixels for encoding, so things work out best when the entire frame fits an even number of blocks.

     

    Do the math on every standard resolution.  You'll find both dimensions are evenly divisible by 8.  This is not by accident.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 11:53 AM   in reply to Richard Crook

    Apparently when 24bit or 32bit is selected, it clamps to 8bit.

     

    This makes perfect sense.  The 24 represents all three channels of RGB; 3 x 8 =24.  The 32 adds the alpha.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 11:59 AM   in reply to Richard Crook

    Well, unless you're planing to cop the Intermediate, the criteria probably should be the same.  I mean, even every acquisition format follows this rule.  So it's generally a good idea to keep that rule in place throughout the post production chain.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2012 12:10 PM   in reply to Richard Crook

    You can also use my new Cropping presets if you like to use as a  'guide'.

     

    http://forums.adobe.com/thread/1010578?tstart=60

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points