Skip navigation
Currently Being Moderated

Admin is unabled to install Flash ActiveX due to missing rights

May 21, 2012 6:33 AM

Hello!

I have been using FlashPlayer ActiveX for a very long time without any problems. Now I tried to upgrade to 11.2.202.253 ActiveX and received the fllowing error message:

"A neccesary file (C:\Windows\system32\Macromed\Flash\FlashUtil32_11_2_202_235_ActiveX. exe:5) could not be written due to missing access rights

." (I translated this from the orinial german error message, so the original english one might look different).

This happens on Windows 7 32bit Home Premium.

I am logged in with admin-rights (in fact I have tried with three diferent admin account).

The Flashplugin for Firefox installe without any problem.

 

Here is my flashinstalllog:

=O====== M/11.2.202.235 2012-05-21+13-23-59.004 ========

0000 [I] 00000010 "D:\Users\Public\install_flash_player_ax_32bit.exe"

0001 [W] 00001036 Software\Macromedia\FlashPlayer\SafeVersions/11.0 2

0002 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

0003 [W] 00001036 Software\Macromedia\FlashPlayer\SafeVersions/11.0 2

0004 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

0005 [I] 00000020 C:\Windows\system32\FlashPlayerCPLApp.cpl

0006 [W] 00001037 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX/ 2

0007 [I] 00000013 C:\Windows\system32\Macromed\Flash\Flash32_11_2_202_235.ocx

0008 [I] 00000015 C:\Windows\system32\Macromed\Flash\FlashUtil32_11_2_202_235_ActiveX.e xe

0009 [E] 00001031 C:\Windows\system32\Macromed\Flash\FlashUtil32_11_2_202_235_ActiveX.e xe:5

0010 [I] 00000016 C:\Windows\system32\Macromed\Flash\FlashUtil32_11_2_202_235_ActiveX.d ll

0011 [W] 00001026 C:\Windows\system32\Macromed\Flash\FlashUtil32_11_2_202_235_ActiveX.d ll 5

0012 [I] 00000021 C:\Windows\system32\Macromed\Flash\FlashPlayerUpdateService.exe

0013 [W] 00001106

0014 [W] 00001106

=X====== M/11.2.202.235 2012-05-21+13-30-03.038 ========

 

Any ideas / any help?

Thanks!

 
Replies
  • Currently Being Moderated
    May 21, 2012 8:26 PM   in reply to ek_ger

    It seems that the permission problem is not so much the Admin account, but either the C:\Windows\system32\Macromed\Flash folder, or some of the files that should be overwritten in it.

     

    I suggest that you try the following:

     

    If you still have permission problems after this, try

     
    |
    Mark as:
  • Currently Being Moderated
    May 22, 2012 6:05 PM   in reply to ek_ger

    I have only looked at the FlashInstall.log file so far.  Are you really sure that the C:\Windows\system32\Macromed\Flash folder was empty at the time of the install?

     

    I will look at the Procmon log later if I have some time.

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2012 11:01 PM   in reply to ek_ger

    From the FlashInstall.log file it appears as if the installer can't write FlashUtil32_11_2_202_235_ActiveX.exe; but I cannot see anything regarding this in the procmon log file.

     

    I'm a bit lost here...  But, what I would try if that happened to me is the following

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 5, 2012 10:43 AM   in reply to Pat Willener

    I am having exactly the same issue.  using MSI installers instead gives an error. 

     

    Were you able to solve the problem?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 6, 2012 7:07 PM   in reply to ek_ger

    ek_ger wrote:

     

    The OCX-file is placed in the installation directory though, but it is not registered as the installation fails.

    Did you actually get a message that indicates "could not be registered"?

     

    If so -> http://forums.adobe.com/thread/987370

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points