Skip navigation
STEPHANIE COOK
Currently Being Moderated

Dark prints using CS5 & Epson R2400 ongoing problem, now new PC and magenta cast

Jun 8, 2012 7:29 AM

Tags: #photoshop

Have tried every combination of set up in trying to solve problem. Had One Eye (now defunct lamp) various experts etc etc but compensated for dark prints by having screen lightened to bizarre point. Now having a new PC am faced with massive magenta cast. I really don't want to buy a new printer but have had the dark print problem since I got it. Have spoken to Adobe and Epson at length but eventually washed their hands. I feel it is something to do within the computer set up or Photoshop - don't think its printer problem. All drivers updated regularly. Thought it could be monitor problem but don't really think this is the case.

 

Any ideas welcome as I think I have tried everything. Use Windows 7.

 

Am retired and not very technically minded!  Serious amateur photographer.

 
Replies
  • Currently Being Moderated
    Jun 8, 2012 6:02 PM   in reply to STEPHANIE COOK

    Hi Stephanie, welcome to the forums!

     

    A "massive magenta cast" usually means one of two things: a clogged printer nozzle or double color-management in your workflow.

     

    Dark prints are usually the result of a too-bright monitor screen.

     

    However, the starting point of all color-managed workflows is an accurately calibrated and profiled monitor.  Without it, you're flying blind.

     

    This thread really belongs in the Photoshop forum or the Color Management forum, as this is not a photography issue.

     

    Photoshop General Discussion

     

    When you post over there (I'd suggest the Photoshop forum) you may want to give exact details about your platform, Macintosh or Windows, exact versions of Photoshop and of the OS, and include screen shots of all your color settings and print windows. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2012 4:53 PM   in reply to station_two

    I have an Epson 1280 printer, and I have the same problem with prints. Part of the problem are the different color profiles in the monitor and the printer. The other problem to deal with is the type of photo paper used. While looking at web sites, I found that the ICC Color Profiles for the printer are on the install disc and are not automatically installed. One of the links describes which folder to install the profiles on both Mac & Windows computers.

    As station_two wrote, calibrate your monitor first.

    Below is a link about calibrating.

    http://dpexperience.com/2009/12/18/calibrating-your-monitor-to-your-pr inter/

    The next link is for printer tips

    http://www.normankoren.com/printers.html#Printer_tips

    And some more here

    http://www.digitaldog.net/tips/

     

    I do not have an exact answer for you because I have not figured it out myself, but here is what I have been doing on my prints. I might recommend that you work on a copy of the original.

    In the Layer floating window, create a New Adjustment Layer by clicking on the half black/half white circle, and choose Hue/Saturation or Color Balance or Selective Color. Because the prints come out too red, you want to increase the green sliders, which is the opposite of red, and/or decrease the red. (Layer>New Adjustment Layer>Color Balance) is another way to do it.

    Under the menu item Image>Adjust Levels. Move the center triangle at the bottom to lighten the mid-range, or use the center dialog box and change it to 1.20 or 1.30, for example.

     

    Now press Print with Preview (but you really are not going to print).

    When the dialog box comes up, make sure the Print Space: dropdown is set to Epson Paper or whatever you are using.

    I have been using Relative Colorimetric. Press Print. Another dialog box will come up. At the bottom will be a button for Preview, which will generate a preview of what the photo will look like if printed.

     

    Keep going back to the original and double click on the Adjustment Layer and adjusting it until the Print Preview looks ok.

    Be sure when you actually print that the paper and color settings in the Epson dialog box match your settings in Photoshop. There is a dropdown that has Print Settings or Color. Often they don't match unless you print several photos in a row. I have found printing at the lower settings (less than 360 dpi) also messes up the color.

    It is not an excellent solution, but until I can figure out more, I am in the same boat as you.

     

    I'd suggest saving the lightening and color adjustments as two different Actions.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points