Skip navigation
Lisa Jaworski2
Currently Being Moderated

master page displays wrong when published

May 7, 2012 1:56 PM

Tags: #bug #muse #adobe_muse

I have 2 master pages, 1 for home, 1 for the secondary pages. my home master page is showing up on all my secondary pages when I publish.

 

It  occasionally happened in preview too. http://whimsysweetcreations.businesscatalyst.com/products.html

 

the real background should be longer and have no brown band until the bottom of the page. Please advise!!!!! (it used to work fine, now with the new update it doesn't)

thank you

Lisa Jaworski

 

Message was edited by: Lisa Jaworski2

 
Replies
  • Currently Being Moderated
    May 7, 2012 2:10 PM   in reply to Lisa Jaworski2

    Hi Lisa,

     

    Can you confirm that your Master pages have been properly assigned in Plan view?

     

    Thanks, Dean

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2012 2:30 PM   in reply to Lisa Jaworski2

    What I mean is, while working in Plan view you are able to assign different Master pages to each of your site pages. You can do it by dragging a Master page thumbnail onto your site page thumbnail. In the image below, the labels highlighted in orange indicate which Master Pages I have assigned to each of the pages in my site. That said, if it's showing up correctly in Design and Preview mode, it's doubtful that's your problem.master_pgs_1.jpg

    When you update your site are you updating the whole thing, or just portions. I'm not sure this would have an impact either way, but I'm curious.

     

    Dean

     
    |
    Mark as:
  • Currently Being Moderated
    May 8, 2012 10:48 AM   in reply to Lisa Jaworski2

    Could you post screenshots of your home page and one of your other pages in design view and in preview view?

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 9:23 AM   in reply to Lisa Jaworski2

    Hmm, interesting that it is not showing up in Muse itself.

     

    Could you try exporting it to HTML, and see if the problem is reproducible locally? To do this, go to File > Export to HTML and you can choose a folder to export the site to. When it completes, there should be a link to "View Site". Click on this link and see if it has the same issues. If it doesn't, try logging into your Business Catalyst account and deleting all of the files, and republishing again from Muse.

     

    If it does have the same problems, or if deleting the files from Business Catalyst does not help, send your .muse file to muse-support@adobe.com so that we can take a look and try and help figure it out. In the email, be sure to include a link to this thread, and "ATTN: Andrew" so that we know where it was coming from.

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 11:18 AM   in reply to Lisa Jaworski2

    You can use services like Adobe SendNow or SendThisFile to send the file to us.

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 3:44 PM   in reply to Lisa Jaworski2

    I've found the bug you describe. The issue is that the backgrounds on the master page are both being exported with the same name, so one is overriding the other. Unfortunately this won't be fixed for the release version coming out this week, but I have logged it in our system. In the meantime, to fix the issue, you can place the background image for the homepage on the homepage itself, instead of on the master page, and it should solve the problem.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2012 9:50 AM   in reply to Lisa Jaworski2

    I don't see the links as Fuscia from my screen. There might be a browser setting you have set to override these styles. If that is not the case, your browser may be styling it differently because you have visited those links.

     

    And I'm not sure what you mean by the depth keeps moving. I do see that the height of your pages is variable, and from the looks of it you have your background image set to "Scale to Fill" so it will resize the image to try and make it fit the size of the page. If you remove this, your image will stay the same size, but on pages where your image is shorter than the page, a background color will show through. You can make this background color the same as the background color on the image by using the eye-dropper tool, and it should remove any ill effects of a shorter background image.

     
    |
    Mark as:
  • Currently Being Moderated
    May 22, 2012 10:04 AM   in reply to Lisa Jaworski2

    The are two background fills you can control on the each page. The first, is the browser fill, found in the control strip on the far right hand side (the default for this is a grey color, what you have as brown). The second is the page background fill, which will control the background of the content within the page border (the default is white, and it is where you currently have the image set for the page background). You will want to use the eyedropper to set the background fill on the page, which will sit below the image. You shouldn't need to change the fill for the browser background. Hopefully I understood you correctly, but if I did not, let me know and I can try and help further.

     

    As for the bug, this will be fixed in an upcoming release of Muse. I'll post here as we get more information.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2012 3:58 PM   in reply to Andrew Hushbeck

    I have a similar issue. In Design view my home page shows a footer. In Preview and when published,  the home page footer disappears.

    We exported to html as guided above; the footer wasn't there.

    It appears on every other web page, but not on my home page.

    See images below.

     

    This is the design view:

    IDesign View.png

    This is the preview view:

    Preview view.png

    Thank you for any help you can give me.

    Gay Ann Rogers

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2012 4:37 PM   in reply to GARRogers

    Can you publish the site or upload it somewhere so that we can take a look at the output?

     

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2012 5:23 PM   in reply to Andrew Hushbeck

    Yes, it is published at www.GayAnnRogers.com

     

    Please forgive it right now -- it is very new and not complete. I am in the process of migrating from my former website.

     

    Thank you for any help.

     

    Gay Ann Rogers

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2012 5:40 PM   in reply to GARRogers

    Upon checking the published source, I see that your footer navigation bar is contained within the <noscript> tag. This would only allow the footer bar to show when the browser has Javascript disabled. Did you enter the footer navigation code using Insert HTML feature along with your statcounter code?

     

    This is how it looks in Firefox with Javascript disabled:

     

    http://flashfiredesign.businesscatalyst.com/FTP/2012-06-21_0608.png

     

    Thanks,

    Vikas

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2012 5:45 PM   in reply to Vikas.Sharma

    No I didn't know to do that, but I will have help first thing in the morning and will see if it works.

    Thank you.

    Gay Ann

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 11:46 AM   in reply to GARRogers

    Looking at my site, I imported the statcounter via Object>Insert html, just like you presumed.

    Do you know how I can fix it?

    Thanks for your help.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 12:14 PM   in reply to GARRogers

    Thanks for confirming that.

     

    I think you have missed out on some statcounter code that you inserted using the Insert HTML feature. The statcounter code ends with a code like ...</a></div></noscript>. In your case, you missed out the closing </noscript> tag (at least). Muse checked that and placed a </noscript> tag at the end of the html code - effectively hiding ALL code on page following the <noscript> tag in statcounter code.

     

    I recommend you place complete code again in the HTML box for statcounter. Although just typing </noscript> at the end of statcounter code in HTML box would do the trick.

     

    Cheers,

    Vikas

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 1:10 PM   in reply to Vikas.Sharma

    It worked perfectly!

    Thank you!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 6:14 PM   in reply to GARRogers

    Hello again, Vikas,

    You were so helpful the last time I wondered if you would help me with another problem.

     

    Below are three photos. Photo #1 is the page as I designed it and as it appears in 'Design'.

    Photo #2 is how #1 looks in 'Preview'. Note the text is the same but the image is different.

    Photo #3 is later on in the series. It's as if 'Preview' for photo #1 stole the image from photo #3.

     

    Do you know what happened?

     

    The photo below is the page in 'Design'

     

    Eliza Photo in Design.png

     

     

    The photo below is in Preview. Note that the text is right but the photo is very different:Same photo in Preview.png

     

    The photo below is a few pages later; below it is with its correct text:Actual photo page.png

     

    In preview mode the page immediately above is correct.

     

     

    If you wish to see the pages, they are as follows:

     

    Photo #1 which is in my Design mode doesn't appear on the published site.

    Photo #2: http://www.gayannrogers.com/ruth-hubert.html

    Photo #3: http://www.gayannrogers.com/beth-richards.html

     

    Thank you for your help.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 7:40 PM   in reply to GARRogers

    It appears as if you are not adding the image(s) using File > Place option. Rather you are copying the image from another image editing software like Photoshop and then pasting in Muse using Edit > Paste or Ctrl+V or Cmd+V.

     

    If that is the case, I would suggest that you first save your image as a JPG or PNG on disk and then import that into Muse using File > Place.

     

    Let me know if that is not the case.

     

    Cheers,

    Vikas

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 22, 2012 6:03 AM   in reply to Vikas.Sharma

    I did use the File > Place option, but I went back and File > Placed a different copy of the photograph and all is well now.

    Thank you. I should have thought of replacing the photo.

     

    Here's another problem

     

    The page splinters. It is OK in Design, but it splinters in Preview and sometimes (depending on the size of the page) in the published version.

    See photos below:

     

    In Design .png

     

    In Preview:

     

    in Preview.png

     

    Here is the URL for the published page:

     

    http://www.gayannrogers.com/melba-kelly.html

     

    Thank you.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points