Skip navigation
Danie@PBMR
Currently Being Moderated

Cannot play imported CamStudio Screen Codec video. Only audio

Jun 21, 2012 12:05 PM

Tags: #import #screen #codec #camstudio #cscd

Cannot play imported CamStudio Screen Codec (CSCD) video. Only audio. When imported no video stream is visible.

From Classic Media Player:

Video: CSCD 768x576 25fps [00) ~temp.avi Video #1]

Audio: PCM 22050Hz stereo 705kbps [01) Microsoft Waveform: ~temp001.wav]

 

MediaInfo:

Format                     : CamStudio
Codec ID                   : CSCD
Codec ID/Info              : RenderSoft CamStudio lossless (LZO & GZIP compression

 

Also VLC can play it nicely.

 

What do I miss?

 

How can I set the appropriate codec for Premiere Pro CS6?

 

I would like a project for DV-PAL Widescreen 48kHz.

 
Replies
  • Currently Being Moderated
    Jun 21, 2012 12:10 PM   in reply to Danie@PBMR

    This ARTICLE is a bit old now, but in it, there are some Replies by Jeff Bellune, that might be useful. Jeff produces tutorials with Camtasia and PrPro.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 12:25 PM   in reply to Danie@PBMR

    Hope that Jeff's comments will prove helpful. I do not recall him updating his instructions for later versions of PrPro, but if he drops by this thread, I will ask, and if so, update that older article.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 1:18 PM   in reply to Danie@PBMR

    First step: Reformat your hard disk, reinstall OS & program, BUT NEVER INSTALL K-LITE anymore.

     

    Then try again.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 1:43 PM   in reply to Danie@PBMR

    K-Lite has proven to be an utter disaster to remove and it corrupts a lot of registry settings and priorities of codecs that are almost impossible to repair. In Explorer you can attach file extensions to applications pretty easily, but in the registry it is way more complex and that is exactly what K-Lite messes up and by consequence corrupting the Adobe installation.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2012 3:00 PM   in reply to Danie@PBMR

    If you have a System Restore Point, from before K-Lite, I would recommend trying that.

     

    What happens with many (most?) CODEC "packs" is that the usually over-write commercial CODEC's with their hacked, or reverse-engineered versions, or at least add theirs, and change the priority, as Harm mentioned. That is one reason that Adobe "hides" their Adobe MainConcept CODEC's, but that does not protect them from being dropped in priority.

     

    File Associations can end up changed, and a lot of those CODEC packs will install a lot of other "stuff," like FFDShow, that can really mess up Adobe programs, and is virtually impossible to completely uninstall.

     

    For some horror stories, just Search this (and the CS4 & Earlier) forum for "K-Lite." Very few success stories, and plenty of really bad ones.

     

    I always go "to the source" for my CODEC's, even if they are commercial. The only free CODEC's, that I will use are ones from the source, like Lagarith, or UT.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 5, 2012 5:40 AM   in reply to Danie@PBMR

    Are you using CamStudio or Camtasia Studio?  Camtasia Studio is often written as CamStudio for convenience, so it's easy to get the two mixed up.  Camtasia has a 64-bit codec that works in Premiere Pro.  CamStudio does not.  If CamStudio has an option to use UT or Lagarith as its recording codec, then choose one of those for future recordings.

     

    For the current file, try exporting it from VirtualDub using either Lagarith or UT and then edit that in Premiere Pro.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 5, 2012 9:15 AM   in reply to Danie@PBMR

    VirtualDub is telling you the codec needed to play the video isn't installed, which makes sense because you said CamStudio isn't installed.  This should fix your VirtualDub error:

     

    CamStudio - Free Screen Recording Software

     

    CS3 was a 32-bit app, so it was able to see 32-bit codecs like the CamStudio codec.  CS5 and later can't do that -- they need a 64-bit version because they're 64-bit programs.

     

    Once you get a good export out of VirtualDub to a Lagarith or UT .avi file, you shouldn't have any problems editing in any version of Premiere Pro.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 5, 2012 10:08 AM   in reply to Danie@PBMR

    You may have to follow these instructions (from the CamStudio user forum):

     

    I had the same problem as described in this thread and followed moisamva's instructions on Windows 7.  I am however using a work computer which does not allow changes to the registry.  So I figured out another way to make the same changes to the registry which doesn't require so much technical knowledge.  I wish I could simply post an attachment here, but unfortunately I'll just have to write out instructions to re-create what worked for me:

     

    1. Download the latest Codec.

    2. Extract it from the zip file.

    3. Double click camcodec.inf or drag it to notepad.

    4. Find the section that looks like this:

     

    [camcodec.AddReg]

    HKLM,SYSTEM\CurrentControlSet\Control\MediaResources\icm\VIDC.CSCD,Des cription,,%Description%

    HKLM,SYSTEM\CurrentControlSet\Control\MediaResources\icm\VIDC.CSCD,Dri ver,,"camcodec.dll"

    HKLM,SYSTEM\CurrentControlSet\Control\MediaResources\icm\VIDC.CSCD,Fri endlyName,,%Description%

     

    HKLM,Software\Microsoft\Windows\CurrentVersion\Uninstall\camcodec

    HKLM,Software\Microsoft\Windows\CurrentVersion\Uninstall\camcodec,Disp layName,,"CamStudio Lossless Codec"

    HKLM,Software\Microsoft\Windows\CurrentVersion\Uninstall\camcodec,Unin stallString,,"rundll.exe setupx.dll,InstallHinfSection DefaultUninstall 132 %12%\camcodec.inf"

     

     

    5. Add the following two lines:

     

    HKLM,SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc,"camcodec.dll",,"CamStudio lossless codec [CSCD]"

    HKLM,SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32,VIDC.CSCD,,"camcodec.dll"

     

     

    6. Save the file.

    7. Right click on the file, click 'Install'.  If you've already done this (e.g. before reading this post), dont worry - you can do it any number of times.

    8. Start CamStudio.  You should now see the Lossless codec listed.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 5, 2012 10:49 PM   in reply to Danie@PBMR

    Did you run it through VirtualDub (the 32-bit version, not the 64-bit version)?

     

    Jeff

     

    EDIT: Premiere Pro CS5 or later will never see that codec because it's 32-bit.  You need to run it through 32-bit VirtualDub and encode it with a 64-bit codec like Lagarith or UT.  Then, and only then, will Premiere Pro CS5 be able to play the video portion of the file.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 10:58 AM   in reply to Danie@PBMR

    The last suggestions I have are:

    1. Install the CamStudio codec separately from the program, or
    2. See if you can encode it to .wmv using Windows Media Encoder 9 or the new Expressions Encoder 4 (free version).

     

    If either or both of these don't work, then I'm out of ideas.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2012 5:49 AM   in reply to Danie@PBMR
    • CamStudio was designed to see the codec, so it may have an advantage over other Windows apps.
    • VLC has its own library of codecs, so it doesn't rely on Windows.

     

    VirtualDub has been known to be able to decode that codec, so maybe something is wrong with the codec installation.  A program called GSpot Codec Information Appliance can help.

     

    First, open GSpot's filter list:

    GSpotMain.png

     

    Then:

    1. Sort the list by Format
    2. Check that CSCD is listed as a decoder.
    3. See if it has any problems.

    GSpotFilters.png

    NB: Some decoders, like the MainConcept and Flash decoders in Adobe applications, are listed as having problems when they really don't.  It's just Adobe's way of keeping them for Adobe use and not for general use by other applications.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2012 11:13 AM   in reply to Danie@PBMR

    I solved the problem installing the Lagarith Lossless Video Codec again using a binary downloaded from the codec's website: http://lags.leetcode.net/codec.html

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 9:05 AM   in reply to Danie@PBMR

    I know this is a dated thread now, but since I found it when I encountered a similar problem importing CamStudio AVI into prPro (cs6 in my case) I thought I would post my workaround here in case some other poor soul stumbles in.

     

    First, let me say that I know this is a little bit janky, but bear with me because it worked perfectly for me and seems a lot easier than what's being suggested here.

     

    I'm running 64-bit Windows 8.

     

    Also couldn't get prPro to import CamStudio .avi files - I'd just get an error message.

     

    My solution was to open the .avi file in Windows Live Movie Maker - then save the file using their "High Definition Display" preset. This output the file in a .wmv file that imported both video and audio into prPro with no detectable issues. I suppose the quality of the video may have been diminished in some way, and I know how much people hate .wmv, but I've used it for several videos that I had to post to YouTube and it's worked like a charm.

     

    Your mileage may vary.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points