Skip navigation
RtwerkBoi
Currently Being Moderated

How do I import my custom-made workspace from InDesign CS5 into InDesign CS6 on the Mac?

Jun 24, 2012 1:31 PM

Tags: #indesign #workspaces

I updated from CS5 to CS6 using the Creative Cloud - on my Mac.  Now my previously created custom workspaces aren't showing up.  Yes, I tried copying them from the Library's Preferences folder into the CS6 preference folder, but they still don't show up.  I don't see a way to import workspaces.  I manually re-created my Photoshop workspace, but I don't want to have to do that with InDesign - I did too much work creating it in the first place.  Help, please.

 
Replies
  • Currently Being Moderated
    Jun 24, 2012 1:37 PM   in reply to RtwerkBoi

    Moving to InDesign Section.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2012 3:16 PM   in reply to RtwerkBoi

    Workspaces are saved as .xml files in the workspaces folder in your user library: <USER>/Library/Preferences/Adobe InDesign/<Version #>/<Language>/

     

    Just copy and paste into the same location for the new version.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2012 2:14 PM   in reply to RtwerkBoi

    Are you sure it's in the correct place? I moved my wrospaces without a problem, but I'm on Windows.

     

    Save new workspace and see where it is stored, then put your others in the same folder.

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Jun 25, 2012 2:20 PM   in reply to RtwerkBoi

    Also worked for me in OSX. I copied the entire workspaces folder though:

     

    Screen shot 2012-06-25 at 5.16.46 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2012 3:01 PM   in reply to Rob Day

    On a Mac you can also find the presets with workspaces in User/Library/Preferences/Adobe InDesign/(version). Copying it there worked for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2012 3:03 PM   in reply to Frans van der Geest

    Ah wait, this was already mentioned. In other cases try: Mac HD/Applications/Adobe InDesign/presets/workspaces/(language, like en_US)

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2012 5:07 PM   in reply to RtwerkBoi

    If you are using 10.7.X, the the User/<yourname>/Library folder is a hidden folder. Do a google search for instructions on making it visible.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2012 2:10 AM   in reply to RtwerkBoi

    Version numbering got  a bit confusing when Adobe Adopted the CS designations. For InDesign, add 2 to the CS number because CS1 came out with InDesign 3.0.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2012 8:12 AM   in reply to RtwerkBoi

    May I add that I just received CS6 Cloud and immediately setup a workspace in InDesign (after reading the blogs I decides to make fresh ones instead of bringing them over from CS5).

     

    The problem I am having is that I cannot save it as a default. Everytime I open InDesign the Essentials workspace is active. Maybe I am creating it wrong? Can someone tell me how to create it correctly so that it sticks as a default?

     

    Also note below the workspace is my custom workspace—not the Essentials as shown above the pallets. Should not the "Essentials" read "The Name Of Myworkspace?" since the pallets are my custom settings?

    Essentials.jpg

     

    Any help would be appreciated.

     

    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2012 8:19 AM   in reply to kylenorthway

    Did you save the workspace with a new name?

     

    If all you did was modify the Essentials workspace to suit, it will continue to display as Essentials untill you actually save the current condition with a new workspace name.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2012 10:34 AM   in reply to Peter Spier

    Yes, I named it with a completely new name.

     

    When I select my custom workspace from the flyout menu above the pallets, the workspace DOES change to my custom workspace, but the flyout button still reads "Essentials." See below.

     

    Screen-Shot-2012-08-22-at-10.32.00-AM.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2012 10:41 AM   in reply to kylenorthway

    Try trashing your prefs. See Replace Your Preferences

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 23, 2012 10:42 AM   in reply to Peter Spier

    OK, got it.  It was the slash in the name, "Jeff 8/2012", that did it.

     

    You cannot put slashes in the workspace name.

     

    Everything works great now.

     

    Thanks or talking!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 23, 2012 12:14 PM   in reply to kylenorthway

    Good to know. Thinking about it, it isn't a big surprise. I bet other special characters like * or % cause trouble too since they mean something as part of a file path. Stick to alphanumerics, hyphen and underscore and you should be OK.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 11:54 AM   in reply to Peter Spier

    Thanks for this info.

     

    This is a common beef for me when installing new versions of InDesign... why can't it offer to take settings etc. from previous versions? I have to manually bring over or re-do settings, workspaces, presets, scripts, keyboard shortcuts, etc.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points