Skip navigation
Currently Being Moderated

After Effects CS6: Cache and Reload Footage Problem

May 25, 2012 7:33 AM

After Effects CS6: Cache and Reload Footage Problem

 

I am having trouble getting my footage to update in an AE project. 

 

In an existing project, there is an image sequence in a composition.  I have saved and closed AE, modified the footage (same dimensions and qty. of frames, only the pixel data changes), and then re-launched AE and opened the project.  Though I have changed the footage, the old content still appears.

 

To resolve this, I have done the following:

 

Edit>Purge>All Memory

Edit>Purge>Image Cache Memory

Edit>Preferences>Media & Disk Cache>Empty Disk Cache

Edit>Preferences>Media & Disk Cache>Clean Database & Cache

From the Project window I've selected all footage and selected Reload

 

None of these got the footage to update.  I could double-click on the footage in the project bin and scrub the play head and the old footage was still displayed.

 

Finally I had to replace the footage with itself and that resolved the issue.

 

If this is operator error, lack of understanding the cache functions, or something else, I'd appreciate some assistance. I don't recall this behavior in CS 5.5, so I am guessing this is a change in CS 6.

 

Win 7 Pro 64bit Service Pack 1

Intel Xeon CPU X5450 @ 3.00 GHz 2.99 GHz

RAM 20 GB

 
Replies
  • Currently Being Moderated
    May 25, 2012 7:40 AM   in reply to adam@blueapplestudio

    It's probably one of those bugs that got just fixed with the 11.0.1 update released today... Apply the update, try the steps again and see if it works.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2012 11:27 PM   in reply to adam@blueapplestudio

    This issue is still there after the .01 update. I have to do all kinds of tricks everytime I need to refresh the comp, so frustrating.

    Is Adobe listening at all?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2012 12:56 PM   in reply to David Cabestany

    Hi,

     

    I tried your scenario and wasn't able to repro..  Here is what I did. 

     

    Iimported a DPX sequence (700 frames), into a comp.  Put the sequence on the timeline, closed/saved the project. 

     

    Selected four random files from the sequence, then opened the DPX files in photoshop.  Made changes then saved the files. 

     

    Opened up After effects, selected the saved project, select the image sequence, right click, reload footage

     

    When I scrubbed to the timeline the changes to the frames I modified showed up.

     

    Did you add anything different to this workflow?

    .

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 24, 2012 8:45 AM   in reply to StevRo

    I've run into this problem a number of times.  And no, purging doesn't fix it.  There are certain attributes, that when changed, aren't recognized by AE (and its Render Engine) as a change that requires a new render.

     

    I believe that in most instances (if not all) it was while using the plugin, "Trapcode: Particular".

     

    I assigned the position of the emitter in Particular to a motion path on another layer that was was drawn using Motion Sketch.  I did a RAM preview and realized it needed to move faster.  I highlighted all position key frames in the motion path and alt(option) clicked on one end and dragged them closer together.

     

    When scrubbing through the timeline after making the change, the Null object moved along the line properly, but the emitter in Particular did not.  It still moved as in the previous preview.  I had to change an attribute in the Particular effect that I knew wouldn't really have any effect on things in order to get it to make a new render.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 31, 2012 7:08 AM   in reply to TonyV125

    Did anyone find a solution for this?

     

    Having a bit of a wierd one with Illustrator layers. Purge Image Cache seems to have no effect on anything. Strangly, after reloading footage, nothing changes in either the project window or the timeline at full-res. Drop to half res and change has been updated. Back up to full res and reverts back to my pre-edited version!

     

    I'm finding the whole CS6 memory cache/handling thing a little whack on my Mac, Lion (and same in Mountain Lion, I'm finding). Not convinced it's refreshing what I do entirely reliably.

     

    UPDATE: it does refresh in full res, but only every couple of frames or so  :-(

     

    UPDATE 2: Empty Disk Cache under preferences sorts the problem out so it's definitly some kind of caching bug.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 9, 2012 9:36 AM   in reply to David Cabestany

    I am having this issue not only with Particular but also with Element. I have cleared cache and memory yet the issues still exists. I have even tried working the project and saving it to cs 5.5 then later brining it back into cs6 and the problem is still there. For the most part element is ok.  The first time I bring in my own jpeg that I made in photoshop it works fine as diffusion and bump maps, ect. If I then make changes to that layer back in photoshop discarding the old jpeg, then I go back to work on my cs6 comp, the old jpeg still pops up on my object even though that jpeg is been replaced. It sounds to me like it is more than a cache issue. Once the cache is cleared you would think that the old jpeg info would be gone, but it still pops up in the comp even after closing cs6, and rebooting the computer it still pulls the old jpeg info into the comp which is so very frustrating. It makes it very difficult to use my two favorite pluggins.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 11, 2013 3:12 PM   in reply to adam@blueapplestudio

    I have encountered similar problems with assets not refreshing proplerly. (it doesn't happen all the time, but does occur occasionally)

     

    Here is a workaround that has saved me several times in the past:

    Change the filename of the revised asset (like put an 'X' or 'rev' at the end of the filename, then ask After Effects to 'replace footage' with the newly renamed item.

     

    The fact that the filename is different seems to be enough to keep After Effects from remembering the old version.

     

    Like I said, it's not really a solution, but hopefully this workaround will help someone if they're in a bind.

     

    Good luck!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 21, 2014 6:05 AM   in reply to adam@blueapplestudio

    I'm having this problem, still. And it's the AE CC!

     

    When I create a new ae file and a new composition, it appears an existing image from another file in place of alpha. It appears on render and with Adobe dinamic link even.

     

    Putting an image on the timeline, the "ghost image" disappears, but the frames that have all the frame with alpha, the ghost appears again.

     

    My deadline is short, and I've lost 3 hours of work today with this bug.

     

    Sorry about the english.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2014 5:33 PM   in reply to VIEWCOM

    Thanks guys.  This was helpful.  What worked for me was to just replace all the unlinked footage that was moved with the SAME footage in my new location.  so just choose replace footage then find your same clips and then relink.  Like reconnecting online footage in Final Cut Pro.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points