Skip navigation
Gzla
Currently Being Moderated

RoboHelp 9 WebHelp Project Only Displays 

Jul 2, 2012 12:16 PM

Hi - I generated a WebHelp project using RoboHelp 9 and put it on a Windows IIS server. When I go to the URL, it displays only this: chars.jpg

 

If I go to the individual topic files, they display correctly. If I double-click the index.htm file on my local drive, it displays correctly.

 

I've seen some postings about this type of issue, but not exactly the behavior I'm seeing. I've only seen fixes for an Apache server, but we use Windows. I'm hoping someone has a suggestion.

 

Thanks!

 
Replies
  • Currently Being Moderated
    Jul 5, 2012 12:10 AM   in reply to Gzla

    That is exactly what you see with the issue on an Apache Server. You haven't said which posts you have seen so let me post how I respond. You will note that one person reported it worked on Windows and added some notes.

     

    ****************************************

     

    This is what I was advised by the company hosting my site.

     

    "I would therefore conclude that the solution to this problem (on Linux systems running Apache) is to add the AddDefaultCharset utf-8 directive to either the Apache config or the site .htaccess file. The advantage of the latter is that it only affects individual sites. The default Apache character set is taken from the locale file on Linux and defaults to iso-8859-1. It is the conflict between the Apache header with iso-8859-1 and the page character set of utf-8 that obviously causes Firefox a problem."

     

    In a forum post Chrissy_Tissy added

    My machine is Windows, but this fix still worked  - some notes about making the fix visible:

    1. Do the fix itself (httpd.conf: AddDefaultCharset utf-8).

    2. Restart the box to apply the fix.

    3. Once the box is restarted, clear your cache in FireFox to make sure you don't continue to see the cached file.

     

    Once all this is done you will see the output content as expected.

     

    ****************************************

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 1:45 AM   in reply to Gzla

    I cannot help with the question you ask about the equivalent file. I'm guessing but can you check somewhere the server is configured for utf-8?

     

    Also in the dialog where you generate, you can set encoding other than utf-8. Perhaps another option there would help?

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points