Skip navigation
Currently Being Moderated

Apache not working  with FMS 4.5 on Windows 2008

Mar 30, 2012 6:22 AM

Tags: #start #not #for #hls #windows #apache #using #streaming #domain #name #the #2008 #4.5.1 #could #1 #127.0.0.1 #fmshttpd #-k #returned #determine #server's #fully #qualified #servername

FMS 4.5.1 Windows 2008 SP2 (64bit).

 

I've searched everywhere for a possible solution to this, so my apologies if this has been asked before and my thanks for any potential help that anyone can offer to help resolve this.

 

We are deploying Adobe Flash Media Server 4.5.1 on a new server but Apache does not work (does not serve html files or stream Quicktime H.264 files).

 

      Assorted Problems & Error messages:

1.  The webroot/index.html page loads locally, but the HLS/HDS streams result in a 2032 error.

 

2. The webroot/index.html page does not load from  external locations:

     http://63.116.232.5/index.html (does not load externally).

     http://63.116.232.6/index.html (our old server, FMS 4.0 and Windows 2003). Everything on this server works, the 2 major differences being that it is running FMS 4.x on Windows 2003.

 

Some RTMP streaming works externally and internally (f4v files):

http://www.librarymedia.net/flash/player.html?source=rtmp://63.116.232 .5/vod/mp4:sample1_150kbps.f4v

 

FMS does not stream Quicktime H.264 files even though f4v files work.

   New server (does not work): http://www.librarymedia.net/flash/player.html?source=rtmp://63.116.232 .5/vod/mp4:Basketball.mov

                              (f4v works): http://www.librarymedia.net/flash/player.html?source=rtmp://63.116.232 .5/vod/mp4:sample1_150kbps.f4v

  

Old server (Quicktime/H.264 file works): http://www.librarymedia.net/flash/player.html?source=rtmp://63.116.232 .6/vod/mp4:Basketball.mov

 

Apache does not serve Quicktime/H.264 files: I made sure that Apache had all of the correct mime types specified.

 

    Error messages and attempted solutions:

  1. Apache's erro_log file:

       a. httpd.exe: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

 

2. FMS master.log file

      a. FMSHttpd -k start returned 1:

 

Solutions: http://wiki.apache.org/httpd/CouldNotDetermineServerName

1a:  Edited httpd.conf file to include ServerName 63.116.232.5

 

1b: The presence of this error message also indicates that Apache httpd was unable to obtain a fully-qualified hostname by doing a reverse lookup on your server's IP address.

In order for the server to accept external connections a reverse DNS lookup needs to be created. I created a reverse DNS lookup and  edited the /etc/hosts file to include the IPaddress, Fully Qualified Domain Name (FQDN), shortname.

 

This is the format suggested by the article:

 

127.0.0.1       localhost.localdomain   localhost       foo.example.com

 

Running the nbtstat -a 63.116.232.5 command on the machine results in the following:

 

WIN-8AIHI2J0524<00>  UNIQUE      Registered

THS-LIBRARY-VOD<00>  GROUP       Registered

THS-LIBRARY-VOD<1C>  GROUP       Registered

WIN-8AIHI2J0524<20>  UNIQUE      Registered

THS-LIBRARY-VOD<1B>  UNIQUE      Registered

 

So the FQDN = WIN-8AIHI2J0524.Ths-library-vod.local

 

I edited the /etc/hosts to the following (with versions using the local host ip 127.0.0.1 and the external ip address, IPv4 is being used):

 

63.116.232.5 WIN-8AIHI2J0524.Ths-library-vod.local

# The following lines are desirable for IPv6 capable hosts

::1 localhost ip6-localhost ip6-loopback

fe00::0 ip6-localnet

ff00::0 ip6-mcastprefix

ff02::1 ip6-allnodes

ff02::2 ip6-allrouters

ff02::3 ip6-allhosts

 

I've also read Adobe's port configuration articles and  changed the ports that Apache and FMS use as specified in the conf/fms.ini file, but nothing has worked so far. I restored everything to the original settings until I can find out exactly how to fix this.

 

Thank you.

 
Replies
  • Currently Being Moderated
    Apr 2, 2012 5:19 AM   in reply to Carlos1327

    Did you properly installed the server or

    1. Overritten the old server with the new one.

    2. Just untar the linux installer zip and copied them.

     

    The httpd.conf issue happens to me, in case I just do unzip of the bundle on linux and start using it.. If I do proper ./installFMS and then use the fms from installed path, then it works fine..

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 12, 2012 11:32 AM   in reply to Carlos1327

    Narrowed it down to this:

     

    1. Fixed: Got Apache to serve html pages to external connections: http://63.116.232.5/index.html

     

    2. FMS does not stream Quicktime/H.264 files, f4v files work.http://www.librarymedia.net/flash/player.html?source=rtmp://63.116.232 .5/vod/mp4:sample1_150kbps.f4v

     

    Re-encoded the file in Media Encoder. Changed extension from .f4v to .mov and the file  works. This is therefore a problem with the way the files are being encoded by Compressor. I don't know what the difference is between FMS 4.x and 4.5 when it comes to this issue since the .mov files from Compressor work with no problem with 4.x.

     

    http://www.librarymedia.net/flash/player.html?source=rtmp://63.116.232 .5/vod/mp4:Basketball2.mov

     

     

    I don't want to use Media Encoder because:

    1. My workflow is based on Compressor, and more importantly,
    2. I feel that I get better results with Compressor (better quality).

     

    Any  ideas, anyone?

     

    Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 3:11 AM   in reply to Carlos1327

    Hi,

     

    Can you just try a telnet from any external client to the public IP of the FMS machine and port 80 just to ensure there are no firewall issues happening?

    Also, can you check if you have not set any domain restrictions say in allowedSWFdomain.txt & allowedHTMLdomains.txt if you are using live or vod sample applications?

     

    Thanks,

    Apurva

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 5:31 AM   in reply to Carlos1327

    Hi Carlos,

     

    I'm able to telnet your machine on port 80 but connection fails on port 1935. Can you please reconfirm that port 1935 is open?

     

    You need to add port 80 in Apache and not replace it. So your httpd.conf will have :

    Listen 80

    Listen 8134

     

    Your fms.ini should have :

    ADAPTOR.HOSTPORT = :1935

     

    Once you make these changes, please restart your server and then try.

    If you're unable to access anything on the server, could you please check the Master log under <root_install>/logs for any errors and check what process is bound to those ports.

     

    Thanks,

    Ms Apurva

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points