Skip navigation
Currently Being Moderated

quicktime movie doesn't show up in shockwave

Jul 5, 2012 9:35 AM

Hi Guys,


perhaps somebody can help me with this question that is really hard to figure out.

I have a project made with director 11 that use some quick time videos(H264). Pubblishing the .app the project is ok. Instead if I export html and .dcr file, the .mov doesn't show up. I can hear audio, I can use interactive buttons, but the video is totally black.


To figure out I tried to put the URL in the internet button under the filename of the member tab. Also I tried to preload the movie using the following script but nothing. 


Have you any ideas?



property pURLString -- the URL o  the asset to preload

property pNetMember -- the cast member to assign the URL to



-- Attach this behavior to a frame script or sprite.


-- This behavior preloads a user-specified URL string and

-- stores a reference to it in a global variable.

-- The status of the global variable needs to be checked with

-- netDone(_global.netID)to be sure the asset is loaded.


-- Ken Loge -



on getPropertyDescriptionList me

  list = [:]

  addProp list, #pURLString, [#comment: "URL of asset to preload:", #format: #string, #default: ""]

  addProp list, #pNetMember, [#comment: "Cast Member to assign the URL to:", #format: #member, #default: "Video1"]

  return list



on exitFrame me

  -- set the filename of the specified member to the specified URL

  member(pNetMember).fileName = pURLString

  _global.netID = preloadNetThing(pURLString)






I am working on a IMac 3.4 Ghz Intel Core i7 8 GB RAM. Os X 10.6 snow leopard. Browser safari o google chrome.



Thank you very much,


  • Currently Being Moderated
    Jul 7, 2012 8:43 PM   in reply to elisabettaclarius

    Are you running the DCR locally or off a website? If local, then you should put all files into a folder called 'dswmedia'. When running Shockwave with external material, a dswmedia folder is required for security reasons.


    If the file is running on the web, you could try link the video cast member to the URL.



    Mark as:
  • Currently Being Moderated
    Jul 9, 2012 7:27 PM   in reply to elisabettaclarius

    Elisabetta - have you tried the files on another computer?


    Is this with Director 11 or 11.5?


    It could be that the Xtra has not downloaded.

    - Go to Modify > Movie > Xtras

    - Click on the AQAsset

    - Make sure the Download if Needed is checked. Perhaps uncheck it and then reselect it.

    - Save and republish.



    Mark as:
  • Currently Being Moderated
    Jul 11, 2012 7:44 AM   in reply to elisabettaclarius

    Hi Elizabeth,

    I meant QT6Asset not AQAsset which was a typo. Reason it is it is QT6 is because that's the last version of the QT Xtra developed. If you want to contact me direct, maybe I can look at your video and see what's happening. My contact is


    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points