Skip navigation
Currently Being Moderated

Where has the user defined variable pod gone?

Mar 16, 2009 2:20 AM

Last week I used the User Defined Variable pod to define some user defined variables in a project.

Today I click View > Pods > User Defined Variables and nothing appears! Furthermore, on the Insert menu, the User Defined Variable option is greyed-out.

Has anyone experienced this before? What is the solution?

Regards

Ian Saunders
 
Replies
  • Currently Being Moderated
    Mar 16, 2009 2:53 AM   in reply to s4unders
    Welcome to the forum.

    Easiest solution is to File > Load Default Environment.

    You say the insert option is disabled. When a topic has focus? Click in a topic and try again.

     
    |
    Mark as:
  • RoboColum(n)
    5,356 posts
    Oct 8, 2004
    Currently Being Moderated
    Mar 16, 2009 3:03 AM   in reply to s4unders
    Chances are it didn't Ian but may have got "hidden" somewhere in the UI. You may want to save your own environment in case this happens again.
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 16, 2009 3:04 AM   in reply to s4unders
    Possibly accidentally moved to somewhere in your layout where you couldn't see it.

     
    |
    Mark as:
  • RoboColum(n)
    5,356 posts
    Oct 8, 2004
    Currently Being Moderated
    Mar 16, 2009 3:29 AM   in reply to s4unders
    You could use a find and replace tool such as FAR or BkReplaceEm if you know the code that RH would use for a variable. There is not other way inside RH without manually looking for the text string and replacing it with a variable.
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 16, 2009 3:42 AM   in reply to s4unders
    For what it is worth, RH8 has a script that does this.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 18, 2010 7:38 AM   in reply to Peter Grainge

    Peter, you have once again saved me from having a meltdown!  The same thing just happened to me in RoboHelp 7.  All of a sudden I could get the Project Manager pod to open.  I uninstalled and reinstalled, and still couldn't.  Got an error and it shut down when trying to load my environments.  So I loaded the default environment, and voila!  It worked.  Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2012 3:54 AM   in reply to ginafromtampa

    Hi Everyone,

     

    I echo ginafromtampa's comment. Just had the same thing happen in RH8.

    FYI in RH8 it's File/Environment/Load Default Environment.

     

    So many thanks to Peter for this nugget of life-saving info.

     

    I'm still a bit surprised I had to do this though - all I did was close all pods to maximise my editing window space.

    Then upon trying to reset everything -> forget it, I didn't even have the View/Pods menu item (in fact I still don't).

    Is this (dare I say it) a slightly flaky GUI? or have I done something stupid?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2012 6:08 AM   in reply to TA Andy

    I'm not the great and powerful Peter, but hopefully youl find this helpful.

     

    Right-click the menu and choose Customize... Then from the General tab, ensure the Menu Bar is selected and click the Reset... button.

     

    Dismiss the dialog and see if things are better.

     

    If it helps, I've spent time with Peter on a few occasions. Perhaps that helps my credibility?

     

     

    Helpful and Handy Links

    RoboHelp Wish Form/Bug Reporting Form

    Begin learning RoboHelp HTML 7, 8 or 9 within the day!

    Adobe Certified RoboHelp HTML Training

    SorcerStone Blog

    RoboHelp eBooks

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2012 6:27 AM   in reply to Captiv8r

    Tee hee - pay no attention to the Rick behind the curtain !

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2012 6:41 AM   in reply to Captiv8r

    Rick jests. He's the man who taught me a lot of what I know and who will always remain king of the these forums.Rick has posted more replies than anyone else ever has and likely ever will.

     

    There are more than a few people who owe Rick for helping them along the way career wise and I am one.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2012 7:48 AM   in reply to Captiv8r

    Hi Rick,

     

    That did the trick nicely. Many thanks for that.
    I've just clicked the "Was this helpful - Yes" link on your post, so hopefully you'll get some extra chocolate or something now.

     

    Blimey, where would we be without forums eh? Anyone remember life pre-internet? Now there's a scary thought...

     
    |
    Mark as:
  • RoboColum(n)
    5,356 posts
    Oct 8, 2004
    Currently Being Moderated
    Jul 12, 2012 7:52 AM   in reply to TA Andy

    tumbleweed.png

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points