Skip navigation
Currently Being Moderated

Adding text to frames

Jul 14, 2012 5:12 AM

 
Replies
  • Currently Being Moderated
    Jul 14, 2012 5:12 AM   in reply to Community Help

    I am having no luck pasting text with italicized titles from OpenOffice, even after saving as RTF.  I did turn on Clipboard 'preserve all...'

    Anything else to do?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 5:26 AM   in reply to joannfigueras

    Use file>place, not paste.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 5:52 AM   in reply to Bob Levine

    Just tried PLACE with RTF-saved file, and no italics come thru; InD doesn't "see" .odt file.

    Great idea, but doesn't work here.  Using Mac Lion with InD 5.5.  (New computer, new InD, new OOo)

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 5:56 AM   in reply to joannfigueras

    Make sure you show import options when you place the file....

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 6:08 AM   in reply to Peter Spier

    Where are those options set?  Just searched InD Help, and found nothing.

    Thank you.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 6:24 AM   in reply to joannfigueras

    Check the checkbox in the Place dialog as shown below:

     

    Checkbox.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 7:15 AM   in reply to Steve Werner

    You can also leave the box unchecked and hold the Shift key down when you click Open.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 7:19 AM   in reply to Peter Spier

    I did the original check of "preserve..." in Show input options, but it doesn't work.  Will try shift on open.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 7:23 AM   in reply to joannfigueras

    If preserve formatting isn't working (and there really is some formatting to preserve), how you get to the import options dialog won't matter. You might want to try trashing your preferences. See Replace Your Preferences

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 7:25 AM   in reply to joannfigueras

    I seethat just brings up the Place optionsBut result is same.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 14, 2012 12:25 PM   in reply to joannfigueras

    Does the IDD font support italics for the font you are using? I believe that some don't. They use a variant like Oblique, maybe it doesn't map properly to italics during import?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2012 8:37 AM   in reply to locavore

    Changed to Arial, and same result--either PASTING or PLACING

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2012 9:12 AM   in reply to joannfigueras

    DId you try trashing the prefs as suggested above?

     

    Can you share a sample file that isn't working?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2012 11:00 AM   in reply to Peter Spier

    No, I did not clear prefs because my IDD is new, and the only thing I changed is "Clipboard Handling."

    I don't see where to attach a file.  I made two samples--one is RTF, and other is .odt.

     

    Thank you for helping.  (I don't want to buy a new copy of Office, which is what I used on by old computer)

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2012 11:16 AM   in reply to joannfigueras

    There's no way to predict when prefs will become corrupt, so please do try that.

     

    Attachments are disabled so you must post a link to a file hosted on some other system. One way to do that, if you don't have your server, is to use YouSendIt.com to send the file to yourself, then copy and paste the link here.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2012 12:05 PM   in reply to Peter Spier

    I deleted the prefs, reopened IDD (reset import options) and tried to PASTE or PLACE from RTF file.  Didn't work.  Then I saved my .odt file as OpenOffice (.docx), and I was able to PLACE with formatting.  IDD does not "see" the OOo (.odt) file, so I cannot attempt to PLACE that.  Looks like I chose the wrong open source suite.  LibreOffice is apparently not compatible with IDD.

     

    I am a volunteer layout person for a theatre, and now I must decide between a switch to OpenOffice or purchase a new version of MS Office.  It looks like Word is more compatible with IDD. 

     

    Thank you very much for following through with me.  Re:  Adding text to frames

    Joann

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2012 12:11 PM   in reply to joannfigueras

    ID should have no problems with RTF from ANY application. I don't know how many users there are importing from OpenOffice/LibreOffice, but we don't hear a lot of problems, which makes me think the issue is something else on your system.

     

    Import options only affect Placing. When you paste, the clipboard handling prefs kick in.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2012 9:05 PM   in reply to Peter Spier

    I have "All Information..." selected (radio button) in ID Clipboard prefs, and I just tried to PASTE text with italic titles from Mac Mail, and italics did not come thru.  I then did the same thing on the old computer with CS3, pasting from the same email, and what should have been italic was not, but it was pink shaded--so I knew it was a font problem and when I changed font to Arial, the italics showed. 

    Something is not right in my SS5.5.  I need to be able to paste with formatting.

    I just tried a copy/paste from my website into frames in CS3 and 5.5, and the same thing happened: OK in CS3 and not in 5.5. 

     

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2012 2:09 AM   in reply to joannfigueras

    After testing with Indesign CS3/CS4 and an older OpenOffice 3 (3.2.0), I can confirm, that the issue is already there in CS3 (5.0.4) and InDesign CS4 (6.0.6) on Mac OSX 10.6.8. All software in German.

     

    I tried several workarounds:

     

    1.a Copy/Paste from OpenOffice to TextEdit => OK

    1.b Copy/Paste  from TextEdit to InDesign CS3/CS4 => FALSE

     

    2. Save as .doc format out of TextEdit, place file in InDesign CS3/CS4 => OK

     

    3. Save as .doc format out of OpenOffice, place file in InDesign CS3/CS4 => FALSE

     

    4. Save as .rtf format out of TextEdit, place file in InDesign CS3/CS4 => FALSE

     

    5. Save as .rtf format out of OpenOffice, place file in InDesign CS3/CS4 => FALSE

     

    The used font was Times New Roman, also tried Adobe Caslon Pro, same thing.
    In my OpenOffice 3.2 there is no option to save to .docx, though opening .docx files are possible.

    I will try with the new version 3.4 and report back.

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2012 2:33 AM   in reply to Laubender

    Uwe,

     

    Thanks for posting this. It does sound like a bug or problem with text from open office, after all. Have you written it up?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2012 7:44 AM   in reply to Peter Spier

    @Peter – not yet.
    I'll give myself another try with OpenOffice 3.4.
    And testing with InDesign CS5, CS5.5 and CS6.

     

    But no spare time today for this…

     

    My solution with my combination of applications, so far, would be:

     

    A. Copy/Paste from OpenOffice to TextEdit
    B. Save as .doc format out of TextEdit
    C. Place the .doc file

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2012 9:00 AM   in reply to Laubender

    For comparison, "new" system is Mac OS X 10.7.4, IDD CS 5.5, LibreOffice 3.5.3.2, TextEdit 1.7.1

               "old" system is Mac OS X 10.4.11, IDD CS 3, Word 2004 

     

    "New Sys"  Copy/Paste all FALSE (.odt, .RTF, Mail, html); Place from docx (saved from LibreOffice) TRUE; other Place's all FALSE

    "Old Sys"   Copy/Paste & Place all TRUE

     

    Joann   --Thanks for joining, Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 12:59 PM   in reply to joannfigueras

    Followup to my copy/paste with formatting problem in CS5.5  [My "new system" is described in msg above 7/17.]

     

    I just downloaded trial copy of MS Office, and copy/paste with formatting is works correctly from Word docs.  I also opened files saved as RTF from LibreOffice, and formatted paste from them works also. 

     

    Caveat:  installing MS Office messed up my LibreOffice files!  Those files were fine yesterday; now I can OPEN them, but they're unreadable.  After some panicked minutes, I SAVED them as TEXT out of LibreOffice and opened them in Word/Excel and they're fine. 

     

    CONCLUSION:  As of now, LibreOffice and InDesign are not compatible.

     

    Thanks to everyone who helped.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points