Skip navigation
Currently Being Moderated

Encore CS6 always transcodes 1440x1080 h264 video imports

Jul 19, 2012 8:17 AM

If I encode an interlaced 1920x1080 files with x264 I can import it into encore and it will not transcode. If I import a 1440x1080 file into encore it always wants to re-transcode. The only clue I have is that it does not get the pixel aspect ratio right and I have to force it to be 4:3. Unfortunatly Encore does not re-evaluate for transcode when I do this. If I import the file into premiere pro the correct par is detected. So there seems to be a difference between how premiere and encore determine the par.

 

The file is a raw h264 video 1440x1080i50 with the sar set to 4:3.

 

If I use the premiere pro encoder that works correctly. Please can someone tell me how I can correct for this problem. I want to use x264 as it is the most superior encoder on the planet.

 

Regards Trevor

 
Replies
  • Currently Being Moderated
    Jul 19, 2012 8:53 AM   in reply to tjh65

    Have you tried going to File | Transcode Settings and setting the Quality Preset to Do Not Trancode after forcing the PAR to 4:3?

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2012 10:05 AM   in reply to tjh65

    If you've already transcoded the clip, then you'll have to go to File | Revert to Original to force En to stop looking for the transcoded version and instead to seek the original version.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2012 7:30 PM   in reply to tjh65

    1440x1080i50 with the sar set to 4:3.

     

    I'm not sure that's Blu-ray legal.  All HD resolutions are 16:9.  Only SD resolutions have a 4:3 option.  So 1440 x 1080 will have a PAR of 1.33 and a DAR of 16:9.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2012 10:37 PM   in reply to Jim Simon

    Jim is right. Blu-ray spec does not allow 4:3 for HD resolutions.

    Following are the Encore supported Blu-ray compliant dimensions :

     

    720 × 480     4x3   29.97   Interlaced 

    720 × 480     16x9 29.97   Interlaced 

    720 × 576     4x3   25,00   Interlaced 

    720 × 576     16x9 25.00   Interlaced 

    1280 × 720   16x9 23.976 Progressive 

    1280 × 720   16x9 50.00   Progressive 

    1280 × 720   16x9 59.94   Progressive 

    1440 × 1080 16x9 23.976 Progressive 

    1440 × 1080 16x9 25.00   Interlaced 

    1440 × 1080 16x9 29.97   Interlaced 

    1920 × 1080 16x9 29.97   Interlaced 

    1920 × 1080 16x9 25.00   Interlaced 

    1920 × 1080 16x9 23.976 Progressive

     

    Encore has a feature called "Asset Based Transcoding" for Blu-ray.  In this, if Encore gets an asset which has dimensions from any of the above listed, then Encore will create a timeline based on the asset's dimension and will transcode according to that only. It will not consider the project settings in this case.

    But if the asset has any other combination of dimensions, then Encore will create a timeline based on the project's settings and will transcode the asset based on that only. Asset's properties will be ignored in this case.

     

    Since your asset is 1440x1080 with 4:3, which is not Blu-ray compliant, so Encore will want to transcode the asset. As premiere pro does not go into the burning process, so it does not change the sequence settings there.

     

     

    -Ramesh.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2012 3:13 AM   in reply to tjh65

    Please post screenshot of the file properties. The file properties can be seen with Mediainfo tool.

     

    -Ramesh.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2012 5:00 AM   in reply to Ramesh_Encore

    When he says "4:3", he means that it has a PAR of 4-divided-by-3, or 1.333, which is correct.  And when he says 50I, he's using camera mfrs. terminology -- it's the same thing as 25 fps interlaced in your list.

     

    So his 1440x1080i50 (4:3) file is really a 1440x1080 (1.333) 25 fps interlaced file, which is spec-legal, if I've parsed his posts correctly.

     

    To the OP: did you try Revert to Original?  It may save you the HDInfo hassle.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2012 1:35 PM   in reply to tjh65

    MBAFF support is built-in now to x264.  I'm not a real expert on x264 settings, but as I understand MBAFF, even if --tff or --bff is specified in the x264 settings, if the adaptive encoder doesn't find any "gaps" that should exist between scan lines in interlaced video, then it will still encode as progressive.

     

    Is this video from a STB?  If so, it's possible the content was progressive, but encoded with MBAFF for broadcast; or encoded with MBAFF at the STB by the box's encoder.  Kind of a "fake interlaced" result, maybe? 

     

    Anyway, if that's the case, then it makes sense that Pr/En see the footage as progressive.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2012 11:30 PM   in reply to tjh65

    Can you share any such small test footage? There was a H264, 2 pass encoding bug but that was fixed in CS6. May be this is some other case that is causing this issue.

     

    -Ramesh.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2012 4:07 PM   in reply to tjh65

    I thought this would be appropriate to post in this thread as it is a very similar issue with just a codec difference.

     

    Specifically, I shoot at 1440X1080i/60 with a Canon HV20.  With CS4 and 5 I have always used AME to render to MPEG2 at 1440x1080i.  Encore never re-encoded my footage.  So while the OP used H.264, I am using MPEG2.  I was going to use H.264 but I had enough room for HQ MPEG2.

     

    So in this particular project, when in CS6, I rendered using MPEG2 in AME and then brought it into Encore CS6 at 1440x1080i. Like the OP, it immediately began transcoding.  No way to stop, the file transcode option is greyed out, etc. This is even though I setup the project initially at 1440x1080. This setting must be made when you start a new Encore project...it cannot be changed.

     

    So I tried the same footage in CS5, I setup a new project in Encore, chose 1440X1080 for my new Encore project and when I put the exact same footage into Encore CS5.1 after making the project 1440x1080, it comes up "Don't transcode" (as it should) and its properties say 1440x1080.

     

    Now perhaps I should be transcoding my video to 1920x1080 and I know some recommend that, but I've had good results with keeping my renders at the source footage ratio and they look great on Blu-Ray players which of course changes the pixels to HD widescreen.  But I don't think Encore should FORCE us to transcode since 1440x1080 is an approved ratio.

     

    Is this a new workflow decision by Adobe or a bug?

    Is there any way to just tell Encore to leave the video alone?  In the asset property box there is a blu-ray transcode drop down, but before you can even get to it, it starts transcoding to 1920x1080.  Which again, makes no sense since the project was indeed setup at 1440x1080.  I even just double checked as I thought I was losing my mind!

     

    For now, I am just going to use Encore CS5.1 since it doesn't care that the video and audio were rendered in CS6, it won't even know the difference. Thanks to some great advice from people on this forum, I was advised to leave CS5 on my machine.  Great advice!

     

    Any thoughts would be appreciated.

     

    BJBBJB1

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2012 6:26 PM   in reply to BJBBJB1

    brought it into Encore CS6 at 1440x1080i. Like the OP, it immediately began transcoding.

    Very odd.

     

    I don't think that's what the OP said. I don't know what process in Encore would transcode without you telling it to do so.  The only thing that EN does automatically (other than examining the file) is audio caching etc.

     

    What are you seeing that tells you it is transcoding? This is immediately upon importing "as asset" or "as timeline" or what?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2012 6:35 PM   in reply to Stan Jones

    Stan,

    I imported the video clip as an asset.  In the Blu-Ray column to the right of the filename, within seconds it switched to 5%.....then 6%....etc.etc.  I let it run to conclusion, and sure enough the properties on the clip had changed to 1920X1080.  Clearly it transcoded it.

     

    I just finished running the same clip through Encore CS5.  It stuck with "do not transcode" and definitely built the BD image without transcoding the video.

     

    It appears to be ignoring the project resolution you choose (and cannot change) when you start a new project.

    If that was set to 1920X1080, I would expect it to transcode right away.

     

    I guess the setting I am looking for is the "do not transcode" setting/preset.  In CS5 with that set it won't transcode if it is BD compliant.

     

    After re-reading, perhaps it is not autmatically running for him, but it is forcing him to transcode when previously he wasn't.  Sorry if I mixed up the issues. When it happened to me I actually remembered reading this post!

     

    BJBBJB1

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2012 8:40 PM   in reply to BJBBJB1

    Very odd. The project setting is a default transcode that is primarily for menus.

     

    Try a new project, new name, import your video as asset. Does it transcode immediately?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 10:34 PM   in reply to Stan Jones

    I tried two things.  I setup a new encore project and imported the same clip, it sending pending for a few seconds and then began transcoding.

     

    Then, just to be sure that it was not something strange with my clip wrapper or something, I took another clip (same resolutions, etc), brought it into encore cs6 and it did the exact same thing.  It began rendering.

    It may not be the project setting that is doing it but there is something with the encore/render interface that is grabbing that high def preset immediately and rendering.

     

    And since it does not que up and just starts, you have no chance to change it.

     

    It would be like if AME just fired up immediately before you had a chance to tell it what to do.

     

    I would assume it is repeatable with another 1440x1080i clip.

     

    I guess back to CS5 Encore for now.

    I did see something in the Encore preferences about using AME for rendering but not sure what it did and I was having enough problems.  Wonder if there would be some joy there.

     

    Thanks,

     

    BJBBJB1

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 11:39 PM   in reply to BJBBJB1

    The "use ame" preference requires you to select an asset and click "transcode now."

     

    I would reinstall.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 31, 2012 7:56 AM   in reply to BJBBJB1

    Please don't double-post.  Duplicate post deleted.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 31, 2012 8:17 AM   in reply to Jeff Bellune

    Okay......sorry about that.

     

    I am very sensitive to starting new double post threads...however I was not aware that trying to tap into another thread that has a group of people subscribed to it that may not see another thread (that perhaps they were not subscribed to) was not allowed.  Unfortunately I did not see the other very detailed analysis and technical solution in that other thread until after I had posted the first time.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points