Skip navigation
AZElizabeth57
Currently Being Moderated

Missing Topic Pages in Project upgraded from RHTML8 to RHTML9

Jun 17, 2011 9:33 AM

I have a very extensive help project that I just did two things with:

 

  • First, I moved it over to a new laptop which my client provided me that has Html 9 instead of 8.
  • When I opened the project on the new machine, it prompted me to upgrade to v9, which I did

 

However, when I viewed one of my many TOCs and tried to open the first Topic in the topic editor pod, the topic would not display.  When I searched for the topic in the topic list, using Edit/Find Topic, it told me it could not be found.

 

I then went to my Windows Explorer and opened the Help Source directory.  The "missing" topic was there.  Moreover, when I double-clicked on it, the topic displayed just as it should.  I found several other topics with the same issue.  I cannot look through all the topics to find out which ones are missing as there are hundreds of them in the project.

 

I have tried deleting the project and copying it back from my old machine to my new one 5 times, both using a thumb drive and loading it up to our ftp site then down to the new machine.

 

Is this a bug?

 

Thanks,  Elizabeth

 
Replies
  • Currently Being Moderated
    Jun 17, 2011 9:52 AM   in reply to AZElizabeth57

    Were both versions (RH8 and RH9) all patched up to date?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2011 10:12 AM   in reply to AZElizabeth57

    Make sure that the RH8 machine was patched too - there were some issues with that release that were damaging projects. See Peter Grainge's site grainge.org for the workaround in Opening Projects.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2011 11:56 AM   in reply to AZElizabeth57

    Did you try killing the .cpd file in the project on the RH9 machine? It may have gotten messed up; deleting or renaming it causes RH to rebuild it.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2011 1:19 AM   in reply to AZElizabeth57

    If the RoboHelp 8 project was opened without the 802 patch applied at the time, the damage was likely done there. Applying the patch alone does not fix the problem.

     

    I suspect if you go to a backup of the 8 project and open it in 8, you will see the same problem.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2011 12:02 AM   in reply to AZElizabeth57

    It is not a case of something being hidden in files. RoboHelp 8 without the 802 patch lost track of files. You may have opened a folder and a topic and worked on it but the act of opening the project may have caused it to lose track of topics elsewhere in the project. It may have done so as you closed the project. The point is that opening a project in 802 could have resulted in the problem you describe.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Aug 24, 2011 9:07 AM   in reply to AZElizabeth57

    Hello,

       I have the same issue. I am using Robohelp 8.0.2.208 and going through an upgrade process when opening a web help project created in an earlier version of Robohelp, perhaps version 6. The origianl project has a .mpj file, after upgrade this is replaced with a .xpj file. My project contains 322 topic pages but only 207 appear in the topic list following the forced upgrade. Any help would be appreciated.

    Greg

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 24, 2011 11:35 AM   in reply to gregH0123

    This thread is about upgrading from 8 to 9. It sounds like you are upgrading to 8, is that the case? For now I will assume it is.

     

    Did you apply the patches when you installed 8 and before you opened the project? If you opened the project in 8 before the patches were applied, that could well be why you have missing topics. Why is explained in Opening Projects on my site.

     

    Either way, do you have a lot of broken links and are the missing topics still where they should be if you look at the project folder in Windows Explorer?

     


    See www.grainge.org for RoboHelp and Authoring tips

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 24, 2011 12:24 PM   in reply to Peter Grainge

    Hello,

       Yes, I am upgrading to Robohelp 8. Version 9 is not approved by my IT dept yet. I have only one broken link. I applied the 8.0.1 and 8.0.2 patches prior to opening the project in Robohelp. Also, the glossary and index are empty following the upgrade, previosly they had many entries.

     

    Thanks,

    Greg

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 24, 2011 12:26 PM   in reply to AZElizabeth57

    Sorry, forgot the last part...yes the topic files are still in there, they just don't appear in the topic list.

     

    Greg

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 24, 2011 1:07 PM   in reply to gregH0123

    Very odd.With all those topics missing would have expected more broken links.

     

    Your options are to import the topics back in and you can select all the topics in a given folder and import them in one go, that should make it fairly quick, or to try a new upgrade. I think I would try the latter first.

     

    I'm assuming the project is local.

     

    You say you applied both patches, check that Help > About does show 802.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 8, 2011 12:48 PM   in reply to AZElizabeth57

    I am having the same problem. We have tried unistalling RH9, applying the 8.0.1 and 8.0.2 patches, and deleting the .cpd file before reopening the project in RH8 - now the topics (and many graphics files and all sub folders and their contents) are missing from the RH8 project. Repairing the links only restores a few topics. For example: I have one folder with 118 topics - only 12 converted to RH9, 6 more were recoverd with the missing link repair. so I am still missing 100 topics.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2011 11:40 AM   in reply to BlalockD

    Hi and welcome to the community,

     

    Do you have patch 9.0.1 installed? Take the backup of the RH8 project and make a new copy. Try to upgrade the backup to RH9 after installing the patch.

     

    Greet,

     

    Willam

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2011 11:42 AM   in reply to AZElizabeth57

    I backtracked through our version control software to find the last version that opens without issue.Noticed that the roled back root.fpj file conflicted with the current one on my machine so I compared them - ALL the lost folders and topcs were gone from the currrent file. I deleted my current root.fpj file and replaced it with the one that worked properly and Viola! My topics and other files seem to have reappeared. I am not finished inventorying (and since literally hundreds of topics and .gif or .png files were missing that inventory is going to take some time), but most of the missing fiels seem to have reappeared. Very good news.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2012 12:40 PM   in reply to BlalockD

    Verify that you do not have any special characters in the file name or in the name of the folder that contains them. We had them in RH 8 version of the project (I know, I know, not supposed to do this--project was inherited) and had topics dropping because of that.

     

    Had me vexed for a long time!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2012 12:20 PM   in reply to twxrx

    I am in the process of upgrading from RH8 to RH9. I am using RH8 HTML, RH 8 server and I am current on all patches. I opened my disk and there is no readme document on how to upgrade to RH9.

     

    We have to move to a new 64 bit server and RH8 can not work on 64 bit server. Also we have not received the RH9 Server disk. I have these questions 

     

    1). Where can I get instructions on the procedure of upgrading to RH9?  

    2). Can I uninstall RH8 server then upgrade the RH8 HTML client on the current server to RH9 HTML client then have our IT people move RH9 to the new 64 bit server.   

    3). Since I will not have RH9 server for some time can I manually publish a project? 

     

    System attributes

        RoboHelp HTML V8.02

        RoboHelp Server V8.0

        WebHelp Pro 5.5o (7.00.145)

     

    

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2012 12:49 PM   in reply to rwrich21

    This post should be in its own thread or split into 2 - one about upgrading your RH8 projects to RH9 (which is dead simple - just open them in RH9, they convert automatically) and one about upgrading RH Server 8 to RH Server 9. Have you checked the RH Server forum first?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2012 11:05 AM   in reply to AZElizabeth57

    Hi there

     

    Sorry, but I have to respectfully disagree with your assessment about RoboHelp being "deeply flawed". I've used it almost daily for the last 20 years (Yes, I mean that literally) and while it is software and all software has flaws, I have never found it to be "deeply flawed". But I suppose that's all in the eye of the beholder.

     

    Like ANY piece of software, RoboHelp may not behave as expected on certain and specific configurations of hardware and with specific permissions setup on the operating system.

     

    As for closing threads, there really is no process to close them. As a volunteer forum moderator, we can lock threads, but we only do that if there is something like SPAM attacks or other undesirable activity. So just leaving a thread alone will cause it to eventually fall off the list until it's been posted to again.

     

    Cheers... Rick

     

    Helpful and Handy Links

    RoboHelp Wish Form/Bug Reporting Form

    Begin learning RoboHelp HTML 7, 8 or 9 within the day!

    Adobe Certified RoboHelp HTML Training

    SorcerStone Blog

    RoboHelp eBooks

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points