Skip navigation
arpette
Currently Being Moderated

Attaching keyboard shortcuts to click boxes in Captivate 6

Jul 21, 2012 6:32 AM

Tags: #captivate #box #6 #keyboard_shortcuts #click

Just wondered in anyone else is having difficulty attaching  keyboard shortcuts to click boxes in Captivate 6.  I simply want to attach the Delete Key to a click box to simulate the removal of highlighted text in a simulation.  Things seem to be working in preview mode, but when I preview in browser the simulation freezes.  I have since tried attaching a number of simple keystrokes to click boxes, buttons and smart objects, and they all seem to have the same problem - the correct keystroke does not move the simulation forward.  

 
Replies
  • Currently Being Moderated
    Jul 21, 2012 8:22 AM   in reply to arpette

    Hi there

     

    This could be the result of timing and the action assigned to the Click Box. For example, if the Click Box is timed to pause the slide at perhaps four seconds and the action is configured to simply "continue", if you press the shortcut at the two second mark, the Click Box carries out its action and continues, but pauses at the four second mark. In this case, you would need to press the shorcut again after the pause.

     

    The bottom line is to check the action and the timing.

     

    Can you post screen captures of the Click Box properties and the Timeline for the slide?

     

    Cheers... Rick

     

    Helpful and Handy Links

    Captivate Wish Form/Bug Reporting Form

    Adobe Certified Captivate Training

    SorcerStone Blog

    Captivate eBooks

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 24, 2012 2:26 AM   in reply to arpette

    Hi,

     

    Sorry to say we are not able to reproduce the issue reported by you.

    Can you send us the project for investigation, it will give us more info for debugging the issue.

     

    Mail the project or sample set of slides where issue is occuring to below mail id.

    mathkyar@adobe.com

     

    Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 6, 2012 3:19 PM   in reply to NarutoCaptivate

    I'm having the same problem. This is on a project that was created in 5, where the keystroke worked fine. Now in 6 it doesn't. I deleted the click box, and then recreated it, and it still doesn't work. It's fine in preview, but not when running in IE (I haven't tried other browsers).

     

    Has anyone found a solution?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 7, 2012 7:22 AM   in reply to err229

    Same problem. CP6 for Windows. Building software demo with slide containing a click box with "Enter" as shortcut to simulate user input. If I preview from that slide, it works. If I preview from any previous slide, the faulty slide plays (I can see it advance and pause on the scrollbar), but will not accept ANY keyboard input. I have changed shortcuts, but the slide is dead to all input. Clicking anywhere on the slide activates it so that it will accept the shortcut. However, that is not the input that I need.

     

    Works perfectly in 5.5. Am dreading the prospect of recreating several projects since there is no way to roll back from CP6.

     

    I would be happy to use an object other than a click box, but can't figure out an alternative. I need the slide to pause and then advance to the next slide when the user to presses "Enter."

     

    Any ideas???

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 7, 2012 2:04 PM   in reply to watrain2012

    OK, I know how to work around this, but it is bizarre. My problem is going from a slide with a click box to a slide that requires a keyboard shortcut. That combination doesn't work for me together in CP6. The keyboard input on the second slide is ignored. After much grief, I found that the problem was caused by the interaction with the previous slide with the click box. Through trial and error, I discovered that the keyboard shortcuts only work on the second slide IF I completely cover the click box on the previous slide with an object such as a text box. An empty, transparent text box works fine. The text box must be above the click box on the timeline. Unfortunately, the hand cursor does not display--but the actions work.

     

    This makes no sense to me, but it does work. I have the same issue with TEB's. I do not have this problem in 5.5. It has to be a bug in 6.0.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points