Skip navigation
lozandier
Currently Being Moderated

Can Dreamweaver CS6 Won't Recognize PHP 5.4 Array Syntax and Other New Syntax

Jul 21, 2012 1:41 PM

Tags: #cs6 #php_5.4

Dreamweaver CS6 doesn't seem to be recognizing PHP 5.4 syntax such as the new array syntax which is equivalent to (finally) allowing  you to  declare arrays in the way Javascript has and other great web programming languages ( $array = [ 'item1', 'item2', 'item3,]

 

 

Also traits seem to be ignored as well, will this be added soon (hopefully not in a 'Dreamweaver CS6.5'); 

 
Replies
  • Currently Being Moderated
    Jul 21, 2012 2:44 PM   in reply to lozandier

    Unfortunately no.  The release cycle of DW put its release one month after the release of PHP 5.4.  It would be more likely in DW CS6.5 or CS7.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2012 3:07 PM   in reply to lozandier

    lozandier wrote:

     

    Couldn't it be just patched/be in a update rather than wait a whole new release?

    Yes it could and that's one of the selling points of the Adobe Creative Cloud - they'll incrementally release features via patches when they're ready.

     

    That said, there are no patches for Dreamweaver CS6 (Cloud version) yet.

     

    Perpetual license customers (those who have a serial number for their products) still have to wait for a new version. No incremental patches for them.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2012 3:10 PM   in reply to lozandier

    Dreamweaver is trying to do this with the "Creative Cloud" where software is no longer owned on a perpetual license, but rather on a leased license whereby you pay to keep the latest release.  There are still a large number of users/companies that have not moved to this model for a number of reasons.  I'm not trying to justify them not updating, but there are a lot larger, more critical issues that some users are having such as FTP not working where updating to the latest and greatest PHP is not as big of an issue.  And PHP 5.4 is not all that common at the moment on hosts so it's only for a limited number of users.  As much as I hear where you are coming from and understand how important it is to stay on top of changing web technologies, I don't foresee it happening any sooner.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 15, 2013 2:19 PM   in reply to lozandier

    I second this request!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 15, 2013 3:13 PM   in reply to adamjazz

    Feel free to tell Adobe via the official feature request form

    https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

     
    |
    Mark as:
  • Currently Being Moderated
    May 19, 2013 12:03 PM   in reply to lozandier

    I second!

     

    Does anyone know how the syntax is checked by DW? I've opened all the files I couls in /Applications/Adobe/Adobe Dreamweaver CS6/Configuration

    I've found how to change the color coding (trait is not colored like class or interface).

    But I couldn't find which file defines the syntax validation.

     

    It's really annoying especially because you can't disable syntax checking! Not even an option in preferences.

     

    Time to switch to another app?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points