Skip navigation
Qsawatsky
Currently Being Moderated

Adobe Premier Elements 9 setup problem

Jul 25, 2012 1:20 PM

Tags: #9 #elements #premier #installation #premire_elements_9

Hello.

 

I recently purchased a Dell Inspiron 15R special edition laptop, and was provided with a copy of Adobe Premier Elements 9.  However, whenever I attempt to use PRE, it asks me to select my country/region.

 

Normally, this would not be an issue, but the country/region selector drop down menu is completely blank and does not change when I click on it.

 

Is there a way I could fix this problem?

 

Thank you.

 
Replies
  • Currently Being Moderated
    Jul 25, 2012 2:41 PM   in reply to Qsawatsky

    It might possibly have something to do with your DPI setting.  If you go to Start>Control Panels>Display and select the Set custom text size what is it set too?  Please try setting it for 100% and see if you continue to face the same difficulty.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2012 4:13 PM   in reply to Qsawatsky

    Interesting - I had a similar issue with Elements 10. I was told by Adobe Support to:

    1. Uninstall Elements 10.
    2. Change the date on my Mac to 11/01/11.
    3. Reinstall Elements 10.

     

    It worked!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 9:44 AM   in reply to Qsawatsky

    Excellent thank you for the update Qsawatsky!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points