Skip navigation
Currently Being Moderated

Find and Replace in HTML crashes RoboHelp HTML

Jun 23, 2008 11:37 AM

When trying to do a Find and Replace in the HTML view, RH HTML crashes. Has anyone else seen this? I have both patches applied and am working in XP with 4 gigs of memory.
 
Replies
  • Currently Being Moderated
    Jun 24, 2008 2:22 AM   in reply to wgmeisheid
    Hi William!

    Is it possible for you to provide us the search or find string that you are using - there could be a character specifc problem. Adobe team will be gald to help you.

    Regards,
    Pooja
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2008 7:07 AM   in reply to wgmeisheid
    That is part of a table definition and I am wondering if perhaps you are amending part only and confusing the life out of RH.

    I would take a table before the amendment and copy the definition. Then amend just that table using functionality within RH. Finally copy the new definition and compare the two.

    Is your replace the only change RH would make?

    I also notice that you are changing from a mix of inches and points to just points. Maybe that is worth checking as well.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2008 10:36 AM   in reply to wgmeisheid
    Are you aware that the RH Find/Replace does not do multiple lines or extra spaces? Depending on the rest of the code that precedes these values, you might find that you have to do them manually because some values have wrapped to the next line. Either that, or find a more robust tool like FAR or BK ReplaceEm.


    Good luck,
    Leon
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2008 10:18 PM   in reply to wgmeisheid
    Hello William!

    Thanks for the Find straing! At Adobe, we have tried to recreate the scenario with the exact string and as well as mutations of it but RH HTML did not crash. If you are still facing this problem, our suggestion would be to break down the string in two parts and then use Replace all functionality.

    Regards,
    Pooja
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 5, 2012 2:01 PM   in reply to Pooja_at_Adobe

    RoboHelp 9 has crashed several times as I've been using Find and Replace in Files.  I am rebranding our user docs and replacing such text as product names using a variable like this:

    <?rh-udv_start name="company_product_name_track-it" ?>BMC Track-It!<?rh-udv_end ?>

    I'm searching for the product name that does not yet have a variable with Find and Replace in Files, and replacing it with the variable code.

     

    The crash first occurred only when I clicked Replace All.  Then I accidentally clicked it and it crashed again.  Is there a specific problem with using variables with the Find and Replace in Files feature>

     

    Thanks.

     

    Gina

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 5, 2012 2:35 PM   in reply to ginafromtampa

    It crashed again, but this time when I tried to generate the Webhelp:

    Error:  Unhandled exception at 0xccccffff in RoboHTML.exe: 0xC0000005: Access violation reading location 0xccccffff.

     

    My files are in Microsoft Visual Studio 2010 source control, and I haven't had problems like this before I tried to use variables with Find and Replace in Files.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 2:01 AM   in reply to ginafromtampa

    Health warning: I don't use source control.

     

    Could it be the find and replace is trying to work on files you have not checked out?

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 4:27 AM   in reply to Peter Grainge

    No...all the files are checked out (only to me).

     

    Thanks.

     

    Sent from my iPhone

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 6:35 AM   in reply to ginafromtampa

    Peter,

     

    I might have to contact support.  I just tried this:

    Copied my RoboHelp source files from Windows Explorer to another folder and removed Read Only. 

    Tried to generate WebHelp.

    Got this error:

     

    Thanks!

     

    Gina

     

     

    Problem signature:

     

    Problem Event Name: APPCRASH

    Application Name: RoboHTML.exe

    Application Version: 9.0.2.271

    Application Timestamp: 4ede0156

    Fault Module Name: StackHash_0a9e

    Fault Module Version: 0.0.0.0

    Fault Module Timestamp: 00000000

    Exception Code: c0000005

    Exception Offset: b640e9cc

    OS Version: 6.1.7601.2.1.0.256.48

    Locale ID: 1033

    Additional Information 1: 0a9e

    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

    Additional Information 3: 0a9e

    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

     

    Read our privacy statement online:

     

     

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 6:59 AM   in reply to ginafromtampa

    I'm chatting with Support now and will post the outcome.

    Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2012 9:58 AM   in reply to ginafromtampa

    OK.

     

    If they do not give an immediate answer, try in another project next.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2012 12:58 PM   in reply to Peter Grainge

    Peter,

     

    I reported this to Adobe support almost 3 weeks ago with a bronze (email) support contract and there is still no resolution.  I tried this in other projects and it works fine.  I FTPd my project to Adobe 2 weeks ago and they haven't been able to resolve the problem.  (They haven't said whether or not they could reproduce the problem.)

     

    I rolled back the changes I had in source control and now just got the same appcrash error trying to use the Edit > Find and Replace in Files feature.  This is so frustrating because I have to rebrand several RoboHelp projects with hundreds of topics each.  I'm having to go file by file to find and replace text.

     

    I haven't had this problem in the 11 years I've been using RoboHelp.  Very strange.

     

    Thanks.

     

    Gina

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2012 1:33 PM   in reply to ginafromtampa

    So to go back to the beginning

     

    You search for

     

    BMC Track-It!

     

    and replace with

     

    <?rh-udv_start name="company_product_name_track-it" ?>BMC Track-It!<?rh-udv_end ?>

     

    Correct?

     

    I have recently done the same thing and it worked without any problems.

     

    Do you have Rh on a machine away from the office?

     

    • If you do, try it there. I have had people tell me their project was checked out but when it is sent to me, the project is still looking for the source control.
    • If you do not, can you share the project with me? Please do not send just yet. Post back first.

     

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2012 1:38 PM   in reply to Peter Grainge

    Peter,

     

    I'm not trying to replace the text with a variable now.  I am just searching for Track-It! and replacing it with BMC Track-It!.  I have tried it on a different computer where I had checked in all the files, then copied the project to an external hard drive and opened it, with the same problems.  This is project specific -- it's not happening with my other projects. I can't share the project unfortunately.  I really appreciate your help though.

     

    Gina

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2012 1:46 PM   in reply to ginafromtampa

    So there's something messed up in just this project - what about doing a FAR outside of RH as a quicker workaround?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2012 1:49 PM   in reply to Jeff_Coatsworth

    Jeff,

     

    I haven't used FAR.  Any tips before I search for it and try to use it?

     

    Thanks.

     

    Gina

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2012 1:56 PM   in reply to ginafromtampa

    Sorry, I just meant an external Find and Replace (FAR) program; not any specific one. There's a whole bunch out there. Just make sure that you've got a copy of your project zipped up as a backup - FAR programs can make things go sideways real fast.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 1:27 AM   in reply to ginafromtampa

    Gina

     

    In the other projects, is the search for the same string?

     

    Regardless, I agree with Jeff that using some other tool may solve your problem provided you can back out if things go wrong. Presumably you would just discard what you have checked out and start over as you have source control.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2012 11:40 AM   in reply to Peter Grainge

    Adobe support got back to me.  There was something wrong with one or more of the variables.  They were able to reproduce the problem.  We don't know, though, which of the variables was causing the crash and why.  I deleted the variables and selected the option to convert the variables to text. Now the Find and Replace in Files works. I only tested Replace, not Replace All in File or Replace All in the Find and Replace in Files dialog.  But this will work for me.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points