Skip navigation
Currently Being Moderated

FB 4 is not starting after updating network setting

Jul 26, 2012 2:14 PM

Tags: #problem #flash_builder #flash_builder_4.5

I was following the instustions to setup a local Flash Builder development environment. Now, Flash Builder crashes with an error every time I open it. Here is what I did:


The only change I did was - update the Network Connection setting (under preferences). I made the active provider manual and entered a local network ip address. Later I found that the proxy at that ip address does not exist (no reponse from ping).


Then I tried to swap the exisitng plugins folder with a different one with all the plugins. But then I reverted to the original folder.


Now everytime I start Flash Builder I get an error message: "An error has occurred. See the log file <log file path>".


Here is the log file from the latest crash:


================Start of log file================================================================= ============


!SESSION 2012-07-26 14:07:40.921 -----------------------------------------------



java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

Command-line arguments:  -os win32 -ws win32 -arch x86



!ENTRY org.eclipse.osgi 4 0 2012-07-26 14:07:41.796

!MESSAGE Application error


java.lang.RuntimeException: Application "com.adobe.flexbuilder.standalone.FlexBuilderApplication" could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner,, org.eclipse.equinox.p2.artifact.repository.mirrorApplication,, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.metadata.generator.EclipseGenerator, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher,,,, org.eclipse.ui.ide.workbench, org.eclipse.update.core.standaloneUpdate, org.eclipse.update.core.siteOptimizer.



          at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runAppli cation(

          at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Ec

          at va:368)

          at va:179)

          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

          at java.lang.reflect.Method.invoke(Unknown Source)

          at org.eclipse.equinox.launcher.Main.invokeFramework(

          at org.eclipse.equinox.launcher.Main.basicRun(




!ENTRY org.eclipse.osgi 2 0 2012-07-26 14:07:41.875

!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:

!SUBENTRY 1 org.eclipse.osgi 2 0 2012-07-26 14:07:41.875

!MESSAGE Bundle reference:file:plugins/com.adobe.flexbuilder.project.e35_1.0.0.201001 080934.jar was not resolved.

!SUBENTRY 2 com.adobe.flexbuilder.project.e35 2 0 2012-07-26 14:07:41.875

!MESSAGE Missing host com.adobe.flexbuilder.project_0.0.0.



!ENTRY org.eclipse.osgi 2 0 2012-07-26 14:07:41.875

!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:

!SUBENTRY 1 org.eclipse.osgi 2 0 2012-07-26 14:07:41.875

!MESSAGE Bundle com.adobe.flexbuilder.project.e35_1.0.0.201001080934 [6] was not resolved.

!SUBENTRY 2 com.adobe.flexbuilder.project.e35 2 0 2012-07-26 14:07:41.875

!MESSAGE Missing host com.adobe.flexbuilder.project_0.0.0.


================End of log file================================================================= ============


I have tried deleting the .metadata folder from the workspace folder. The application still crashes.


I'm guessing that the invalid proxy ip address is causing the crash. If this is true, how can I revert the setting. If not, what is going on here?


More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points